Orbi WiFi 7 RBE973

Re: RBR850 returning "Refused to Connect"


RBR850 returning "Refused to Connect"



I have a RBR850 router with 3 satellites that I have been using for about a year. It has ip, and I have been able to access it using that ip from my web browser (mac/chrome). Today when I tried to access it, it started to return " refused to connect." message. I tried to do the same on a PC using Windows Edge as well as Chrome, but all got the same message. I restarted the router but that didn't fix the problem. Any help will be deeply appreciated.



Message 1 of 3

Re: RBR850 returning "Refused to Connect"

NG is aware of this. Seems to be working on a fix currently. 

Was your FW updated that you know of recently? 


Are you try HTTP instead of HTTPS with 


What happens if you power OFF the RBR. Disconnect it from the ISP modem, then back ON and try HTTP and 

Message 2 of 3

Re: RBR850 returning "Refused to Connect"

Thank you for the response. I'm not aware of any recent firmware updates, although I might have set it on auto update. I tried https as well but it didn't work either.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation

Orbi 770 Series