Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Orbi WiFi 7 RBE973

Losing connection on devices, whilst still being connected.


Losing connection on devices, whilst still being connected.


I’ve hard Orbi for a while now and recently had some cat 6 points installed so I could get Max speeds out of my satellites. Before the cat 6, I was getting 50% of my router speeds of 300mbs.

However, since switching to hardwire, I’m encountering problems, where one is connected to a satellite from our phones, but internet has just dropped and no apps work, and even WhatsApp just says “connecting”. The funny thing is the phone or devices will still be connected to Orbi, with the WiFi signal on top of screen. It’s easily fixed by just disconnected and reconnecting the device. That gets everything working again, but it’s happening so often and shouldn’t be.

Any reason as to why?

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 1 of 4

Re: Losing connection on devices, whilst still being connected.

You might get more/better help in the Orbi forum than the general router forum. 



Message 2 of 4

Re: Losing connection on devices, whilst still being connected.

Thank you.

Could an admin please redirect this thread to the correct forum please?
Message 3 of 4

Re: Losing connection on devices, whilst still being connected.

What Firmware version is currently loaded?
What is the Mfr and model# of the Internet Service Providers modem/ONT the NG router is connected too?



What is the size of your home? Sq Ft?
What is the distance between the router and satellite(s)? 30 feet or more is recommended in between RBR and RBS to begin with depending upon building materials when wirelessly connected.


What channels are you using? Auto? Try setting manual channel 1, 6 or 11 on 2.4Ghz and 40 to 48 channel on 5Ghz.
Any Wifi Neighbors near by? If so, how many?


Try enabling Beamforming and MIMO(MIMO may or may not be needed) and WMM. Under Advanced Tab/Advanced Settings/Wireless Settings


Try disabling the following and see:
Armor, Circle, Daisy Chain, Fast Roaming, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Set Short preamble instead of Long preamble modes. Save settings and reboot the router and satellite(s).


One User Experience/Configuration:

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 0 kudos
  • 3 in conversation

Orbi WiFi 7