×  Introducing Nighthawk RS700 WiFi 7 (BE) Router. For more details, please visit Nighthawk Tri-Band WiFi 7 Router.

Orbi RBK40 keeps rebooting and runs slowly


Orbi RBK40 keeps rebooting and runs slowly

I have been having some major issues with my RBK40 which I woud not expect after 18 or so months..  The Main Router is power cycling it's self regularly at various times of the day no set pattern.  When it is not doing this it drops connection or we get connectivity issues in terms of throughput in the house.  I have checked the firmware and its on the latest version  I have a sperate sky router in the house but they are on seperate SSID's and use different passwords.  Also this sky router has been in place for about 18 months now.  The loss of connection is not linked to any single device or seemingly caused by only one device attached to the network which has a mix of iOS, Mac OS, WIndows and Android devices but less than 30 connected in total which I would expect this device to cope with easily.  Any help is appricited before it finds a window to depart through.  For information I have set the Sky network channels to be set to remove any potential interence. 

Message 1 of 2

Re: Orbi RBK40 keeps rebooting and runs slowly

What is the Mfr and model# of the Internet Service Providers modem/ONT the NG router is connected too?


What is the size of your home? Sq Ft?
What is the distance between the router and 📡 satellite(s)? 30 feet or more is recommended in between RBR and RBS📡 to begin with depending upon building materials when wirelessly connected.
https://kb.netgear.com/31029/Where-should-I-place-my-Orbi-satellite 📡


What channels are you using? Auto? Try setting manual channel 1, 6 or 11 on 2.4Ghz and 40 to 48 channel on 5Ghz.
Any Wifi Neighbors near by? If so, how many?


Try enabling Beamforming and MIMO(MIMO may or may not be needed) and WMM. Under Advanced Tab/Advanced Settings/Wireless Settings
Not seen 


Try disabling the following and see:
Armor, Circle, Traffic Meter, Daisy Chain, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Save settings and reboot the router and satellite(s). Under Advanced Tab/Advanced Settings/Wireless Settings


One User Experience/Configuration:

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX30 Mode Mode  | Wifi Router XR500 and RBK863 Router mode | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX3/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX120v2, RAX50v2, XR450/500/700/1000, EX7500/EX7700

Message 2 of 2
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation

Orbi WiFi 6E