× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

Orbi RBK53S having blocking outgoing connections from Synology NAS

dbrewood
Guide

Orbi RBK53S having blocking outgoing connections from Synology NAS

Guys I need some help, I've recently been suffering with a problem whereby my Synology NAS (DS918+) is unable to access the internet (to update DDNS data, etc)

This has worked fine for 9 months but since the last Orbi firmware update (I think) this has been problematical. To debug the issue all network cables have been replaced and the NAS connected to various ports. If I switch back to using the British Telecom Home Hub 5 as a modem / router everything works.

Tests that synology have asked me to run give results as follows:

 

root@mynas:~# ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
64 bytes from 192.168.1.254: icmp_seq=1 ttl=64 time=0.357 ms
64 bytes from 192.168.1.254: icmp_seq=2 ttl=64 time=0.327 ms
64 bytes from 192.168.1.254: icmp_seq=3 ttl=64 time=0.423 ms
64 bytes from 192.168.1.254: icmp_seq=4 ttl=64 time=0.323 ms
64 bytes from 192.168.1.254: icmp_seq=5 ttl=64 time=0.233 ms
^C
--- 192.168.1.254 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 0.233/0.332/0.423/0.064 ms
root@mynas:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 192.168.1.254 icmp_seq=1 Destination Port Unreachable
From 192.168.1.254 icmp_seq=2 Destination Port Unreachable
From 192.168.1.254 icmp_seq=3 Destination Port Unreachable
From 192.168.1.254 icmp_seq=4 Destination Port Unreachable
From 192.168.1.254 icmp_seq=5 Destination Port Unreachable
From 192.168.1.254 icmp_seq=6 Destination Port Unreachable
From 192.168.1.254 icmp_seq=7 Destination Port Unreachable
^C
--- 8.8.8.8 ping statistics ---
7 packets transmitted, 0 received, +7 errors, 100% packet loss, time 8ms

root@mynas:~# ping www.google.com
PING www.google.com (142.250.187.196) 56(84) bytes of data.
From 192.168.1.254 (192.168.1.254) icmp_seq=1 Destination Port Unreachable
From 192.168.1.254 (192.168.1.254) icmp_seq=2 Destination Port Unreachable
From 192.168.1.254 (192.168.1.254) icmp_seq=3 Destination Port Unreachable
From 192.168.1.254 (192.168.1.254) icmp_seq=4 Destination Port Unreachable
From 192.168.1.254 (192.168.1.254) icmp_seq=5 Destination Port Unreachable
^C
--- www.google.com ping statistics ---
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 7ms

root@mynas:~# nslookup www.google.com
Server:		81.139.57.100
Address:	81.139.57.100#53

Non-authoritative answer:
Name:	www.google.com
Address: 142.250.200.36
Name:	www.google.com
Address: 2a00:1450:4009:81f::2004

root@mynas:~# nslookup www.google.com 8.8.8.8
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	www.google.com
Address: 142.250.200.36
Name:	www.google.com
Address: 2a00:1450:4009:820::2004

root@mynas:~# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  192.168.1.254 (192.168.1.254)  0.352 ms  0.392 ms  0.403 ms
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
root@mynas:~# 

As you can see outgoing connections to Google (used as a test) fail at the Orbi (192.168.1.254)

This is causing major concerns as I host a forum on the NAS and the issue takes it offline.

 

Any ideas how to fix it folks? Any assistance would be greatly appreciated. If any more information is needed please advise.

 

Thanks in advance.

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 1 of 14
Hansdampf74
Aspirant

Betreff: Orbi RBK53S having blocking outgoing connections from Synology NAS

Did you find a solution for this problem? This bothers me for more than two months now.

Message 2 of 14
dbrewood
Guide

Betreff: Orbi RBK53S having blocking outgoing connections from Synology NAS

I just posted this on Synoforum:

 

I had a call from them yesterday, they asked how things were for me with the issue. I advised that I've not had the problem for over 3 weeks now and as far as I myself was concerned the issue looked to be fixed. I did state that it was still an issue for other DSM7 users.
They advised they we're still waiting for the higher tier developers to report back (IMHO after liaising with the Bitdefender Armor team - my own opinion there). I did say I wanted the ticket to remain open until they had the information I could feedback to Synology so that the problem could properly be closed out from both sides.
At least we know now it is a Bitdefender Armor issue and I guess we need them to apply whatever fix they have made out globally?
For me it's now 23 days, 23 hours, 54 minutes since I last had to toggle Armor off / on to resolve the issue.

Message 3 of 14
FURRYe38
Guru

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Netgear has set up a community forum specifically for the Orbi AC products. Most of the people who watch that forum are more likely to have experience with Orbi and know how to work it better than those of us who follow this router forum. Might be more likely to find someone who has a solution if the question is posted there:
https://community.netgear.com/t5/Orbi/bd-p/Orbi


Please use this link to the main forum product list to review and choose where to make your posts. 
https://community.netgear.com/t5/NETGEAR-Forum/ct-p/en-netgear


Thank you.

Message 4 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Today Netgear has replied to me with:
 
As per the engineers the issue was caused by BD agent incorrectly handling some of the packets. Let us know if you have any other concerns or clarifications.
 
I have replied to them saying:
 
So does that mean the issue should be fixed for all Synology DSM7 users now? If so do you want me to check with the other users who were affected and also tell Synology? Should I be okay to go back to using LAN1 on the NAS?
 
I am waiting on their reply.

Message 5 of 14
CrimpOn
Guru

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Hard to imagine a less useful response. What is a BD agent? Did they fix the software?
Message 6 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

It was looking like the issue was with Bitdefender Armor as toggling that off / on (On the Orbi) immediately fixed the problem for me.

 

I assume BD agent is 'Bitdefender Agent' part of the RBK53S Armor system.

Message 7 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Interesting reply from Netgear:

 

As per the team it will be fixed in the next release no ETA was provided yet. Let us know if you have any other concerns or clarifications.

 

So I've gone back with:

 

So is this then an issue with each and every Orbi and the fix will be in place when the firmware is updated?

This sounds strange as the problem has not hit me four 2 weeks now with no firmware uplift. Or have support put a temporary fix in place (tied to my MAC address etc?) so it is fixed for me?

Can you please get some clarity from the higher tier as I've got at least 3 other users to advise as well as Synology.

 

It'll be very interesting to see what they come back with.

Message 8 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

A final update from Netgear:

 

I have checked this with the team and they confirmed that engineering did no change on your router. They just identified the cause and confirmed that they will address it in later firmware release that we do not have an ETA yet.

 

It seems there is no response as to why I'm no longer suffering from the issue. I have asked....


Message 9 of 14
CrimpOn
Guru

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Thanks for sharing the ongoing saga. Having never activated Armor, I wonder if there is any way to determine the 'version' of Armor.

Armor is offered on nearly every Netgear WiFi router. Other anti-virus, anti-malware applications frequently update their detection databases.  One would think that Armor would do something similar.  This might be considered independent of the router firmware.

 

 

Message 10 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Exactly, as far as I was aware the Armor system is independant to the Netgeat device and was run by Bitefender as a AI driven defensive cloud system. THis woule explain why the Bitdefender team could implement a fix for it.

To be honest I think I'm getting hit with a fair bit of BS now.

The problem does look to be fixed (for me at least), and I wanted to give a proper explanation to Synology and other affected users, but it does not look like I'll ever get any true explanation.

 

 

Message 11 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Well I got a final reply from Netgear, after this I'm giving up chasing:

 

Basing from the response I got, there was no explanation why your issue got resolved all of a sudden but they did confirmed the cause and is already working it with Bitdefender team to get it addressed. Furthermore if the issue would reoccur we can still open a new ticket and re-escalate the case to them to get an update of the fix.

Message 12 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

Well the issue has returned for me alas so I'm having to turn Armor of again I chased Netgear again ventimg much annoyance:

 

I did raise a ticket with Bitdefender (1007084068) on Thursday and I'm yet to receive a response from them.
I do understand these things can take time to resolve it is just very frustrating to have Armor as a useful defensive tool but having to disable it to allow my NAS to be fully operational and my forum to run.
I do feel that if I hadn't gone through the pain of reporting / testing this issue it'd just be ignored. It seems of the people who have reported the issue I'm the only one who has fought it through and gained any response at all.
I do wish now I'd not renewed the Armor subscription in December (when the issue seemed to be hitting me).
Anyway for now I'll leave Armor turned off and once (if) it is ever fixed I'll be looking Netgear / Bitdefender to extend my Armor subscription for the time the problem has been in place (since August last year).......
Anyway I'll continue to be as patient as I can and hope that eventually beta (or release) firmware is made available to resolve the issue.

 

They came back with:

 

This is acknowledged, once the Issue is fixed we can request for the unused Bitdefender subscription to be extended because of the Issue.
For now what we really need is just to wait for updates from both sides Bitdefender and Netgear.
I really appreciate you being patient about this. Meanwhile what I can do is to keep the case open for now since the Isssue is not yet fixed.

 

Bitdefener came back to me asking for debug / logging data and I sent on a portion of the data I had originally sent to Netgear (no reply to that yet), but I did inform Netgear support of their response. Interestingly I then got the following reply:

 

We are checking if we can provide you with the release date for the fix and if we can provide you the file you requested. Please stand by for an update.

 

Which has me intrigued.... Beta firmware maybe?

Message 13 of 14
dbrewood
Guide

Re: Orbi RBK53S having blocking outgoing connections from Synology NAS

To help resolve this issue and to force the NAS to 'reappear' in Armor I've had to make it appear as a new device so I have changed the LAN port, network IP address etc.

The NAS is now appearing as a different device type so I'm hopeful it might make a difference.

Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 1721 views
  • 1 kudo
  • 4 in conversation
Announcements

Orbi 770 Series