× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

Orbi RBR20 v2.6.1.36, bug in IPv6 over PPPoE WAN remains.

Retired_Member
Not applicable

Orbi RBR20 v2.6.1.36, bug in IPv6 over PPPoE WAN remains.

On set 14th 20 I reported a bug on IPv6 over PPPoE WAN connection cause by wrong TCPMSS / MTU afecting my Orbi RBR20 v2.5.1.16, it cause and some insights about how to fix it. On that time the same bug were present on RBR50/RBR50 v2 running v2.5.1.16 and days after in v2.5.2.4 launched on set 17th 20.

 

Since then Netgear released RBR20 v2.6.1.36 (oct 7th 20) and RBR50/RBR50 v2 v2.6.1.40 (oct 27th 20), but unfortunatly they implemented fix only for RBR50/RBR50 v2 model and didn't care about RBR20.

 

RBR20 owners, I'm very disapointed with Netgear support behavior, but how could we ask to support team "save us" too ?

 

Fix implemented on RBR50/RBR50 v2 firmware v2.6.1.40 in /etc/net6conf/6service

diff ./_RBR20-V2.6.1.36.img.extracted/squashfs-root/etc/net6conf/6service ./_RBR50-V2.6.1.40.img.extracted/squashfs-root/etc/net6conf/6service
43a44,66
> 	
> 	wan_type=`$CONFIG get wan_proto`
> 	if [ "x$wan_type" = "xpppoe" ]; then
> 		wan_mtu=`$CONFIG get wan_pppoe_mtu`
> 	elif [ "x$wan_type" = "xl2tp" ]; then 
> 		wan_mtu=`$CONFIG get wan_l2tp_mtu`
> 	elif [ "x$wan_type" = "xpptp" ]; then
> 		wan_mtu=`$CONFIG get wan_pptp_mtu`
> 	elif [ "x$wan_type" = "xmulpppoe1" ]; then
> 		wan_mtu=`$CONFIG get wan_mulpppoe_mtu`
> 	else
> 		if [ "x$w6_type" = "xpppoe" ];then
> 			dhcp_mtu=`$CONFIG get wan_dhcp_mtu`
> 			wan_mtu=$(($dhcp_mtu-8))
> 		else
> 			wan_mtu=`$CONFIG get wan_dhcp_mtu`
> 		fi
> 	fi
> 
> 	#for 6to4 and 6rd, the header still have ipv4  
> 	if [ "x$w6_type" = "x6d" -o "x$w6_type" = "x6to4" ];then
> 		wan_mtu=$(($wan_mtu - 20))
> 	fi
54a78
> 	printf '\tAdvLinkMTU %s;\n' "$wan_mtu"

@Dustin_V 
@Blanca_O 

 

PS:

binwalk was used to unpack firmware images.

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 5

Accepted Solutions
Retired_Member
Not applicable

Good news, NG fixed it on RBR20 v2.6.2.104

Finally NG published the /etc/net6conf/6service with the fix on RBR20 V2.6.2.104

 

Thanks @Dustin_V  and @Blanca_O 

View solution in original post

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 4 of 5

All Replies
FURRYe38
Guru

Re: Orbi RBR20 v2.6.1.36, bug in IPv6 over PPPoE WAN remains.

Sonething to keep in contact with NG support. Nothing we can do here in the forums. 

 

Good Luck. 

Message 2 of 5
Retired_Member
Not applicable

Re: Orbi RBR20 v2.6.1.36, bug in IPv6 over PPPoE WAN remains.

Unfortunately, when I typed router serial number I was informed that my hardware is under warranty, but my 90 days complementary technical support has ended, so I'm unable to open a ticket on NG support.

Smiley Sad

Message 3 of 5
Retired_Member
Not applicable

Good news, NG fixed it on RBR20 v2.6.2.104

Finally NG published the /etc/net6conf/6service with the fix on RBR20 V2.6.2.104

 

Thanks @Dustin_V  and @Blanca_O 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 4 of 5
Retired_Member
Not applicable

Orbi RBR20 v2.6.2.104, bug in IPv6 over PPPoE WAN was finally fixed .

Finally NG published the /etc/net6conf/6service with the fix on RBR20 v2.6.2.104

 

Thanks @Dustin_V  and @Blanca_O 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 1088 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi 770 Series