× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

Orbi RBR40 Lost Power & Will Not Reconnect to Modem

FURRYe38
Guru

Re: Orbi RBR40 Lost Power & Will Not Reconnect to Modem

Corrupted? 

What browser did you use to download the FW file? 

You did unpack the .zip file after you downloaded the RBR file correct? 


@Ben8 wrote:

No luck.  I downloaded the firmware from the Netgear website for the RBR40 model i have, but it says the files are corrupted.  Guess Netgear will get their way, and extort me out of $90.  I'm off to pay for a support package now.

 

Thanks to all for the suggestions!


 

Message 26 of 32
Ben8
Guide

Re: Orbi RBR40 Lost Power & Will Not Reconnect to Modem

I used Google Chrome. I’ve been on the phone and in a remote session with Netgear support for an hour and a half and they could not get it to work either. They had the same issue with the firmware files not downloading properly, so they’re sending me a new router and refunding me the support package expense.

Who knows how long it will take, so thank god for the phone hot spot.

Thanks again for the help!
Message 27 of 32
plemans
Guru

Re: Orbi RBR40 Lost Power & Will Not Reconnect to Modem

Glad your getting it replaced!

Message 28 of 32
FURRYe38
Guru

Re: Orbi RBR40 Lost Power & Will Not Reconnect to Modem

I recommend NOT using Chrome for doing any FW updates. Use Edge, Firefox if you do any FW updates for FW file downloads. 

Glad that it's getting replaced. 


@Ben8 wrote:
I used Google Chrome. I’ve been on the phone and in a remote session with Netgear support for an hour and a half and they could not get it to work either. They had the same issue with the firmware files not downloading properly, so they’re sending me a new router and refunding me the support package expense.

Who knows how long it will take, so thank god for the phone hot spot.

Thanks again for the help!

 

Message 29 of 32
vajim
Master

Re: Orbi RBR40 Lost Power & Will Not Reconnect to Modem


@FURRYe38 wrote:

I recommend NOT using Chrome for doing any FW updates.

 

thanks for your recommendation 

 

however when I did  update chrome worked just fine. 

 


 

Message 30 of 32
BoilerPlate
Apprentice

Re: Orbi RBR40 Lost Power & Will Not Reconnect to Modem

vajim< User Beware. Smiley Sad

Message 31 of 32
vajim
Master

Re: Orbi RBR40 Lost Power & Will Not Reconnect to Modem


@BoilerPlate wrote:

vajim< User Beware. Smiley Sad


Hey it's my friend again who insists on personal attacks.  Hold on and we'll get the moderators over here 

Message 32 of 32
Top Contributors
Discussion stats
  • 31 replies
  • 3540 views
  • 7 kudos
  • 5 in conversation
Announcements

Orbi 770 Series