×

Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Orbi WiFi 7 RBE973
Reply

Re: Orbi RBR50 Interface doesn't save Device Model or Device Type

munkeyjooce
Follower

Orbi RBR50 Interface doesn't save Device Model or Device Type

I have noticed that when you select a Attached Device in the list and try to set the details, the only thing that reliably gets changed is the Device Name. Both the Device Model and Device Type seem to never change to what you set them. Most of the time they just reset to default ('---' and Network Device) The Orbi app is no better. It is even missing the Device Model (way to go for consistency Netgear). The icon (Device Type) always revers back to Network Device. Is there are reliable way to set the Device Model and/or the Device Type? Orbi Router Firmware: V2.3.5.30
Message 1 of 6
CrimpOn
Guru

Re: Orbi RBR50 Interface doesn't save Device Model or Device Type

The web interface on 2.3.5.30 always works for me, except when I forget to click on the "Apply" button.  The 2.5.0.38 firmware (that was pulled) was reported to fail miserably (be unusable).  I never updated to that version, so I have no first hand knowledge.

Message 2 of 6
pablohoney
Luminary

Re: Orbi RBR50 Interface doesn't save Device Model or Device Type

This is a known and annoying issue.  Netgear have acknowledged it to me and a new firmware is in QA testing at the moment whcih is meant to address this issue with a release imminent if QA is passed.

Message 3 of 6
FURRYe38
Guru

Re: Orbi RBR50 Interface doesn't save Device Model or Device Type

Has a factory reset and setup from scratch been performed since last update?

What browser are you using? Same thing happens in IE11, Firefox or Opera?

 


@munkeyjooce wrote:
I have noticed that when you select a Attached Device in the list and try to set the details, the only thing that reliably gets changed is the Device Name. Both the Device Model and Device Type seem to never change to what you set them. Most of the time they just reset to default ('---' and Network Device) The Orbi app is no better. It is even missing the Device Model (way to go for consistency Netgear). The icon (Device Type) always revers back to Network Device. Is there are reliable way to set the Device Model and/or the Device Type? Orbi Router Firmware: V2.3.5.30

 

Message 4 of 6
tomschmidt
Virtuoso

Re: Orbi RBR50 Interface doesn't save Device Model or Device Type

I had this same issue when I first upgraded to v2.3.5.30. I suggest saving your settings, then performing a factory reset.  Manually configure the router again enough until you can restore your settings.

 

Do not upgrade to v2.5.0.38 or v2.5.0.40 releases, as this release is even worse for device naming and has been pulled from the release tree by NG.

 


@munkeyjooce wrote:
I have noticed that when you select a Attached Device in the list and try to set the details, the only thing that reliably gets changed is the Device Name. Both the Device Model and Device Type seem to never change to what you set them. Most of the time they just reset to default ('---' and Network Device) The Orbi app is no better. It is even missing the Device Model (way to go for consistency Netgear). The icon (Device Type) always revers back to Network Device. Is there are reliable way to set the Device Model and/or the Device Type? Orbi Router Firmware: V2.3.5.30

 

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 5 of 6
FURRYe38
Guru

Re: Orbi RBR50 Interface doesn't save Device Model or Device Type

I believe v34 is working FW for device naming...

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 887 views
  • 1 kudo
  • 5 in conversation
Announcements

Orbi WiFi 7