×  Introducing Nighthawk RS700 WiFi 7 (BE) Router. For more details, please visit Nighthawk Tri-Band WiFi 7 Router.

Re: Problem updating firmware on add-on Orbi satellite


Problem updating firmware on add-on Orbi satellite

I have an add-on satellite (RBS 50) that has never given me trouble until I went to manually update the firmware on my router and two satellites. All went well with the router and orginal satellite, but something went wrong with the add-on. When i check the firmware status I get:


Model NameDevice NameCurrent VersionStatus
RouterRBR50RBR50V2.1.1.12No new firmware version available.
SatelliteRBS50Orbi Satellite-1V2.1.1.12No new firmware version available.
SatelliteRBS50Orbi Satellite-2V2.0.0.74No Internet


The add-on satellite is listed as "Orbi Satellite-2" in the table above, with the old firmware version and the notation "No Internet." So I reset the satellite, powered it up, synched it with the router following the add-on satellite instructions, got a solid blue light from the satellite, and still that table indicates: "No Internet." When I try to again update the firmware manually, the admin name and password that work for the router do not work.I even tried the network name and password on the bottom of the add-on satellite (which don't match the network name and password), but that didn't work either (of course). I cannot access the satellite to upgrade the firmware. Any idea or suggestions as to what is wrong and how I got about fixing it?


Thank you in advance for any assistance you may be able to provide.

-- Candace


Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 4

Re: Problem updating firmware on add-on Orbi satellite

Same problem here with RBS40.

Model NameDevice NameCurrent VersionStatus
RouterRBR40RBR40V2.1.1.16No new firmware version available.
SatelliteRBS40Orbi Satellite-1V2.0.0.56No Internet
SatelliteRBS40Orbi Satellite-2V2.1.1.16No new firmware version available.


Tried the following:

1) Moving Satellite closer to the router.  

2) Factory Reset of Satellite.

3) Reboot of Router.

4) Manually updating firmware - gave me an invalid firmware error message.

5) Reboot of the Satellite about half a dozen times.


Nothing has corrected the problem.  Please advise.

Message 2 of 4

Re: Problem updating firmware on add-on Orbi satellite

I had this problem as well.  What worked for me was a simple reboot of the main router and then going through the connection process of Router to Satellite.  Once I did that, when I went back to the firware update screen it located the new version.  This was for my move to from


Also, possible to factory reset the satellite so it is as new to again add to the network?

Message 3 of 4

Re: Problem updating firmware on add-on Orbi satellite

I had the same problem with one satellite refusing to authenticate (the other one was fine), but it worked after I updated the router.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 2 kudos
  • 4 in conversation

Orbi WiFi 6E