× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

RBK50 and Apple AirPlay

velociti
Tutor

RBK50 and Apple AirPlay

I have the RBK50 system hooked up to my Hegel H360 integrated amplifier-DAC via Ethernet. As others seem to have found, trying to use AirPlay is beyond hit-or-miss on default settings. I can only stream from my iPhone or MacBook Pro for a couple of minutes before it cuts out and I have to manually reconnect. Per some others' suggestions, I did change the CTS/RTS treshold to 2346 (from default 2347), and also turned off WMM on both 2.4 and 5 GHz. This seemed to fix the issue! Except it murders my Wi-Fi speeds. The difference between WMM enabled (150/450) and disabled (13/20) is absurd. MU-MIMO and beamforming are both enabled, for what it's worth. Is there a definitive answer for how to get usable AirPlay connectivity and the fast Wi-Fi speeds that I purchasing this thing for? 

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 1 of 5
guzzijason
Apprentice

Re: RBK50 and Apple AirPlay

 Disabling WMM is abosolutely going to kill your speeds, as 802.11n and 802.11ac protocols require its use. By disabling WMM, you are effectively disabling thoe protocols on the router, and your devices are going to connect using other protocols at much slower rates. There's really nothing Netgear can do about that.

 

As for the AirPlay thing, I've been streaming from iTunes to a stereo attached to an AirPort Express (all wirelessly - no ethernet) for a couple hours today with no real problems noticed so far. I'm on firmware V2.0.0.76, with WMM enabled, but beamforming and MU-MIMO are both disabled (the last two were off by default when I originally set up the Orbi, and I figured there was probably a reason for that, so I never bothered to enable them).

Message 2 of 5
helmoot
Initiate

Re: RBK50 and Apple AirPlay

I have had a similar problem.  I have been working with support.  They provided a few solutions but they did not resolve the issue.  I had to go back to an old router.  I do have the Orbi in AP mode.  I dusted off an old WiFi AP and connect the AirPlay devices to it.  The connection of iPhone and iTunes on Orbi over the networ through two APs is better and more reliable than everything running on the Orbi.  Not good.  One of the whole reasons for getting the Orbi.

 

Support told me there is a firmware fix in progress but no timeframe, which most likely means there is nothing coming.

Message 3 of 5
FURRYe38
Guru

Re: RBK50 and Apple AirPlay

Try disabling some of these options:

Beamforming, MIMO, Daisy Chain and Fast Roaming. 

 

Ensure 20/40Mhz Coexistence is enabled. Some older Apple devices needs 20Mhz. 


@helmootwrote:

I have had a similar problem.  I have been working with support.  They provided a few solutions but they did not resolve the issue.  I had to go back to an old router.  I do have the Orbi in AP mode.  I dusted off an old WiFi AP and connect the AirPlay devices to it.  The connection of iPhone and iTunes on Orbi over the networ through two APs is better and more reliable than everything running on the Orbi.  Not good.  One of the whole reasons for getting the Orbi.

 

Support told me there is a firmware fix in progress but no timeframe, which most likely means there is nothing coming.


 

Message 4 of 5
FURRYe38
Guru
Top Contributors
Discussion stats
  • 4 replies
  • 3645 views
  • 2 kudos
  • 4 in conversation
Announcements

Orbi WiFi 7