×

Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Orbi WiFi 7 RBE973
Reply

RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Blanca_O
NETGEAR Moderator

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Hi, All, 

 

Firmware file for RBS50 V2.7.3.22 should be fixed now

 

https://kb.netgear.com/000063811/RBR50-RBS50-Firmware-Version-2-7-3-22

 

Regards,
Blanca
Community Team

Message 26 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Thank you. 

Message 27 of 66
evilcougar
Aspirant

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

After this upgrade, on top of the bugs already mention, also noted the following:

- Under Advanced -> Advanced Setup ->  Web Services Management.

All the Remote Management options have disappeared. Has this been removed intentionaly I wonder.

 

- Also noted in orbi app (for IOS), under Settings -> Anywhere Access" "Out-Of-Home Controls" turned itself back on, I had this turned off before upgrade. That to me is a major concern, do we have to check every setting each time we do an upgrade now!!!

 

- Along with the other known bugs that have not been addressed, as mentioned in this thread.

 

Is Netgear going to take software upgrades more seriously in future? The constant simple QA oversights, ie mismatch firmware, changing configuration, not addressing major bugs etc are starting to get tiresome.

 

Seriously, unless there are some assurances there will be better QA before releasing software updates, and addressing bugs in a timely manner, I'm just going to buy another router from somewhere else.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 28 of 66
Lyth
Guide

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Wonder if or when they will ever fix the access control problem with it spontaneously blocking devices which has carried through numerous firmware revisions now.

Message 29 of 66
svetaketu
Luminary

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Hi @Lyth,

Are there any specific devices that is affected by the access control problem you mentioned?

Sorry, you may have mentioned it in another thread that I haven't read.

Message 30 of 66
tagteam
Virtuoso

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect


@evilcougar wrote:

- Also noted in orbi app (for IOS), under Settings -> Anywhere Access" "Out-Of-Home Controls" turned itself back on, I had this turned off before upgrade. That to me is a major concern, do we have to check every setting each time we do an upgrade now!!!


That is, indeed, odd. I just checked my Orbi app (iOS) and that setting is still turned off; nothing else appears to have changed with the update.

Message 31 of 66
Lyth
Guide

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect


@svetaketu wrote:

Hi @Lyth,

Are there any specific devices that is affected by the access control problem you mentioned?

Sorry, you may have mentioned it in another thread that I haven't read.


We use access control set to block all new devices to keep the kids from changing their MAC addresses to bypass the Circle parental controls.  There have been a number of firmwares over the past year, year and a half, that it will work as expected for a while then start switching a device here and there from allowed to blocked.  You can unblock them but the problem then starts getting worse to the point ALL devices no matter what they are become blocked.  You can switch them back to allowed in the app but it will change back to blocked quickly.  It's completely unusable.  I've posted in a few threads over time where other people have experienced the same thing.  I'm hesitant to try any firmware at this point because it is working without access control on and I had an automatic firmware update pushed last fall or winter that bricked my router.  There was no recovering it whatsoever with any method and I had to purchase a used one off Amazon.

Message 32 of 66
alokeprasad
Mentor

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Please post the release notes here.

 

Not that it'll be very useful beyond "Security fixes".

It is getting tedious to slog through the bulletins on NETGEAR Product Security and decode on whats new in any firmware release ...

 

Message 33 of 66
CrimpOn
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect


@evilcougar wrote:

After this upgrade, on top of the bugs already mention, also noted the following:

- Under Advanced -> Advanced Setup ->  Web Services Management.

All the Remote Management options have disappeared. Has this been removed intentionaly I wonder.


I just now installed v2.7.3.22 on my spare Orbi RBR50. Web Services  Management appears as it always  has. (see attached image). With only one device connected to this Orbi (my Double NAT test bed), I have not noticed any other changes.

 

Continue to be amazed that people can install the exact same firmware on Orbi routers and wind up with different settings.

Message 34 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Some users may need a factory reset and setup from scratch if they encounter odd problems like browser items missing or not appearing. 

Be sure to clear out all browser caches before entering the RBRs web page.

 

Try a different browser as well. 

Most cases this isn't a FW issue. 

Message 35 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

can find release notes here or on NG download site as well:

https://community.netgear.com/t5/Orbi/New-RBK50-53-Series-Firmware-Version-2-7-3-22/m-p/2113656/high...

 

There also included in the FW .zip file as well. 


@alokeprasad wrote:

Please post the release notes here.

 

Not that it'll be very useful beyond "Security fixes".

It is getting tedious to slog through the bulletins on NETGEAR Product Security and decode on whats new in any firmware release ...

 


 

Message 36 of 66
evilcougar
Aspirant

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

After reading the replies, looks like I'll have to do a factory reset. Will do that later today.

Thanks all for the good replies and comments, I normally would not post, and I know I've probably sent the original post off on a tangent, but I was just getting frustrated after satellite firmware install error, we are in lock down over here emotions are running high at the moment. Smiley Happy

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 37 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Be sure to save off a back up configuration to file for safe keeping. Saves time if a reset is needed.
https://kb.netgear.com/000062080/How-do-I-back-up-the-configuration-settings-on-my-Orbi-WiFi-System

I recommend doing a base back up configuration file. One with just the basics setup. Then if you want to enable Access Controls, Armor, Circle ,Traffic Meter and such then do another that includes all that. 

Message 38 of 66
CrimpOn
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect


@CrimpOn wrote:

I have not noticed any other changes.

It appears that Enable Telnet is no longer an option.on the Debug page.  The Orbi router still does not accept telnet connections by default. (nor ssh - never has).

My plan was to see if that hack that gets Attached Devices to sort on every column (name, IP, MAC, host, etc.) still works.  Guess our days of poking around in the router are over.

Message 39 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Following Orbi AX...

Message 40 of 66
CrimpOn
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect


@FURRYe38 wrote:

Following Orbi AX...


Yes.  One can imagine truly automatic firmware updates may be next.

 

It is not a tradegy, but does raise the question, "do I stop here? switch to Voxel? or...."

Message 41 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Users choice. Smiley Wink

Message 42 of 66
ChuckieCheese
Luminary

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Does 2.7.2.104 (Last Updated:02/02/2021) still have Telnet enabled and SSID separation? This is the previous version right before 2.7.3.22

 

I am just looking for the latest stable firmware that still have telnet and SSID separation. My RBR50 is currently on 2.5.24

Message 43 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

v104 doesn't support telnet. 

Message 44 of 66
ChuckieCheese
Luminary

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

Thanks, @FURRYe38 .

 

Do you know which is the last firmware where telnet stopped working? I tried to search in the forum but couldn't find it. I know my current version (2.5.24) still have telnet working.

Message 45 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

IF your system is working for you on that version, probably best to keep it. 

Message 46 of 66
CrimpOn
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect


@ChuckieCheese wrote:

Does 2.7.2.104 (Last Updated:02/02/2021) still have Telnet enabled and SSID separation? This is the previous version right before 2.7.3.22

 

I am just looking for the latest stable firmware that still have telnet and SSID separation. My RBR50 is currently on 2.5.24


I am pretty sure that 2.7.2.104 has telnet on the debug page.  It is the very latest (2.7.3.22) that eliminated the telnet option.

As to the latest version to support separate SSID's, I have no idea.  I've never had a reason to do that and have not kept up with what is probably the longest running discussion on the forum.

Message 47 of 66
FURRYe38
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

OK I thought v104 didn't. My mistake. I might have been thinking about that beta that they gave out to some of us. 


@CrimpOn wrote:


I am pretty sure that 2.7.2.104 has telnet on the debug page.  It is the very latest (2.7.3.22) that eliminated the telnet option.

As to the latest version to support separate SSID's, I have no idea.  I've never had a reason to do that and have not kept up with what is probably the longest running discussion on the forum.


 

Message 48 of 66
SLK-Purdue
Luminary

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect

I just woke up to an unwanted auto-update to v2.7.3.22.   I will happily update the Attached Device sorting mod but, WTF, Telnet is not available!!   This makes no sense.   At the moment, I think I am going back to a previous version but concerned that will auto-update again.   This is VERY frustrating.  The power of TELNET and nvram changes is the reason I purchsed NG equipment to begin with.

 

Scott

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 49 of 66
CrimpOn
Guru

Re: RBS50 issues with Firware V2.7.3.22 - Firmware incorrect


@SLK-Purdue wrote:

I just woke up to an unwanted auto-update to v2.7.3.22.   I will happily update the Attached Device sorting mod but, WTF, Telnet is not available!!   This makes no sense.   At the moment, I think I am going back to a previous version but concerned that will auto-update again.   This is VERY frustrating.  The power of TELNET and nvram changes is the reason I purchsed NG equipment to begin with.


I put v2.7.3.22 on a spare Orbi. When I discovered telnet was gone, I spent hours and hours looking for a way to replace Netgear's Attached Devices - without success.  It is easy to take apart the img file, use unsquashfs to create the file system, replace Attached Devices, use mksquashfs to put it back together again. But I have found no way to rebuild the img file.  Have also tried emulating Voxel's method of getting Netgear's GPL source, replacing Attached Devices, and compiling. But the compile fails.

 

If mine silently updates to 2.7.3.22, I will probably move to Voxel's version.

Message 50 of 66
Top Contributors
Discussion stats
  • 65 replies
  • 6831 views
  • 4 kudos
  • 13 in conversation
Announcements

Orbi WiFi 7