× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

Random ARP Problems w/WiFi nodes

dfilip
Guide

Random ARP Problems w/WiFi nodes

Dear Netgear Community,

 

I have noticed random and sporadic WiFi / ARP problems on my network, usually after something reboots.  However, the problems seem to always clear up after a while, and I'm wondering if this is "normal"?

 

My configuration is that I have an Orbi (I believe) RBR40 with 2x RBW30 satellites, connected to a BR500 router -- so yes, two (2) routers -- connected as:

 

[Cable Modem] <- Ethernet -> [BR500 Router] <- Ethernet -> [Orbi RBR40] & [2x Orbi RBW30]

 

(I don't think the connection between the Cable Modem and the Orbis matters, since my problem is only on WiFi, but am including it for completeness)

 

This gives me two (2) subnets, 192.168.1.0/24 on Ethernet, and 10.0.1.0/24 on WiFi.

 

I have a noticed a sporadic problem on both my Macs (which are connected via both Ethernet and WiFi simultaneously) and various Raspberry Pis (I have about a dozen), whereby I can ping certain WiFi nodes, but not others, and inconsistently.

 

So for example, an incident from just yesterday:

 

1. Mac A is connected to both Ethernet and WiFi

2. Mac B is connected to both Ethernet and WiFi (and yes, same WiFi!)

3. Raspberry Pi A is connected via WiFi

4. Raspberry Pi B is connected via WiFi

 

So this is what I was seeing:

 

Mac A cannot ping RPi A, but can ping RPi B on the same WiFi network

Mac A can ping the WiFi router (10.0.1.1)

 

Mac B can ping both RPi A and RPi B, and the WiFi router (10.0.1.1)

 

RPi A can ping Mac A, Mac B, RPi B and the WiFi router (even tho Mac A cannot ping it)

RPi B can ping Mac A, Mac B, RPi A and the WiFi router

 

I have verified that Mac A has the correct IP for RPi A, but an 'arp -a' shows the IP for RPi A as 'incomplete'.  However, it is not a typo RPi A can ping Mac A, and an 'arp -a' on the RPi shows the MAC address of Mac A (not to confuse MAC with Mac!).

 

So the question is what causes an 'incomplete' ARP entry on the Mac A for RPi A?  If I delete the entery (arp -d), and then try another ping, it adds another 'incomplete' entry.

 

And if I wait a while (guesstimate is usually 30 - 60 minutes), Mac A can then ping and connect to RPi A.

 

In this particular case, Mac A was recently rebooted when this happened.  If I have to reboot the Orbi router, large parts of my WiFi network can't talk to each other for a while -- usually an hour or two -- and I have various groups of WiFi nodes that can talk to others, but not all WiFi nodes until I wait a while (hour or two), after which everytying seems to eventually come back.  We occasionally get power glitches where I live, so this is something that I experieince.

 

So before someone says this a a problem with Macs, I've also seen the same problem with Raspberry Pi nodes -- who can ping some other WiFi nodes, but not all -- which usually clears up after a while, and usually after something was rebooted.  And when this happens, an 'arp -a' on the RPis usually shows 'incomplete' for the nodes that don't work (even though all nodes can ping the router @ 10.0.1.1).

 

I should note that I have between 50 - 55 WiFi nodes (Macs, RPis, NEST thermostats and smoke alarms, Fire tablets, iPhones, etc.) on my network, most of which have assigned IPs in the Orbi.

 

So I understand what is happening -- the ARP tables translate IPs to MAC addresses, and the MAC address is requred to be complete and accurate to send a packet -- but what could be causing the 'incompletes' in the ARP table?

 

So my ignorance is in not fully understand the complexities of ARP and how it works, and whether it is "normal" for a 50+ node WiFi network to have delays in finding other nodes after a reboot or power outage?  My (probably flawed) understanding was that the routers built the ARP tables from the nodes that connected to them, and answered ARP requests from the nodes to which they were connected, but in reality, I've never really worried about it much before, and would have accepted the explanation of "it's just magic" ... 😉  Years ago, I do remember having to "increase the size of the ARP table" on a router, when had too many nodes, but I understand that the Orbis should be able to handle many more than 50 - 55 nodes.

 

So if you've read this far and have't given up - thank you! - and if you have any feedback for me, any and all suggestions or advise would be appreciated.

 

Also, no errors in the Orbi logs (I just see lost of entries for port triggering, which is expected).  So no ARP attackes or anything like that.

 

Thanks,

 

Dave.

 

 

 

 

 

 

 

 

 

 

 

 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 7
FURRYe38
Guru

Re: Random ARP Problems w/WiFi nodes

What is the size of your home? Sq Ft?
What is the distance between the router and satellite(s)? 30 feet is recommended in between them to begin with depending upon building materials when wirelessly connected.

 

What channels are you using? Auto? Try setting manual channel 1, 6 or 11 on 2.4Ghz and any unused channel on 5Ghz.
Any Wifi Neighbors near by? If so, how many?

 

Try enabling Beamforming and MIMO(MIMO may or maynot be needed) and WMM. Under Advanced Tab/Advanced Settings/Wireless Settings

Try disabling the following and see:
Armor, Circle, Daisy Chain, Fast Roaming, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Save settings and reboot the router and satellite(s).

 

Is the Orbis wifi the only wifi running or is the wifi on the 1st router running as well? 

Has a factory reset and setup from scratch been performed since last update? 

 

Message 2 of 7
dfilip
Guide

Re: Random ARP Problems w/WiFi nodes

Thanks for the quick reply!

 

I live in a modest condo, 2x floors each roughly 20x40 ft, and a basement.  The main router is on the 2nd floor, with one satellite on the first floor roughly beneath it and about 10 ft to one side, and the second satellite is also on the first floor, roughly 20 ft away from the first satellite.  I then have several nodes (Raspberry Pis) in the basement almost directly below the second satellite, which seem to be the most trouble w/r/t 'incomplete' ARP, although I've had troubles with nodes on the first floor as well, and on more rare occasions the second floor (the latter usually after a power hit, which may happen a few times during the summer).

 

FWIW - BOTH RBW30 satellites are connected to the RBR40, and are NOT daisy-chained to each other, and the Backhaul status always says 'Good' for both.  I installed second satellite primary to try to insure good coverage in the basement.

 

There is another 2.4 GHz WiFi router on my 2nd floor, not too far from the RBR40, which I've set up for my step-daughter for security reasons (maybe about 20 feet away from the RBR40, which is also plugged into the BR500, so that she doesn't have access to the rest of my network through firewall rules -- not that I don't trust her per se, but I don't trust her not to visit nefarious sites and click on nefarious e-mails).  The NETGEAR BR500 router does not have any WiFi capabilities, and I do not have a WiFi router from the cable company.

 

However, there are "default cable" WiFi networks on both sides of my condo, and in several other attached units ... and by "default cable" I mean what you get free from the cable company, and not anything fancy (i.e., no extenders, no other meshes, etc., which I feel fairly confident about, because these are mostly older folks to come to me when they have IT questions, and I have been in most of their homes).

 

I have about a dozen or so WiFi networks that I can "see" on my 2nd floor Mac that is not far from the RBR40 with 3 or 4 bars (semi-circles?  ie., relatively strong singnal), and I definitely suspect WiFi saturation to be a likely culprit.  You've given me a few Advanced settings to try tweaking -- I currently have all defaults because I didn't want to mess with settings that I didn't fully understand -- so given this description, what settings do you think will most likely have a positive effect?

 

Again, I have about 50+ devices, including NEST thermostats and smoke alarms, about a half dozen Macs, about a dozen Raspberry Pis, a couple cell phones, and a few tablets.  The WiFi network is fairly stable, except when something gets rebooted, and then it sometimes takes other nodes some time to find it's MAC (ARP response).  Pinging from my 2nd floor Mac to a basement Raspberry PI is generally 10 - 20 ms, with an occasional 50 - 100 ms response (when I've run tests and ARP tables are populated, maybe 1% or less of pings to a basement RPi are > 25 ms, but always < 150 ms).

 

I thought Auto for channel might be the best option, since -- I thought -- it lets the router decide which are the best channels to use, but let me know which -- given that you know more about my configruation -- settings are most likely to provide benefit.  Or should I just start experimenting and see what makes a difference?

 

Thanks again,

 

Dave.

 

 

 

Model: RBW30|Orbi AC2200 Tri-band WiFi Add-on Satellite
Message 3 of 7
FURRYe38
Guru

Re: Random ARP Problems w/WiFi nodes

What happens if you turn OFF both RBWs and just use the RBRs wifi.

 

10-20 feet is too close for the RBWs to the RBR. 30 feet is recommended in between them to begin with depending upon building materials when wirelessly connected.

Message 4 of 7
dfilip
Guide

Re: Random ARP Problems w/WiFi nodes

Interesting ... so I may be over-saturating the mesh?  The "second" RBW30 satellite is probably at least 30 feet away from the RBR40 "diagnionally" going through a wood frame floor.  The first one is probably closer to about +/- 20 ft, so let me first try uplugging that one and see what happens.

 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 5 of 7
FURRYe38
Guru

Re: Random ARP Problems w/WiFi nodes

If the RBWs are placed too close to the RBR, then the wifi over lap is too much and yet, over saturation could be a factor. You kind of have to find the sweet spot. 30 Feet seems to be a good starting point. Depending of course on building materials. 

 

I would first test the RBR alone and see if you notice bad behavior, then graduate adding 1 RBW. Then check again. 

Message 6 of 7
CrimpOn
Guru

Re: Random ARP Problems w/WiFi nodes

What a fascinating situation.  50+ devices on an Orbi network should not be excessive.  There are users on the forum reporting 100+ devices.  The only thing that appears "unusual" in the setup is having computers connected to both routers simultaneously.  I have no clue how a computer connected to two networks would perform arp requests.  i.e. would it send them out both initerfaces, or be 'smart enough' to recognize that it has to be on one subnet?  (Macs are smart, so that's probably not it?)  As an experiment, the Mac that is displaying the problem would be disconnected from the ethernet router.  Restart and see what happens.

 

In a brief internet search, this topic from Cisco showed up: https://networkengineering.stackexchange.com/questions/50843/what-are-the-reasons-for-seeing-an-inco...

Notice that "incomplete" appears to mean "not received", rather than what I assumed ("got part of it, but not all of it.")

At the very bottom of the thread, there was mention of having arp problems when some devices have a different subnet mask than others.  If everybody gets IP's through DHCP, then they should all have the same subnet mask.  Do they?

 

My "go to" tool for issues like this is Wireshark.  The Orbi can be set up to capture all LAN traffic to a file, which can be downloaded to a computer and searched for arp requests.

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 3291 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi 770 Series