×

Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Orbi WiFi 7 RBE973
Reply

Re: Satellite showing up as connected device, unknown connection type

toddinpal
Aspirant

Satellite showing up as connected device, unknown connection type

So I'm trying to set up a new RBR50/RBS50.  After being set up, they needed a firmware update (don't recall from version or to version), and from then on the satellite couldn't connect.  I upgraded and downgraded the firmware on each device and they are both at version v2.5.1.16.  The satellite cycles between purple light and blue light.  The router sees the satellite as a connected device and not a satellite as shown in the attached image.  How do I get them to communicate properly and show the satellite as a satellite?

 

-tl

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 1 of 6
Mstrbig
Master

Re: Satellite showing up as connected device, unknown connection type

Try Rebooting the RBR50 and factory reset the RBS50 and reconfigure.

Message 2 of 6
toddinpal
Aspirant

Re: Satellite showing up as connected device, unknown connection type

Been there, done that, multiple times.

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 3 of 6
Mstrbig
Master

Re: Satellite showing up as connected device, unknown connection type

Did you try this on the satellite, as they tend to be stubborn sometimes?
Turn off satellite, hold down the reset button, power up the satellite while holding down the reset, do not let go of the reset until you see the power light turns red, then let go.
Message 4 of 6
toddinpal
Aspirant

Re: Satellite showing up as connected device, unknown connection type

Yes, I tried that form of reset.  As I mentioned before I also tried a 30-30-30 reset.  I'll try several more times, but this seems a bit absurd.

 

-tl

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 5 of 6
FURRYe38
Guru

Re: Satellite showing up as connected device, unknown connection type

Try updating FW to v4:

https://community.netgear.com/t5/Orbi/RBK50-Firmware-Version-2-5-2-4/m-p/1960919/highlight/true#M100...


@toddinpal wrote:

Yes, I tried that form of reset.  As I mentioned before I also tried a 30-30-30 reset.  I'll try several more times, but this seems a bit absurd.

 

-tl


 

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 1402 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 7