×

Introducing the Orbi 970 Series Mesh System with WiFi 7(BE) technology. For more information visit the NETGEAR Press Room.

Orbi WiFi 7 RBE973
Reply

Re: Slow WiFi speeds

PlatinumGoat
Apprentice

Slow WiFi speeds

Hi everyone,
I recently upgraded my broadband speed to 1gbps.
Although I can achieve around 900mbps up/down with a direct cable connection to the router, I only managed to get around 400 plus mbps from the router over WiFi (just a few feet away) and 300 plus mbps from the satellite (also a few feet away). Is this normal? The orbi iPhone app says link rate is 866mbps. Please advice. Thanks.
Model: RBR50| Orbi AC3000 Tri-band WiFi (Router Only)
Message 1 of 4

Accepted Solutions
FURRYe38
Guru

Re: Slow WiFi speeds

Yes you can disable Daisy Chain, if your on v210, put a check mark in the Daisy Chain box. Users have said v210 seems to work in reverse on this version of FW. 

 

Yes, Enable Beamforming. If you have MIMO supporting devices MIMO can be enabled. If, not, keep it disabled. Leave CTS values if your not having problems with devices connecting to the Orbi wifi. 


@PlatinumGoat wrote:

Thanks for the reply. I however find it strange that official tech support from NG find my speeds too slow. If not, they wouldn't recommended several changes like turning daisy chain off (I only have one satellite), turning on implicit beam forming, turning on mu-mimo and also adjusting the CTS/RTS to 2307 instead of 2347. What do you think?


 

View solution in original post

Message 4 of 4

All Replies
st_shaw
Master

Re: Slow WiFi speeds

Pretty normal and excellent performance. The maximum link rate is 867.  With any WiFi setup you will only realize 50-60% of the link rate in throughput under ideal conditions, due to the overhead of the wireless protocol.  Also, to get the maximum speed you need a very good client.  The best I've measured with Orbi and a 2018 MacBook Pro is 630 for the router and 560 for the satellite.  That's near the AP with clear line of sight.

Message 2 of 4
PlatinumGoat
Apprentice

Re: Slow WiFi speeds

Thanks for the reply. I however find it strange that official tech support from NG find my speeds too slow. If not, they wouldn't recommended several changes like turning daisy chain off (I only have one satellite), turning on implicit beam forming, turning on mu-mimo and also adjusting the CTS/RTS to 2307 instead of 2347. What do you think?

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 3 of 4
FURRYe38
Guru

Re: Slow WiFi speeds

Yes you can disable Daisy Chain, if your on v210, put a check mark in the Daisy Chain box. Users have said v210 seems to work in reverse on this version of FW. 

 

Yes, Enable Beamforming. If you have MIMO supporting devices MIMO can be enabled. If, not, keep it disabled. Leave CTS values if your not having problems with devices connecting to the Orbi wifi. 


@PlatinumGoat wrote:

Thanks for the reply. I however find it strange that official tech support from NG find my speeds too slow. If not, they wouldn't recommended several changes like turning daisy chain off (I only have one satellite), turning on implicit beam forming, turning on mu-mimo and also adjusting the CTS/RTS to 2307 instead of 2347. What do you think?


 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 4552 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 7