× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

"Authentication Error" on mobiles connecting to Orbi RBK-50

Torigo
Aspirant

"Authentication Error" on mobiles connecting to Orbi RBK-50

I have a netgear Orbi RBK-50-100PES with 2 satelites, with some problems. All our Samsung mobiles (and one sony mobile) we keep getting disconnected from the main Orbi wifi network:

  • I receive the message “authentication error”, but the username and password is 100 % correct. Sometimes if I turn on/off the wifi, it works again. Sometimes it works a few hours later.
  • The username and password is correct and the same both when it works and when it does not work.
  • The problem is only on the Orib main wifi network. The Orbi guest wifi network works fine, I receive no authentication error there.
  • The problem is only with mobile phones, other devices works fine.

    How do I fix this? I need both the Orbi main wifi network and the Orbi guest wifi network to work stable with mobile phones and other equipment.
Message 1 of 4
FURRYe38
Guru

Re: "Authentication Error" on mobiles connecting to Orbi RBK-50

What FW is currently loaded?
What is the Mfr and model# of the ISP modem the NG router is connected too?

Message 2 of 4
Torigo
Aspirant

Re: "Authentication Error" on mobiles connecting to Orbi RBK-50

Thanks for your reply.

- The Firmware version is v.2.2.1.210, according to Orbi it is the latest version I can run.

- The ISP (Movistar) modem is: Mitrastar GPT-2541GNAC

 

Message 3 of 4
FURRYe38
Guru

Re: "Authentication Error" on mobiles connecting to Orbi RBK-50

Your ISP modem maybe cuasing this if it's running in router mode. I believe it has a built in router already. 

http://www.mitrastar.com/detail.php?lang=eng&ctwo=zxfsetghrtsyrrdytrt&cthr=gjkhg87fggy4eedu&unit=vcf...

 

Couple of options,
1. Configure the modem for transparent bridge mode. Then use the Orbi router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ for the IP address the Orbi router gets from the modem. Then you can use the Orbi router in Router mode.
3. Or disable all wifi radios on the modem and connect the Orbi router to the modem, configure AP mode on the Orbi router. https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point and https://www.youtube.com/watch?v=H7LOcJ8GdDo&app=desktop

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1792 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7