× We are working to resolve an issue that is preventing some customers from accessing the Orbi app or web interface for the Orbi RBK85x and RBK75x. We are investigating this as the highest priority and will provide updates at Status.NETGEAR.com
Reply

DNS Probe finished nxdomain & missing router logs

Validus
Luminary

DNS Probe finished nxdomain & missing router logs

I have a RBK853 — Orbi WiFi 6 System AX6000 model, which is working fine, but has a couple of bugs?

 

1 router + 2 satellites with currently version 3.2.16.22 firmware on each.

 

The first issue:

 

When visiting new websites for a few seconds the error message "DNS_PROBE_FINISHED_NXDOMAIN" might appear on the web-browser. The website loads and displays later, but just wondering why that message pops up? It only started showing when we got this new wifi mesh.

 

The problem only appears sometimes on new domains visited.

 

Note the PC has Kaspersky Internet Security 2021 installed, that has a security extension on the web-browser(s). 

 

The second issue:

 

Under the router admin login > Administration > Logs

 

That is showing Admin login and DHCP IP to MAC addresses, but that is all. The "Include in Log" tick boxes such as "Known DoS attacks and Port Scans" are all ticked but do not display in the logs.

Message 1 of 19

Accepted Solutions
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

Work around fix for now.

 

Under your router admin > advanced > advanced > IPv6

 

I changed the Internet Connection Type from "Disabled" to "6to4Tunnel", the rest I just left as automatic, applied and also rebooted the PC.

View solution in original post

Message 16 of 19

All Replies
FURRYe38
Guru

Re: DNS Probe finished nxdomain & missing router logs

Have you tried v12?

https://community.netgear.com/t5/Orbi-AX/New-RBR850-RBS850-Series-Firmware-Version-v3-2-17-12-Releas...

 

What is the Mfr and model# of the Internet Service Providers modem/ONT the NG router is connected too?

 

FYI about DNS:

https://community.netgear.com/t5/Orbi-AX/Intermittent-DNS-Errors-and-WiFi-Issues/td-p/1950768/jump-t...

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 2 of 19
Mikey94025
Mentor

Re: DNS Probe finished nxdomain & missing router logs


@Validus wrote:

When visiting new websites for a few seconds the error message "DNS_PROBE_FINISHED_NXDOMAIN" might appear on the web-browser. The website loads and displays later, but just wondering why that message pops up? It only started showing when we got this new wifi mesh.


There are a subset of Orbi AX customers experiencing these intermittent DNS errors: https://community.netgear.com/t5/Orbi-AX/DNS-PROBE-FINISHED-NXDOMAIN-errors-on-RBR850/m-p/2016853 and https://community.netgear.com/t5/Orbi-AX/Intermittent-DNS-Errors-and-WiFi-Issues/m-p/2046801

 

Message 3 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

It's the Model RBK853 - Orbi WiFi 6 System AX6000, which showed Firmware version 3.2.16.22 as the latest, when checking under the auto-update of the router login.

 

Odd how it's listed for RBK852 but not the RBK853. I think I will manually update to Firmware Version v3.2.17.12 anyways in case they just missed updating that and suggests there is a security fix too. Thanks, seems to work fine upon the router and both satellites so far!

 

Will update later if resolved these issue or not.

Message 4 of 19
FURRYe38
Guru

Re: DNS Probe finished nxdomain & missing router logs

What is the mfr and model# if your ISP Modem or ONT?

 

Keep us posted...


@Validus wrote:

It's the Model RBK853 - Orbi WiFi 6 System AX6000, which showed Firmware version 3.2.16.22 as the latest, when checking under the auto-update of the router login.

 

Odd how it's listed for RBK852 but not the RBK853. I think I will manually update to Firmware Version v3.2.17.12 anyways in case they just missed updating that and suggests there is a security fix too. Thanks, seems to work fine upon the router and both satellites so far!

 

Will update later if resolved these issue or not.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 5 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

It's a Chorus Model Type 200 Optical Network Terminal fiber connection connected via ethernet to the Orbi RBK853. It has a VLAN / Bridge setup with ID 10, if that matters as well?

 

The firmware to version 3.2.17.12 was successful and runs fine, but doesn't appear to of resolved the issues. The DNS Probe finished nxdomain is not appearing as much as it did. It's very rare or gone away now? Hard to find a website which does it.

Message 6 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

So are these bugs that has been around for quite a while and affects a bunch with this certain mesh router, but no one has any clue how to resolve it?

 

Is there any information you might need to help?

 

- Domain Name Server (DNS) Address is set and everything else is automatic

 

- WAN Preference is Internet Port (2.5 Gbps)

- Enable AX is on

- Disable IGMP Proxying is ticked

- RIP Direction is both

- RIP Version is disabled

- Use Router as DHCP Server is ticked

- NTP Settings is set

 

Do I use Router or AP Mode? Currently it's on Router

 

- Guest Network is disabled

- E-mail Notification is Off

- No Port Forwarding

- No Dynamic DNS

- No VPN Services

- No Static Routes

- Remote Management is disabled

- UPnP is disabled

- IPv6 is disabled

- Traffic Meter is disabled

- VLAN / Bridge Settings is enabled (VTAG ID = 10 / PRIORITY = 0 / ALL)

Message 7 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

I was originally using CloudFlare DNS:

1.1.1.1

1.0.0.1

 

I assumed it was the fastest DNS available and they worked fine with previous routers, however came across this DNS Performance Tester App (as mentioned in another post):

GRC's | DNS Nameserver Performance Benchmark

 

After a full scan of all DNS servers, it listed CloudFlare DNS as the 6th faster for me. My ISP DNS servers was considered the fastest. I'm guessing it had to do with my location and the distance delay. So updated the DNS to them.

 

This might of resolved the "DNS Probe finished nxdomain" issue, as it hasn't appeared so far since.

 

The problem with this Orbi Mesh Router might only occur for those with delayed DNS and/or a certain DNS? If anyone else has the same problem, does changing the DNS also help them?

Message 8 of 19
FURRYe38
Guru

Re: DNS Probe finished nxdomain & missing router logs

What happens if you use ISP DNS? Same thing? 


@Validus wrote:

I was originally using CloudFlare DNS:

1.1.1.1

1.0.0.1

 

I assumed it was the fastest DNS available and they worked fine with previous routers, however came across this DNS Performance Tester App (as mentioned in another post):

GRC's | DNS Nameserver Performance Benchmark

 

After a full scan of all DNS servers, it listed CloudFlare DNS as the 6th faster for me. My ISP DNS servers was considered the fastest. I'm guessing it had to do with my location and the distance delay. So updated the DNS to them.

 

This might of resolved the "DNS Probe finished nxdomain" issue, as it hasn't appeared so far since.

 

The problem with this Orbi Mesh Router might only occur for those with delayed DNS and/or a certain DNS? If anyone else has the same problem, does changing the DNS also help them?


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 9 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

It still has the problem, but extremely rare to come up now and when it does it's just for a split second.

 

A delayed or slow DNS does seem to increase this problem or at least make it noticable (I barely would notice it now and disregard it as nothing / not a problem - quite a few might have this and just don't notice it). The problem seems to be affecting the Orbi Mesh Router, not other routers (using same DNS and settings). It affects IPv4 users, not IPv6 (but my ISP doesn't seem to offer IPv6)?

 

As for the logs, it's cropping it short. So when you login to the admin and check the logs there would be the last 8 lines only. Does it have to be emailed to you for the full log? What's the point of the clear log button, there's barely a log to clear.

Message 10 of 19
FURRYe38
Guru

Re: DNS Probe finished nxdomain & missing router logs

I doubt the logs will be helpful, though debug logs sent to NG support would be more helpful I presume: router ip/debug.htm

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 11 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

It's still doing it, not resolved yet.

 

I'm wondering if it's because I'm not using "NETGEAR Armor", which is currently STATUS: NOT ACTIVATED. Does the DNS attempt to go via that anyways, not find it and bounce back causing the issue if delayed?

 

I don't think I can use the Orbi Mesh router in AP Mode? My Chorus ONT Model 200 doesn't appear to have any Wifi or options to setup with it.

 

For the /debug.htm on the Orbi, what would I do? There's "Start Debug Log Capture when boot up" and "Enable LAN/WAN Packet Capture" tick boxes, do I use those or just the "Start Capture" button to use? Then do I just have to wait and capture the part when it occurs with the "DNS Probe finished nxdomain" message?

Message 12 of 19
FURRYe38
Guru

Re: DNS Probe finished nxdomain & missing router logs

Had you ever had Armor activated at all?

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 13 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

No, I have not used Armor yet at all. It's never been set.

 

Might be a good idea asking others with the "DNS Probe finished nxdomain" issue if they had setup it before too?

Message 14 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

I didn't need the Netgear Armor, as I already have a 3 year Kaspersky subscription. However, I will try the trial to test upon the Router (without the install of Bit Defender).

 

Instantly after enabling the Netgear Armor on the Orbi Router there was a noticable difference in webpage loading (any web-browser, I tried before and after with three different ones including Microsoft Edge, Firefox, and Google Chrome). I notice some rare webpages don't break on first load like before as well (previously needing a refresh to correct), but rather load faster and more smoothly.

 

So far there has been no "DNS Probe finished nxdomain" issues, but will need to test for longer to ensure.

 

Clearly there's a linkage between Netgear Armor and the DNS lookups?

Message 15 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

Work around fix for now.

 

Under your router admin > advanced > advanced > IPv6

 

I changed the Internet Connection Type from "Disabled" to "6to4Tunnel", the rest I just left as automatic, applied and also rebooted the PC.

Message 16 of 19
FURRYe38
Guru

Re: DNS Probe finished nxdomain & missing router logs

This was mentioned eariler on in some post threads regarding Ipv6. I have it enabled as well...I have noticed some DNS errors however not many. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 17 of 19
Validus
Luminary

Re: DNS Probe finished nxdomain & missing router logs

Yeah, I read over your mention of it before and even asked my ISP if they supported IPv6. They said they didn't.

 

It was your comment which made me just finally try it. I didn't believe it would work, but 6to4Tunnel sounds like it would still use IPv4 addresses on the Internet. Which it does. The only think that's changed is the router using IPv6 and converting it out to the Internet. Even on the Wifi, it still uses IPv4. It's barely doing anything by the looks and has no effect on performance or other behaviours, yet fixes the DNS problem for me.

 

Still no DNS errors so far.

Message 18 of 19
FURRYe38
Guru

Re: DNS Probe finished nxdomain & missing router logs

Same with with my ISP. No IPv6 native. So someone said to try the 6to4. It works nicely. 

I've also enabled DNS over HTTPS on my Opera GX browser as well. Seems to work nicely as well. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 19 of 19
Top Contributors
Discussion stats
  • 18 replies
  • 2868 views
  • 5 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E