Reply

Double NAT / Strict NAT

FURRYe38
Guru

Re: Double NAT / Strict NAT

No, double NAT issue is mostly if your ISP modem has a built in router while having the RBR connected. Having two routers online causes this. This issue is mostly the FW on Orbi not working right when having two or more game consoles online at the same time. I submiited a bug report already on this. ALso NAT Filter feature is working. IF set to OPEN it should help two or more game consoles attain OPEN NAT all at the same time. This feature is not working currently on Orbi AX. It works on Orbi AC. 

 

SO far I have not seen any disconnection issues after v10.11 was loaded and back in router mode. I also don't have a built in router and wifi in my modem. CM1100 is a stand alone modem. 


@ZOOShen wrote:
How do you know it is a double NAT issue, because you are kicked off from the game?

This firmware has know problem of disconnecting from many games. The easiest way temporary is turn on your cable modem routing (rather than bridge mode), and put Obri AX into AP mode.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 51 of 61
ZOOShen
Star

Re: Double NAT / Strict NAT


@FURRYe38 wrote:

No, double NAT issue is mostly if your ISP modem has a built in router while having the RBR connected. Having two routers online causes this. This issue is mostly the FW on Orbi not working right when having two or more game consoles online at the same time. I submiited a bug report already on this. ALso NAT Filter feature is working. IF set to OPEN it should help two or more game consoles attain OPEN NAT all at the same time. This feature is not working currently on Orbi AX. It works on Orbi AC. 

 

SO far I have not seen any disconnection issues after v10.11 was loaded and back in router mode. I also don't have a built in router and wifi in my modem. CM1100 is a stand alone modem. 


@ZOOShen wrote:
How do you know it is a double NAT issue, because you are kicked off from the game?

This firmware has know problem of disconnecting from many games. The easiest way temporary is turn on your cable modem routing (rather than bridge mode), and put Obri AX into AP mode.


 


I know what I am talking about. Been working for CSCO for 6 years in the past,  I know what I am talking about.  I understand what double NAT problem is. But what you are experiencing is not from double NAT. It is a bug with their current firmware which causes Orbi AX router fequently disconnet from the game servers. Put Orbi AX into AP mode will fixed the problem at this momnent. Even you connect Orbi AX as AP to another router then connect to a cable modem as gateway router. In that case, it is still double NAT, but the problem will disappear. 

 

If you still believe this is a double NAT problem, I will not give you more comments. Sorry...

 

 

Message 52 of 61
LVJRich
Tutor

Re: Double NAT / Strict NAT

I only believe it is a Double NAT condition because the Network Settings on my XBox consoles say it is. Power on the XBox, go to settings and then network settings, the screen says: NAT type - Strict / Double NAT detected. It says the exact same thing on all three of my XBox consoles and all three are connected to the Orbi AX differently. One is hard wired to the router, one is hard wired to the satellite, and one is on WiFi through the satellite. This is a new issue for us that only cropped up once we switched to the Orbi AX. Ran the older Orbi for a few years and never once had this problem come up.

The question about being kicked out of games, yes we are, constantly. Getting kicked from games started us down this troubleshooting path which led us here.

As I had mentioned, randomly changing ports through the XBox dashboard is the only work around we have found at time and that seems to work for us. I cannot speak to anyone else with the issue.
Message 53 of 61
FURRYe38
Guru

Re: Double NAT / Strict NAT

Its only a double NAT issue if the modem has a built router. However both the OP and I don't have modems with build in routers. So Yes, this isn't a actual double NAT issue. One would need an additonal router to use the RBR in AP mode. Currently v10.11 is working for gaming with out any problems behind a CM1100 modem. My RBR is running in router mode. Been first time since last year that I could do this since FW broke NAT status for xbox consoles. At least for mine it did. v10.11 was first time I was able to get OPEN NAT on 1 console. Since last year I had been running AP mode all the time due to FW not working right for game consoles.

 

There is a problem in uPnP and NAT Filter that seems to be effecting how NAT is being reported on game consoles. I have been looking at this since last year. I have reported all this to NG and hoping to help them get this working on Orbi AX for those games with this system. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 54 of 61
FURRYe38
Guru

Re: Double NAT / Strict NAT

Are you still getting kicked from games with the ports being set to manual?  Even after getting re-updated? 

Does this happens with just 1 consoles only or when all consoles are online? 


@LVJRich wrote:
I only believe it is a Double NAT condition because the Network Settings on my XBox consoles say it is. Power on the XBox, go to settings and then network settings, the screen says: NAT type - Strict / Double NAT detected. It says the exact same thing on all three of my XBox consoles and all three are connected to the Orbi AX differently. One is hard wired to the router, one is hard wired to the satellite, and one is on WiFi through the satellite. This is a new issue for us that only cropped up once we switched to the Orbi AX. Ran the older Orbi for a few years and never once had this problem come up.

The question about being kicked out of games, yes we are, constantly. Getting kicked from games started us down this troubleshooting path which led us here.

As I had mentioned, randomly changing ports through the XBox dashboard is the only work around we have found at time and that seems to work for us. I cannot speak to anyone else with the issue.

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 55 of 61
LVJRich
Tutor

Re: Double NAT / Strict NAT

No, we are not getting kicked out once he manually chooses a port.

(I'll use Dead By Daylight as an example.)

He starts up the game and it will immediately give him a warning along the lines of "there will be issues with the current NAT type". Cannot chat with his party but the game will start normally after you close the NAT warning screen. After an average of 15-20 minutes, he will get kicked to the main menu. This all happens EVERY time the game is played with the settings as-is.

If he goes into XBox network settings and then into advanced, you can manually change your port. He keeps picking ports at random until the NAT goes away and the settings say open. It might take trying 4-8 different ports but eventually it will show as open NAT. Once it's open, he has full access to party chat and so far has not been kicked at all, gets all the way through a game.
Message 56 of 61
FURRYe38
Guru

Re: Double NAT / Strict NAT

Ok. This points to uPnP not working correctly IMO. 

 

Great information. I've asked NG to look into this and included this thread. Thank you for posting about this. Your one in the first who has more than just 1 xbox console seeing NAT issues on Orbi AX. I have two...

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 57 of 61
LVJRich
Tutor

Re: Double NAT / Strict NAT

Oh, and I failed to answer a previous question you had. We will get the Double NAT issue regardless if just one console is powered on and being used or if all three are powered on and being used. The work around works for us in either situation.

We also have a PS4 that has the Double NAT issue but never really play on it so haven't tried the corrections with that but we will check it if it might help.
Message 58 of 61
FURRYe38
Guru

Re: Double NAT / Strict NAT

Ok, thanks for this information. Hoping we can get NG to dive into this one. Orbi AC routers work. Smiley Wink

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 59 of 61
LVJRich
Tutor

Re: Double NAT / Strict NAT

One last thing I just remembered. There is a suggestion on the XBox boards that say using IPv6 and/or UPnP should also fix the issue, but neither does. I have turned on IPv6 and although it shows up as running it on the XBox dashboard, it does not do anything. I have never turned off UPnP but I tend to agree that this is the problem. UPnP does not seem to be working correctly on the AX.
Message 60 of 61
FURRYe38
Guru

Re: Double NAT / Strict NAT

Do you have native IPv6 support from your ISP? IF so then you can enable it on the RBR. Otherwise, disable it. Mine doesn't. 

Thanks for this info. Ya, uPnP and NAT Filter set to OPEN isn't working. I wish it was, as this would be all you need. Hoping NG can resolve this. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 61 of 61
Top Contributors
Discussion stats
  • 60 replies
  • 3035 views
  • 1 kudo
  • 3 in conversation
Announcements

Orbi WiFi 6E