Reply
Highlighted
Aspirant

2.4 GHz device won't connect to Orbi

An IoT device called Rotimatic (flat bread maker) is unable to connect to Orbi. The device uses only 2.4 GHz to connect.

I tried connecting the device to my phone hotspot and it had no issues.

Not sure where to start troubleshooting.

Thanks in advance.
Message 1 of 4
Highlighted
Sensei

Re: 2.4 GHz device won't connect to Orbi

Most of the posts about "2.4G device cannot connect" conclude that the issue lies with the smartphone app.  A device that has only a 2.4G WiFi chip in it cannot detect or connect to any 5G WiFi.  It is simply impossible.  What is supposed to happen is the smartphone app tells the device the WiFi name (SSID) and password of the Orbi and the device happily connects.  Unfortunately, some apps are written poorly, and when the smartphone is connected to the Orbi at 5G, they tell the device the MAC address of the Orbi 5G signal rather than the information that they should convey.

 

The cure that seems to work is to temporarily tell the Orbi to stop broadcasting the 5G SSID.  Have the smartphone "forget" the Orbi, and then select it from the list of WiFi access points.  This will connect the smartphone at 2.4G.  The app will work.  The device will connect.  Then, go back to the Orbi and tell it to start broadcasting the 5G SSID.

 

This is on the Orbi web interface, Advanced Tab->Advanced Settings->Wireless Settings.  The Orbi "app" does not have the capability of doing this.  Only the web interface.

 

Please try this and let us know how it goes.

I love my Orbi.
Message 2 of 4
Highlighted
Aspirant

Re: 2.4 GHz device won't connect to Orbi

I tried all the steps suggested.
- Using the browser, disabled 5ghz broadcast.
- Used an Android tablet for my next step - forgot my SSID on it. Reconnected to my wifi. Confirmed through the portal that the tablet connected on 2.4ghz.
- Used the "Rotimatic" app to again try configuring the device wifi.

It failed with the same error messages.

I tried at least 4 times just to be sure, but the exact same result.
Message 3 of 4
Highlighted
Guru

Re: 2.4 GHz device won't connect to Orbi

As a quick test, what happens if you disable WPA2 on the Orbi RBR and then attempt to connect your device to the RBR and configure it? Does this work any? After trying this, set WPA and TPIK on the RBR and re-connect and configure the device. Does this work any? 


@Nadan wrote:
I tried all the steps suggested.
- Using the browser, disabled 5ghz broadcast.
- Used an Android tablet for my next step - forgot my SSID on it. Reconnected to my wifi. Confirmed through the portal that the tablet connected on 2.4ghz.
- Used the "Rotimatic" app to again try configuring the device wifi.

It failed with the same error messages.

I tried at least 4 times just to be sure, but the exact same result.

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>RBK853 v3.1.16.6(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK50, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 419 views
  • 0 kudos
  • 3 in conversation
Announcements