Reply
Highlighted
Follower

404 Page Not Found, Page Not Secure, Amazon Fire Stick won't connect, more - Solved

This is not a call for help, rather this is a post of my experience and the solution I found. Hopefully, someone else will find this helpful if they run into the same or similar problem.

 

I installed and used an Orbi RBR50 and Satellite several weeks before my problem surfaced, with no problems at all. My Internet connection is through Verizon FIOS. I had disabled the Wi-Fi on the FIOS router, connected an ethernet out of the FIOS router to my RBR50. Out of the RBR50 I also connected a switch to handle several devices in my home. I was getting great throughput and amazing coverage in our home!

 

After a few weeks I checked for firmware updates and saw that one was available. Naturally, I updated the firmware and rebooted the Orbi's. Shortly thereafter, I started noticing odd problems using the Internet, including:

 

  • Some URL links produced "404 Page Not Found" errors. Sometimes I could load the page by typing in "https://www" at the beginning of the URL, sometimes this did not work.
  • Some URL links produced an error telling me the page is not secure, and asking me to log in (for example, "401 Unauthorized").
  • My DirecTV Genie was no longer connected to the Internet.
  • My Amazon Fire Stick displayed a "Home is Currently Unavailable" message. Checking the network connections from their settings showed a" Network (Disconnected)" message. 
  • My Brother printer was no longer connected to the Internet.

Some of these problems were with devices connected via Wi-Fi. Some were connected to ethernet lines coming from the Orbi satellite.

 

After searching these forums, the Internet, and speaking with several people I determined that I was likely the victim of a double-NAT, sometimes referred to as a NAT conflict. For those who do not know (including me before this problem), a NAT is a Network Address Translation protocol intended to ensure a unique address for Internet connections. The protocol (for lack of a better term) ensures that Internet traffic flows to and from the correct connections.

 

In the end, solving my problem was easy:

 

  • I disconnected all outbound connections from the Verizon FIOS router.
  • I shut down my Orbi's (by disconnecting power).
  • Connecting directly to the Verizon FIOS router, I worked through its settings to release the DHCP, then immediately pulled the outside FIOS ethernet cable to ensure a renew DHCP request could not be completed.
  • I connected the outside FIOS ethernet cable to the RBR50, reconnected my home connections to the RBR50 and my switch, and powered up the RBR50 on. Once it stabilized, I powered up the Satellite.

Everything now works! I did have to reboot or reconfigure some devices (the Amazon Fire stick needed a reboot, the DirecTV required requesting a connection to the Internet so it could go through it's testing steps, and the Brother printer needed a power-cycle).

 

I hope this helps someone in the future who falls into the same or similar set of problems.

 

Enjoy your Orbi. It's a GREAT system.

 

P.S. The steps for releasing the DHCP were found here: http://www.dslreports.com/faq/15898 If that link no longer works, an Internet search for "FIOS router release dhcp" should provide lots of links.

 

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 2
Highlighted
Guru

Re: 404 Page Not Found, Page Not Secure, Amazon Fire Stick won't connect, more - Solved

This would be a double NAT (two router) condition which isn't recommended. https://kb.netgear.com/30186/What-is-Double-NAT
https://kb.netgear.com/30187/How-to-fix-issues-with-Double-NAT
Couple of options,
1. Configure the modem for transparent bridge or modem only mode. Then use the Orbi router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ/ExposedHost or IP Pass-Through for the IP address the Orbi router gets from the modem. Then you can use the Orbi router in Router mode.
3. Or disable all wifi radios on the modem and connect the Orbi router to the modem, configure AP mode on the Orbi router. https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point and https://www.youtube.com/watch?v=H7LOcJ8GdDo&app=desktop

 

Enjoy. 


My Setup (Cable 900Mbps/50Mbps)>CAX80>XR450 v2.3.2.106(Router Mode)>RBK853 v3.2.11.2(AP Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 136 views
  • 0 kudos
  • 2 in conversation
Announcements