Reply

AppleTV+ region error

PixelTreat
Luminary

AppleTV+ region error

"This video isn't available to watch in the country or region you're currently in."

I receive the error message whenever I try to play any content from AppleTV+. My region is the US. And the ip address is seen as the US as well. This happens on both the new AppleTV 4k, an AppleTV HD and on my macbook Air M1, whether by ethernet or wireless. Netflix, Amazon, HBO, Disney+ all stream fine. I've been bumped up three levels on apple support and finally my case was given to an engineer who, without asking, simply closed the ticket saying I had a vpn turned on. I don't, so I called and reopened the case and haven't heard back since.

It does work if I connect to my phone as a hotspot, so it's tied somehow to the router or modem.

My service is Spectrum, my modem is a Nighthawk CM2000 and my router/wifi is an Orbi rbk50.

Any thoughts on what I can do to get AppleTV+ working properly? 

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 1 of 6
CrimpOn
Guru

Re: AppleTV+ region error

Maybe it is something to do with an Apple Account screwup:

https://discussions.apple.com/thread/251707508 

I love my Orbi.
Message 2 of 6
PixelTreat
Luminary

Re: AppleTV+ region error

I tried signing in and out. I also tried a completely different Apple ID. I still see the region code error across multiple devices. 

Message 3 of 6
PixelTreat
Luminary

Re: AppleTV+ region error

Solved: The solution is changing the router's MAC address to force my ISP to assign a new public ip address.
Message 4 of 6
Dai72
Luminary

Re: AppleTV+ region error

I'm getting "This video isn't available to watch in the country or region you're currently in."

whenever I try to access content on AppleTV Plus, even through this was not a problem two days ago. I read that changing the router MAC address would solve this. How is that done? Not a tech wizard here.

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 5 of 6
PixelTreat
Luminary

Re: AppleTV+ region error

This is based on my setup where I have a seperate modem and router:

login into the router on your computer, go to internet setup.

Find the section titled Router MAC Address.

It is most likely set to: Use Default Address

leave this page up.

Now unplug the modem. 

go back to the online router settings. Change the mac address option to: Use Computer MAC Address

Save new setting.

Turn the modem back on. it should now hopefully pick up a new ip address.

 

Hope this helps.

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 559 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E