Reply

Re: Bug: RBR20 incorrectly uses link-local router IPv6 address as address for IPv6 DNS server.

-geoff
Follower

Bug: RBR20 incorrectly uses link-local router IPv6 address as address for IPv6 DNS server.

There is a bug in either the SLAAC/DHCPv6/DNS server configuration when IPv6 (in auto-config and DHCP modes (etc.) is enabled. After IPv6 Neighbor Discovery ICMPv6 and Router Solicitation it is appropriate that the link-local IPv6 address for the gateway be assigned the gateway's IPv6 link-local address, as it *is* literally the "next hop" on the IPv6 protocol. However, unlike IPv4, this does not serve the same purpose as the IPv5 LAN IP of the gateway—the fe:80:: addresses are restricted only to local network functions, and can explicitly not pass requests from clients out to a global IP.

 

However, instead of assigning the gateway's IPv6 external address when assigning DNS servers to clients, it assigns the link-local address instead. That is, if my link-local IPv4 and IPv6 router addresses are 192.168.1.1 and fe80::26a0:74ff:fe74:caf1
 (which are correct), presently, these same addresses are being assigned to clients as DCHP servers as well (incorrect).

 

Instead, the DNS servers should be 192.168.1.1 and 2601:645:400:80:26a0:74ff:fe74:caf1: that is, the DNS server needs to assign clients iits global address, not the link-local address.


This is not a unique issue for this Orbi model; I suspect this is the culprit of several other issues on this board as well. For a bit of a deep dive, see:

 

https://blog.zivaro.com/need-know-link-local-ipv6-addresses
https://en.wikipedia.org/wiki/Link-local_address#IPv6
https://tools.ietf.org/html/rfc4443
http://gtri.wpengine.com/frequently-asked-questions-ipv6

https://forum.vyos.io/t/dns-requests-coming-from-ipv6-link-local-instead-of-global-ipv6-address/2238

 

And related issues on the forum like,

 

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7800-IPv6-DNS-Not-Available-on-Link-Local-A...

 

@Jim769 

 

 https://community.netgear.com/t5/Orbi/RBR50-no-IPv6-after-V2-5-1-8-update/m-p/1865729#M82970


Here's hoping for a fix.

Thanks, Geoff

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 3
CrimpOn
Sensei

Re: Bug: RBR20 incorrectly uses link-local router IPv6 address as address for IPv6 DNS server.


@-geoff wrote:

However, instead of assigning the gateway's IPv6 external address when assigning DNS servers to clients, it assigns the link-local address instead. That is, if my link-local IPv4 and IPv6 router addresses are 192.168.1.1 and fe80::26a0:74ff:fe74:caf1
 (which are correct), presently, these same addresses are being assigned to clients as DCHP servers as well (incorrect).


Is "DCHP" a typo that should be  "DNS"?

What is your temporary fix?  Turning off IPv6?

I love my Orbi.
Message 2 of 3
FURRYe38
Guru

Re: Bug: RBR20 incorrectly uses link-local router IPv6 address as address for IPv6 DNS server.

Please file a support ticket with NG and let them know. 

https://www.netgear.com/support/#

 

Good Luck.


@-geoff wrote:

There is a bug in either the SLAAC/DHCPv6/DNS server configuration when IPv6 (in auto-config and DHCP modes (etc.) is enabled. After IPv6 Neighbor Discovery ICMPv6 and Router Solicitation it is appropriate that the link-local IPv6 address for the gateway be assigned the gateway's IPv6 link-local address, as it *is* literally the "next hop" on the IPv6 protocol. However, unlike IPv4, this does not serve the same purpose as the IPv5 LAN IP of the gateway—the fe:80:: addresses are restricted only to local network functions, and can explicitly not pass requests from clients out to a global IP.

 

However, instead of assigning the gateway's IPv6 external address when assigning DNS servers to clients, it assigns the link-local address instead. That is, if my link-local IPv4 and IPv6 router addresses are 192.168.1.1 and fe80::26a0:74ff:fe74:caf1
 (which are correct), presently, these same addresses are being assigned to clients as DCHP servers as well (incorrect).

 

Instead, the DNS servers should be 192.168.1.1 and 2601:645:400:80:26a0:74ff:fe74:caf1: that is, the DNS server needs to assign clients iits global address, not the link-local address.


This is not a unique issue for this Orbi model; I suspect this is the culprit of several other issues on this board as well. For a bit of a deep dive, see:

 

https://blog.zivaro.com/need-know-link-local-ipv6-addresses
https://en.wikipedia.org/wiki/Link-local_address#IPv6
https://tools.ietf.org/html/rfc4443
http://gtri.wpengine.com/frequently-asked-questions-ipv6

https://forum.vyos.io/t/dns-requests-coming-from-ipv6-link-local-instead-of-global-ipv6-address/2238

 

And related issues on the forum like,

 

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7800-IPv6-DNS-Not-Available-on-Link-Local-A...

 

@Jim769 

 

 https://community.netgear.com/t5/Orbi/RBR50-no-IPv6-after-V2-5-1-8-update/m-p/1865729#M82970


Here's hoping for a fix.

Thanks, Geoff



 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 518 views
  • 2 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E