Reply

Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

Zellio
Aspirant

Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

What can I do here to fix this?  I keep getting 'This firmware file is incorrect' errors when I try to update

Message 1 of 9

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

It isn't clear to me if you have tried an intermediate version.

 

Sometimes the leap is too big to go to the newest.

 

Just another user with a set of boilerplate macros.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 9
plemans
Guru

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

like @michaelkenward stated, sometimes you have to install an intermediate step. some of the firmware change allowed larger firmware version to be loaded and need to be installed first. You shouldn't have to load all the versions but occasionally it'll require a small step in firmware first. 

How are you attempting to  update?  manually or using the auto update feature?  Make sure when you're making these steps to update your satellite's first and then the main router. 

 

https://kb.netgear.com/31573/How-do-I-manually-upgrade-firmware-on-my-Orbi-Satellite

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 3 of 9
FURRYe38
Guru

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

You have to update to an intermediate version v2.0.0.74 first on the RBS then RBR. Then I believe you can directly go to v44 on the RBS first, You'll need to apply V212 first to the RBR then apply v44 lastly to the RBR. 


@Zellio wrote:

What can I do here to fix this?  I keep getting 'This firmware file is incorrect' errors when I try to update


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Router Mode |  Wifi Router CAX80 (Router Mode) and RBK963 (APMode) | and MK63 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M |

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 4 of 9
Zellio
Aspirant

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

None of it was that easy. I had to start with 1.5, then 1.7, then 1.9, the second to latest update bricked my orbi, so I ended up having to use TFTP to fix it (which eventually worked), and finally I have a fully updated unit

All because I was curious about NETGEAR armor 😕 😕 😕 😕
Message 5 of 9
plemans
Guru

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

Wish it would have went smoother for you! Did you just get the orbi or why was it so out of date? There's been quite a few advancements since the 1.2 firmware. some great and some not so great. 

Hope it works well for you!

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 6 of 9
Zellio
Aspirant

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

I got it in late December when I upgraded to gigabit internet, I generally don’t update routers (unless I’m using something like ddwrt or openwrt for reasons like this. Also my other NETGEAR products actually showed when there was an update available while this did not even when it was on the site.
Message 7 of 9
plemans
Guru

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

Huh, Orbi is usually really good about auto updating. There's quite a few posts on the challenges of disabling it because some users don't like that function. I wonder if it was just so out of date it required the manual route. I'm glad to hear you have it running though!

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 8 of 9
FURRYe38
Guru

Re: Cannot update RBK50 or either RBS50 to anything beyond v1.2.0.6

v2.0.0.74 is the only version needed to get from v1. to v2.2.xxx

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Router Mode |  Wifi Router CAX80 (Router Mode) and RBK963 (APMode) | and MK63 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M |

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 1214 views
  • 1 kudo
  • 4 in conversation
Announcements

Orbi WiFi 6E