Reply

Cant Register RBR20

narshallcochran
Follower

Cant Register RBR20

I login to mynetgear account and go to the link that says register product. It takes me to a page where it asks for my serial number ans date of purchase, when I enter them correctly it pops up with this message "Error: Something went wrong! Please try again". I have also tried by clicking the register button on the orbi app in the app it poped up with "Registration Failed. Phone_with_country_already_exist". Every single time I tried any of these methods I encounter the same errors. 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 2
CrimpOn
Sensei

Re: Cant Register RBR20

The best strategy at this point is to send a private message to one of the forum moderators, such as @Blanca_O (click on the name).

Provide the serial number, date, and where purchased.  Maybe this router was purchased, registered, then returned and sold again.

I love my Orbi.
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 266 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E