Reply

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

mbreksop
Star

Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 50)

Hi,

 

It seems like Netgear now forces a new EULA requiring Auto Firmware Upgrade for all Orbi Routers, unfortunately for our RBR/S/K 50, the new 2.7.3.22 is buggy, and sometimes drop connections between satellite and router out of the blue.

 

I have followed this instruction many times: https://community.netgear.com/t5/Orbi/Disable-auto-update-of-orbi-firmware-additional-steps-needed/t...  , by the way you need to downgrade to stable firmware (for me it's 2.3.5.34) first, to enable Telnet portion.

 

But after a while it still gets updated.  So i am trying a new trick, basically using DNS to block, see the addition to /etc/hosts below.

 

Does anyone have same issues ?

 

 

127.0.0.1 localhost update.netgear.com updates1.netgear.com updates2.netgear.com updates3.netgear.com http.fw.updates1.netgear.com readycloud.netgear.com peernetwork.netgear.com readyshare.netgear.com

 

 

Model: RBK53|Orbi AC3000 Tri-band WiFi System, RBR50|Orbi AC3000 Tri-band WiFi Router, RBS50Y|High Performance AC3000 Outdoor WiFi Mesh Extender and Add-on Satellite
Message 1 of 18

Accepted Solutions
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

And by the way, do above steps on every devices (routers and satellites too).

 

Remember after enable root, you can telnet using 'root' account without password.  Highly advice, to change the root password immediately.  Also once you are done, please ensure you disable the telnet access.

 

Hopefully this works, any ideas, please let me know.

 

View solution in original post

Message 3 of 18

All Replies
FURRYe38
Guru

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

I believe telnet is not supported on v22 FW, you'll need to go back to v104 to get telnet then make changes to block FW updates. 

 

Has a factory reset and set up from scratch after last FW update? 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 2 of 18
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

And by the way, do above steps on every devices (routers and satellites too).

 

Remember after enable root, you can telnet using 'root' account without password.  Highly advice, to change the root password immediately.  Also once you are done, please ensure you disable the telnet access.

 

Hopefully this works, any ideas, please let me know.

 

Message 3 of 18
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Yes, telnet has been disabled, that's why i mention to downgrade first, before attempting to perform the steps.

 

The good news is *Nix based, so all the fun stuffs we can do in *Nix, are very applicable....

 

 

Message 4 of 18
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

I didn't do factory reset, but i did backup and restore....

I had to cold reboot, as it wouldn't pickup DHCP from the ISP until i did that....

 

The EULA has new wording where it required Auto Update

Message 5 of 18
FURRYe38
Guru

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Might try a factory reset next time you update FW IF a problem appears after FW is updated. Seen odd things after a FW update and sometimes, just a reset and setup from scratch is needed. 

 

Good luck. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 6 of 18
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Btw, Netgear figured out a way to override my changes, and this morning it came back forced upgraded to 2.7.3.22 again....

 

The real problem is a random drop connection during heavy load, anywhere from few seconds to a minute or so.

 

Is there anyways to schedule a reboot via cronjob or something on downtime (like Friday Midnight or something) ?

 

Message 7 of 18
FURRYe38
Guru

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Try putting on a power plug with a timer built in that offers scheduling. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 8 of 18
CrimpOn
Sensei

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5


@mbreksop wrote:

Btw, Netgear figured out a way to override my changes, and this morning it came back forced upgraded to 2.7.3.22 again....

The real problem is a random drop connection during heavy load, anywhere from few seconds to a minute or so.

Is there any way to schedule a reboot via cronjob or something on downtime (like Friday Midnight or something) ?


As I read through this post, it appears to me that there are several topics mixed together:

  • The newest firmware, V2.3.7.22, does not perform correctly.  It randomly drops connection during heavy load.
    It is difficult to diagnose a problem that occurs randomly.  If "heavy load" is definitely the cause, then it should be fairly simple to replicate the issue on demand by generating the required load.
  • Attempts to address the issue by manually installing previous firmware are frustrated by the Orbi auto-updating itself to V2.7.3.22.
  • There is a desire to force the Orbi to reboot at specified times.

One thing is pretty clear: Any attempt to block the Orbi from auto-updating by modifying parameters through the telnet command line will be erased the next time the Orbi reboots when the entire contents of working memory are replaced by the factory image.  The technique I favor, (which is simply replacing the root file firmware_version with a bigger than possible number) will fail on reboot. So will messing around with the hosts file or setting any parameters.

 

If a scheduled reboot is intended to address problems with V2.7.3.22 by rebooting the router, then using a timer is the answer. A chron job will disappear upon the first reboot, as will telnet access.  A WiFi smart plug stores the schedule on the plug itself.  (I have tested this.)  It could be told to turn the power off at 1:00AM on Friday and back on at 1:02AM on Friday, and it will do so.  Yes, it will lose WiFi for a couple of minutes, but it will do what it is supposed to do.

 

If the goal is to absolutely, positively, "no failures" prevent auto-update, then the only solution is to connect the Orbi to another router and use that router to block those Netgear web sites.

 

It is not clear to me when Netgear's EULA first mentioned allowing Netgear to update firmware without notice.  3-4 years ago, Netgear regularly 'pushed' firmware updates to Orbi and appeared to pause the practice after angry reactions from users.  The only way to check that would be to deliberately load some old firmware and look very closely at the EULA. 

I love my Orbi.
Message 9 of 18
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Finally, i think i solved this issue...

Here are the steps to reproduce:

1. Go https://www.opendns.com and sign up for an account

2. Create Network (usually already done)

3. Setup Web Content Filtering, you can choose 'Custom', then click on whatever you want to block, at the bottom add these entries to block individually: update.netgear.com, updates.netgear.com, updates1.netgear.com, updates2.netgear.com, updates3.netgear.com, http.fw.updates1.netgear.com, readycloud.netgear.com, peernetwork.netgear.com, readyshare.netgear.com --- see the pic attached

4. Grab their DNS Servers: 208.67.222.123 or 208.67.220.123

5. Go to your Orbi Router, and turn off Circle/Parental Control

6. Then click on 'Advanced' tab, 'Setup', 'Internet Setup', go to 'Domain Name Server (DNS) Address, and change it (normally it would have said 'Get Automatically from ISP' into ''Use These DNS Servers', and put the values in Number 4.  Apply.

7. Re-enable Circle (assuming you had it enabled).

8. Download older firmware, i use 2.3.5.34 --- https://kb.netgear.com/000061420/RBR50-RBS50-Firmware-Version-2-3-5-34-Hot-Fix

8.  Steps that some of you know already:  Downgrade Firmware, then Enable Telnet, Set NVRAM values, also you can update /etc/hosts ---- https://community.netgear.com/t5/Orbi/Disable-auto-update-of-orbi-firmware-additional-steps-needed/t...

9. Repeat the steps for Router and all satellites

10. Don't forget to disable Telnet

 

So far it hasn't changed back for, as the Status showed 'Update Failed'

 

 

 

Message 10 of 18
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

My status as of now, after several hours with older firmware

 

Message 11 of 18
CrimpOn
Sensei

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Very creative solution.  Bravo!

Is this a "free" OpenDNS account, or a paid account?

I love my Orbi.
Message 12 of 18
mbreksop
Star

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Free Account...

 

And yes it works, i just checked few minutes ago.

 

Both Router and Satellites shows 'Update Failed'.

 

Now I love my Orbi again.... 😉

Message 13 of 18
CrimpOn
Sensei

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

My "Bag of Tricks" is now almost complete!  Thanks.

 

The key to your fix is getting something written into that "read only" memory that is used to create the working image when the Orbi boots.

All of the previous gimmicks, such as setting paramters and the firmware_version hack do not survive a reboot.

Hmmmm. Wonder if it is possible to log in as root and get access to that protected space?  Something to look into.

I love my Orbi.
Message 14 of 18
jdr1274
Aspirant

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Kudos to you!! Your solution worked perfectly. Many thanks!!

Model: RBR50|Orbi AC3000 Tri-band WiFi Router, RBS50Y|High Performance AC3000 Outdoor WiFi Mesh Extender and Add-on Satellite
Message 15 of 18
olegen1982
Aspirant

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

Sorry, i don't understand this "4. Grab their DNS Servers: 208.67.222.123 or 208.67.220.123"

What i need to do?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 16 of 18
olegen1982
Aspirant

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5

If I have dynamic IP, is it working?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 17 of 18
CrimpOn
Sensei

Re: Disabling Auto Update (Force Update) firmware version 2.7.3.22 for Orbi 3000 (RBR, RBS and RBK 5


@olegen1982 wrote:

Sorry, i don't understand this "4. Grab their DNS Servers: 208.67.222.123 or 208.67.220.123"

What i need to do?


That means to click the option on the Internet Setup page to "Use these DNS Servers" rather than "Get Automatically from ISP" and type those two IP addresses for the DNS servers to use.

I love my Orbi.
Message 18 of 18
Top Contributors
Discussion stats
  • 17 replies
  • 1755 views
  • 7 kudos
  • 5 in conversation
Announcements

Orbi WiFi 6E