Reply

Re: Disney circle premium not working

Shady_Hamilton
Aspirant

Disney circle premium not working

Hello,

 

I am not able to run Disney Circle in Premium mode. i subscribed to the premium mode but whenever i open the circle app it start in basic mode.

i tried subscribing again but it says you are already subscribed.

i tried uninstall/reinstall but that didn't work too.

couple of times i opened the circle app and it showed me the premium version, but when i try to adjust anythign in the premium features it start loading (the circle in the middle of the screen) and it just go on and on. if i close it and start it again it goes back to basic mode.

 

can anybody help please,

 

thank you,

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 1 of 11
FURRYe38
Guru

Re: Disney circle premium not working

You might contact NG support and ask about this.

@DarrenM

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 2 of 11
Shady_Hamilton
Aspirant

Re: Disney circle premium not working

I contacted them but they had no clue. That is why i am posting here hoping somebody have an idea...
Message 3 of 11
FURRYe38
Guru

Re: Disney circle premium not working

Try this?

https://www.netgear.com/support/product/circle.aspx

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 4 of 11
Shady_Hamilton
Aspirant

Re: Disney circle premium not working

It took me to the play store and opened the same version i have
Message 5 of 11
FURRYe38
Guru

Re: Disney circle premium not working

I would contact one of the forum moderators and see if they can help.

@DarrenM

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 6 of 11
Shady_Hamilton
Aspirant

Re: Disney circle premium not working

how to do that please? i am new to the forum?

Message 7 of 11
FURRYe38
Guru

Re: Disney circle premium not working

Click on DarrenM name on my last post and it will take you to his page. Select send Private Message.

 

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 8 of 11
Shady_Hamilton
Aspirant

Re: Disney circle premium not working

I just did, many thanks Dear, hope he will be able to help. if i find a solution i will post it here

Message 9 of 11
FURRYe38
Guru

Re: Disney circle premium not working

Let us know how it turns out...

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 10 of 11
mossywell
Star

Re: Disney circle premium not working

Interesting. 

https://community.netgear.com/t5/Orbi/How-do-I-get-support-for-Orbi-Circle-Premium/m-p/1603233

I had the same problem. In my case support contacted me twice and took a ton of logs but were unable to fix it so I cancelled the premium subscription. 

Message 11 of 11
Top Contributors
Discussion stats
  • 10 replies
  • 1559 views
  • 0 kudos
  • 3 in conversation
Announcements