Reply
Apprentice

FIX - Orbi Firmware 2.2.1.210 Performance Issues

Hello Orbi Community,

 

If any of you are struggling with performance issues with your Orbi system that is currently running on FW version 2.2.1.210, you are not the only one. Countless amount of people have complained to Netgear about this issue and nothing has been done to resolve this. I looked through a ton of threads and it took me some time to put all kinds of codes together to block Orbi from auto-updating to FW version 2.2.1.210 after rolling it back to version 2.1.4.6.

 

So, without further ado, here's the solution:

  1. Enable telnet on each Orbi (Router and/or Satellite)
    • This can be accomplished by putting ip_address_orbi.debug.htm
    • EX: 192.168.1.20.debug.htm
  2. Telnet into each Orbi and/or Satellite
    1. For macOS, seek this link for assiatnce to get Telnet capabilities:
    2. For Windows, install a trusted program called PuTTY.
      • You'll see the telnet option.
  3. For each Orbi (Router and/or Satellite), you will need to do the following when telnetting into the unit:
    1. Input your username and password
      • Username: admin
      • Password: Same password you use to login to Orbi's dashboard
    2. Once you're successfully logged in, enter the following codes EXACTLY as listed. 
      • nvram set orbi_auto_upgrade=0
      • nvram set auto_check_for_upgrade=0
      • nvram set auto_update=0
      • nvram set orbi_auto_upg=0
      • nvram set orbi_auto_flag=0
      • nvram commit
        • If you forget to put any of these lines of code, your Orbi will fight you and auto-update to the 2.2.1.210 FW.
    3. End the telnet session
    4. Repeat this process until you have done this to every single Orbi unit you have in your network.
  4. Manually update the firmware on each Orbi unit
    1. Enter the IP address of each Orbi into your web browser
    2. Select "Firmware Update"
    3. Upload the 2.1.4.6 firmware
    4. When prompted with a message stating your uploading an older firmware, hit yes.
    5. Allow the Orbi to downgrade to the 2.1.4.6 firmware
    6. Repeat process for all Orbi units
  5. ENJOY A STABLE VERSION!

 

Hope this helps Orbi users near and far until Netgear can release a good, solid and stable firmware.

Take care! 😊

-TheOrbiMechanic
Message 1 of 13
Mentor

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

I was glad to see this post -- as it furthers understanding of what makes Orbi tick...

 

I was also thinking that it would be great to have a thread or series of threads that have a library of telnet functions as they apply to Orbi -- as well as html addresses that may be unknown (IP/debug as an example).

 

As an example, On a previous post of mine, there was a sequence of telnet commands that turned off the radio backhaul channel if you had wired backhaul.  I have seen several others to do some pretty interesting control/configurations.

 

I think it would be very useful to see all of those different types of commands in a central place.

---------------
My Equipment: Cox Cable (350Mb/35Mb), Orbi AX6000 (RBR850, 3 x RBS850) (2xWired backhaul), NG GS116PP Gigabit Smart Switch, Synology DS1019+ NAS
Message 2 of 13
Guru

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

v210 has some issues, however others are also having good experiences wtih v210:

https://community.netgear.com/t5/Orbi/How-i-solved-90-of-my-quot-some-devices-keep-disconnecting/m-p...
https://community.netgear.com/t5/Orbi/Firmware-2-2-1-210-released-as-of-10-3-18/m-p/1647303/highligh...

 

Seems to be some problems around how FW is getting applied via auto update. Others have reported also manually applying the FW files, factory reset and setup from scratch helps them get there systems working after the upgrade. 

 

You should try this if you didn't already. 

 

Others have also reported good experiences with out a reset as well:

https://community.netgear.com/t5/Orbi/Firmware-2-2-1-210-released-as-of-10-3-18/m-p/1649157/highligh...
https://community.netgear.com/t5/Orbi/Firmware-2-2-1-210-released-as-of-10-3-18/m-p/1648321/highligh...
https://community.netgear.com/t5/Orbi/Firmware-2-2-1-210-released-as-of-10-3-18/m-p/1649172/highligh...
https://community.netgear.com/t5/Orbi/Firmware-2-2-1-210-released-as-of-10-3-18/m-p/1649389/highligh...
https://community.netgear.com/t5/Orbi/Your-experience-with-Firmware-2-2-1-210-released-as-of-10-3-18...
https://community.netgear.com/t5/Orbi/Your-experience-with-Firmware-2-2-1-210-released-as-of-10-3-18...
https://community.netgear.com/t5/Orbi/Satellite-placement-help/m-p/1658715#M44442

 

I went over to my friends place to check his systema few weeks ago, it had auto updated. He had no complaints. System is working since day one when I installed it.

 

So it's just not always a FW issue. Other factors can contribute to bad operation of the Orbi. Users shouldn't have to downgrade fw, maybe as a last resort if ALL other troubleshooting has been exhausted. 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.16.22
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 3 of 13
Apprentice

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

I am very knowledgeable with Orbi and I have exhausted every single troubleshooting step I could find. Nothing fixed it. Daisy Chain was performing horribly, which caused my devices to have poor connection, even if I changed my WiFi channels, disabled Daisy chain, you name it. My system ran fine when Netgear released version 2.1.4.6 and thus is why I tried everything to roll it back and figured it may help others who are wanting to do the same.

 

As to why some are having no issues with the latest firmware, while some are, I have absolutely no clue. It could be a variety of things.

-TheOrbiMechanic
Message 4 of 13
Apprentice

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

@FURRYe38, I also tried factory resetting and starting setup from scratch. Nothing worked out for me. 😔

-TheOrbiMechanic
Message 5 of 13
Apprentice

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

To see pretty much every command you can do to Orbi via telnet, hit the tab key when you’re in a telnet session and your Orbi will populate all the commands available for you to utilize. At least that’s what I did one time when I was just trying to remotely resync an Orbi unit.

 

PS: Love that idea!

-TheOrbiMechanic
Message 6 of 13
Guru

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

Some have said that they noticed the Daisy Chain issue as well. It's been mentioned that Daisy Chain has been working or the UI check box is doing the opposite of what it should be doing. Check mark means Disabled, Un-Checked means enabled. This may have been an issue that would need to be checked. 

 

Ya I presume next FW upate all this will be fixed and should be a need to downgrade FW. 

Others can downgrade if they want to. For some advanced users sure. For other non advanced users, maybe not so much. Just wanted to let you know, others are having good operation with there systems on v210. 

 

Enjoy. 

 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.16.22
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 7 of 13
Apprentice

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

@FURRYe38, yes I am aware that some do have their systems running fine on version 2.2.1.210, but for me it wasn’t the case. Thus, is why I was in a pursuit to rollback the firmware and figured it might help others who wanted (or needed) to roll their system back.

 

Take care! Here’s to troubleshooting Orbi. 🙂

-TheOrbiMechanic
Message 8 of 13
Apprentice

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

@FURRYe38, I tried disabling the daisy chain as I also saw the same theories you mention. Unfortunately, it only made things worse on my end.

-TheOrbiMechanic
Message 9 of 13
Guru

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

Ok, Hopefully next FW upate will be good for you. 

We just love to troubleshoot the Orbi. Smiley Wink

Good Luck. 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.16.22
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 10 of 13
Initiate

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

Thanks for this!

 

I'm sure 2.2.1.210 is fine for other folks, but I was getting constant random reboots on 2.2.1.210 despite hard resetting and troubleshooting.

 

I did manage to stop my Orbi from auto updating to 2.2.1.210 with this method and have been running stable on the previous firmware (2.1.4.16).  Thanks!

 

My suggestion to Netgear still stands: please give us the option to turn off the auto update from within the GUI itself.  

 

Message 11 of 13
Guru

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

Looks like it will be forth coming:

https://community.netgear.com/t5/Orbi/ORBI-NEWSFLASH-Netgear-Disabling-Forced-Auto-Update-on-Upcomin...


@Jedarius wrote:

Thanks for this!

 

I'm sure 2.2.1.210 is fine for other folks, but I was getting constant random reboots on 2.2.1.210 despite hard resetting and troubleshooting.

 

I did manage to stop my Orbi from auto updating to 2.2.1.210 with this method and have been running stable on the previous firmware (2.1.4.16).  Thanks!

 

My suggestion to Netgear still stands: please give us the option to turn off the auto update from within the GUI itself.  

 


 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.16.22
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 12 of 13
Apprentice

Re: FIX - Orbi Firmware 2.2.1.210 Performance Issues

@Jedarius, I am pleased to hear that my solution has worked for you! Here's to continuing to troubleshooting the Orbi! Also, just got notified today by a Netgear representative that they will FINALLY be disabling forced auto-updates in the upcoming firmware releases!


@Jedarius wrote:

Thanks for this!

 

I'm sure 2.2.1.210 is fine for other folks, but I was getting constant random reboots on 2.2.1.210 despite hard resetting and troubleshooting.

 

I did manage to stop my Orbi from auto updating to 2.2.1.210 with this method and have been running stable on the previous firmware (2.1.4.16).  Thanks!

 

My suggestion to Netgear still stands: please give us the option to turn off the auto update from within the GUI itself.  


-TheOrbiMechanic
Message 13 of 13
Top Contributors
Discussion stats
  • 12 replies
  • 2874 views
  • 3 kudos
  • 4 in conversation
Announcements