Discussion stats
Announcements

Top Contributors
Reply
Highlighted

Firmware Version 2.5.1.8

Netgear have released a new firmware update for RBS50/RBR50 here:

 

https://kb.netgear.com/000061530/RBR50-RBS50-Firmware-Version-2-5-1-8 

 

No mention of specific fixes to device labelling and release notes seem identical to the update they pulled.  Also doesn't mention anything about the speed degredation many suffered with that now removed release.

 

Having been bitten with the last release, causing a rollback to the current "stable" (v2.3.5.30) release, I'm going to take a wait and watch approach to this one.  Interested to read the experience of more adventurous Orbi owners.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 89
Highlighted
Apprentice

Re: Firmware Version 2.5.1.8

New Features and Enhancements:
Enhances the device recognition mechanism of the attached devices list
Add DAL into firmware for several features, like DIL, Armor.
Include Fing for device recognition.

Bug Fixes:
Fixes the compatibility issue with Sonos devices.
Update the web server certification of RBR50/RBS40
Message 2 of 89
Highlighted
Apprentice

Re: Firmware Version 2.5.1.8

I'm also taking a wait & see position before updating to V 2.5.1.8.

 

BTW - I'm still using V 2.3.5.30 and when I log into the router & check for new firmware it indicates none.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 3 of 89
Highlighted
Aspirant

Re: Firmware Version 2.5.1.8

Yes, can some folks please confirm that the update is working - don't have hours of time to reboot, and reset backward if things go sideways. Thank you!

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 4 of 89
Highlighted
Luminary

Re: Firmware Version 2.5.1.8

I’ve only updated it and will wait and see.
Message 5 of 89
Highlighted
Tutor

Re: Firmware Version 2.5.1.8

New Features and Enhancements:

  • Enhances the device recognition mechanism of the attached devices list
  • Add DAL into firmware for several features, like DIL, Armor.
  • Include Fing for device recognition.

Bug Fixes:

  • Fixes the compatibility issue with Sonos devices.
  • Update the web server certification of RBR50/RBS40
Message 6 of 89
Highlighted
Guru

Re: Firmware Version 2.5.1.8

FYI:

https://community.netgear.com/t5/Orbi/Firmware-v2-5-1/m-p/1837488/highlight/true#M78401

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 7 of 89
Highlighted
Initiate

Re: Firmware Version 2.5.1.8

Updated to 2.5.1.8... Renamed a few devices and they seem to be sticking. Refreshed multiple times and the names are holding true.
Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 8 of 89
Highlighted
Apprentice

Re: Firmware Version 2.5.1.8

And here we are in mid December with Version 2.5.1.8 and the security certificate has still not been fixed since Aug 2019. Chrome, Firefox & Microsoft Edge all indicate the certificate is not to be trusted.

 

netgear_certificate.jpg

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 9 of 89
Highlighted
Guide

Re: Firmware Version 2.5.1.8

good for me also.

 

improved DL/UL rates on iPads.

 

Message 10 of 89
Highlighted
Guide

Re: Firmware Version 2.5.1.8

works for me, only been <24hr but its working ( saying that i have never had any major problemns apart from naming and icons in the app, in the past)

Message 11 of 89
Highlighted
Retired_Member
Not applicable

Re: Firmware Version 2.5.1.8

A word of caution......IF your system is working, you may be better off NOT installing any manual firmware update.

Message 12 of 89
Highlighted
Apprentice

Re: Firmware Version 2.5.1.8

Just updated manually and the only real change I noticed is that the web interface is significantly faster. After 2 years this thing is now almost at the speed of my old R7000 with XWRT

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 13 of 89
Highlighted
Guru

Re: Firmware Version 2.5.1.8

Saw same after loading this new version. No issues now with device naming or certification. 


@Durpquad wrote:
Updated to 2.5.1.8... Renamed a few devices and they seem to be sticking. Refreshed multiple times and the names are holding true.

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 14 of 89
Highlighted
Initiate

Re: Firmware Version 2.5.1.8

Its been a very bad experience thus far.  I have had Orbi for over 2 years.  I do not believe there has ever been a very good firmware.  Between Ethernet Backhaul issues to reboots, etc.  

 

Brings us to 2.5.x.x

 

I first tried the failed 2.5.0.40 and had all the issues people already reported.  I downgraded back to 2.3.5.34 and was back to my original state. (I have noticed decreased performance on the 2.3.5.x code hence my desire to upgrade and test out the new codes.)

 

So 2.5.1.8 came out, waited a few days read what appeared positive results.  UGGG.  

Positives - Performace does seem to be back up - note this isnt anything better than long ago firmware, but better than the last few iterations.  Devices on Sweet Spots back up to 300-500mpbs range.  Speedofme showing consistent MAX DL/UL on clients in several locations in my home.  My max is about 125DL/8UL which is my broadband limitation.  And that will do it for positives.

 

Negatives/Issues:

Oh boy..  

1st  - my RBS40V running V2.3.6.4 Latest FW for that device, also that FW worked with other RBR images. Now in GUI shows disconnected.  The Orbi APP shows connected and I can confirm I have working devices through the Satellite.  So this is more a cosmetic PIA issue.  This happened on 2.5.0.40, so this is a return of that bug.  Makes it difficult to see what is going on with the Mesh when  you cant view devices and status of Satellite.  

2nd - This is not specific to this software just fed up with this no longer working for over a year - using manual DNS servers with DHCP for ISP hasnt worked for a very long time.  The option is grayed out if you use DHCP for the WAN/ISP address.   I use to use DHCP for WAN/ISP and still was allowed to use DNS custom settings. 

3rd - Attached devices in GUI or App.  I only see about 10-11 devices all stating wired or connected to the RBR.  I have approximately 42 devices on my network which are working as far as I can tell.   When I go directly to the satellites I see a couple more.  But no where to be seen is about 25-30 devices. Yet they work.  This also carries over to ACCESS control. Since they are not shown I cannot block devices as needed.  

4th - DHCP - I am not 100% sure at this time but the GUI shows my that devices are not using the DHCP reservations I assigned for them.  Again I can only see a few of the devices on the App/GUI, but the ones I do see report using IPs not reserved nor in the DHCP scope.  AHHH..

5th - Device Naming.  Contrary to what others report - I am unable to save manual names.  It just shows the Orbi selected name.  I tried on the App as well and that showed it at least saved the name, but then when it refreshed right back to the incorrect name.  Another related frustration - I have devices that traded names by default -  A QNAP NAS is now named Fire tv 3rd generation.  Again Orbi assigned the names and I cant change.  Also funny in a sad way - Netgear switches are mislabeled as well.

 

So I recommend staying on the 2.3.5.x until they can MAYBE get a working FW with performance and helpful names etc.  Or I recommend just moving on from Orbi.

 

BTW I normally dont factory reset my RBR after upgrades as that has never worked to improve things nor fix the bugs.  I decided this time to try and of course no change in any of the behaviors.  I factory reset all devices and built config from scratch.  The issues were right out of the gate.

 

Setup:

RBR50  

RBS50   - Ethernet Backhauled

RBS40V - Wireless Backhauled

Daisy chain disabled.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router, RBS40V|Orbi Voice Add-on WiFi Satellite and Smart Speaker
Message 15 of 89
Highlighted
Guru

Re: Firmware Version 2.5.1.8

Has a factory reset and setup from scratch been performed since the FW update? This maybe needed. Lets try this first and clear everything out and start from scratch. Also be sure to clear our all browser caches before entering into the RBRs web page. 

 

What browser are you using? Try IE11, FireFox or Opera. I've been using Opera and changing device names is working for me here.

 

What is the mr and model# of your ISP modem? 

I can select "Use These" from the Internet Setup section and there not grayed out for me:

Untitled.png


@Lydosine wrote:

Its been a very bad experience thus far.  I have had Orbi for over 2 years.  I do not believe there has ever been a very good firmware.  Between Ethernet Backhaul issues to reboots, etc.  

 

Brings us to 2.5.x.x

 

I first tried the failed 2.5.0.40 and had all the issues people already reported.  I downgraded back to 2.3.5.34 and was back to my original state. (I have noticed decreased performance on the 2.3.5.x code hence my desire to upgrade and test out the new codes.)

 

So 2.5.1.8 came out, waited a few days read what appeared positive results.  UGGG.  

Positives - Performace does seem to be back up - note this isnt anything better than long ago firmware, but better than the last few iterations.  Devices on Sweet Spots back up to 300-500mpbs range.  Speedofme showing consistent MAX DL/UL on clients in several locations in my home.  My max is about 125DL/8UL which is my broadband limitation.  And that will do it for positives.

 

Negatives/Issues:

Oh boy..  

1st  - my RBS40V running V2.3.6.4 Latest FW for that device, also that FW worked with other RBR images. Now in GUI shows disconnected.  The Orbi APP shows connected and I can confirm I have working devices through the Satellite.  So this is more a cosmetic PIA issue.  This happened on 2.5.0.40, so this is a return of that bug.  Makes it difficult to see what is going on with the Mesh when  you cant view devices and status of Satellite.  

2nd - This is not specific to this software just fed up with this no longer working for over a year - using manual DNS servers with DHCP for ISP hasnt worked for a very long time.  The option is grayed out if you use DHCP for the WAN/ISP address.   I use to use DHCP for WAN/ISP and still was allowed to use DNS custom settings. 

3rd - Attached devices in GUI or App.  I only see about 10-11 devices all stating wired or connected to the RBR.  I have approximately 42 devices on my network which are working as far as I can tell.   When I go directly to the satellites I see a couple more.  But no where to be seen is about 25-30 devices. Yet they work.  This also carries over to ACCESS control. Since they are not shown I cannot block devices as needed.  

4th - DHCP - I am not 100% sure at this time but the GUI shows my that devices are not using the DHCP reservations I assigned for them.  Again I can only see a few of the devices on the App/GUI, but the ones I do see report using IPs not reserved nor in the DHCP scope.  AHHH..

5th - Device Naming.  Contrary to what others report - I am unable to save manual names.  It just shows the Orbi selected name.  I tried on the App as well and that showed it at least saved the name, but then when it refreshed right back to the incorrect name.  Another related frustration - I have devices that traded names by default -  A QNAP NAS is now named Fire tv 3rd generation.  Again Orbi assigned the names and I cant change.  Also funny in a sad way - Netgear switches are mislabeled as well.

 

So I recommend staying on the 2.3.5.x until they can MAYBE get a working FW with performance and helpful names etc.  Or I recommend just moving on from Orbi.

 

BTW I normally dont factory reset my RBR after upgrades as that has never worked to improve things nor fix the bugs.  I decided this time to try and of course no change in any of the behaviors.  I factory reset all devices and built config from scratch.  The issues were right out of the gate.

 

Setup:

RBR50  

RBS50   - Ethernet Backhauled

RBS40V - Wireless Backhauled

Daisy chain disabled.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 16 of 89
Highlighted
Initiate

Re: Firmware Version 2.5.1.8

Furry - As stated - I did a complete factory reset as stated in my post.  Also rebuilt configuration.  Using Chrome. And as I stated I also tried the Orbi App (iOS) and cant rename there as well so its not just a browser issue.   

 

I am very much willing to bet I am not the only one with these issues.  I suspect as I did with the other 2.5.0.40 this FW will be pulled again.  Furry somehow you never have issues. I think you also stated 2.5.0.40 was good.  Anyway thanks but this needs NG to fix.

Message 17 of 89
Highlighted
Guru

Re: Firmware Version 2.5.1.8

Next time try a different browser. Others are also having same experience so I'm not the only one either. 

 

Both v38 and v40 also has the problem.  

 

Good Luck. 


@Lydosine wrote:

Furry - As stated - I did a complete factory reset as stated in my post.  Also rebuilt configuration.  Using Chrome. And as I stated I also tried the Orbi App (iOS) and cant rename there as well so its not just a browser issue.   

 

I am very much willing to bet I am not the only one with these issues.  I suspect as I did with the other 2.5.0.40 this FW will be pulled again.  Furry somehow you never have issues. I think you also stated 2.5.0.40 was good.  Anyway thanks but this needs NG to fix.


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 18 of 89
Highlighted
Luminary

Re: Firmware Version 2.5.1.8

So far so good on this firmware. What do others think? It only took me having to email the CEO and CTO to get it resolved once and for all 🙄
Message 19 of 89
Highlighted
Guide

Re: Firmware Version 2.5.1.8

Successfully upgraded RBR50 and 2 RBS50 to 2.5.1.8 . Renaming and identification of devices is working fine for me. 40+ devices including Light bulbs, thermostats , outlets etc ! My RBW30 remains at the 2.3.5.6 level. Speeds seems consistent and steady .

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 20 of 89
Highlighted
Prodigy
Prodigy

Re: Firmware Version 2.5.1.8

 

root@RBR50:/# cat /tmp/satellite_device_info
[{
                "mac address":  "XXXX",
                "ip address":   "192.168.1.252",
                "module name":  "RBS50",
                "serial number":        "12345",
                "signal strength":      "-56",
                "current version":      "V2.5.1.8",
                "backhaul status":      "2",
                "device name":  "Orbi Satellite-1"
        }, {
                "mac address":  "YYYY",
                "ip address":   "192.168.1.253",
                "module name":  "RBS50",
                "serial number":        "6789",
                "signal strength":      "-59",
                "current version":      "V2.5.1.8",
                "backhaul status":      "2",
                "device name":  "Orbi Satellite-2"
        }]

// 2.4GHz backhaul
root@RBR50:/# wlanconfig ath01 list CHAN TXRATE RXRATE RSSI MINRSSI MAXRSSI
8 300M 270M 35 27 45
8 300M 135M 36 26 45

// 5GHz backhaul
root@RBR50:/# wlanconfig ath2 list CHAN TXRATE RXRATE RSSI MINRSSI MAXRSSI
157 1300M 1300M 40 33 47
157 975M 975M 36 26 42

 

V2.5.1.8 SpeedTest.png

 

v2.5.1.8 has been consistent/stable/smooth sailing vs. v2.5.0.38/40.  I don't rename devices, so can't comment on that.  Performance is making a comeback!

 

Message 21 of 89
Highlighted
Tutor

Re: Firmware Version 2.5.1.8

Having updated at the date of released. Problems:
1. No devices shown connected in the Network map.
2. FaceTime call and Skype call dropped or frozen more frequently.
I rolled the router RBR50 firmware back to 2.3.4.34AU RBS50 remains 2.5.1.8, problems mentioned seems resolved. Will keep an eye on this forum to determine when to proceed the update. BTW, the firmware update notification is shown either in the Orbi Apps or the browser login from a MacBook.
Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 22 of 89
Highlighted
Guide

Re: Firmware Version 2.5.1.8

I'd avoid updating to this latest firmware. It attempted to update to that version during the initial setup process and it bricked the system!  I highly recommend a wait and see approach as it has some OBVIOUS problems.  

 

Message 23 of 89
Highlighted
Guide

Re: Firmware Version 2.5.1.8

Since upgrading my RBR50 and RBS50 to firmware v2.5.1.8, I am no longer able to view any connected devices on either router or satellite Using the IOS ORBI app.

Most but not all connected devices are viewable in the Web Interface.

Can anyone advise what I can do to correct this?
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 24 of 89
Highlighted
Tutor

Re: Firmware Version 2.5.1.8

I encountered the same problem. So I manually downgraded the RBR50 router to 2.3.5.34 but the satellite is still with the 2.5.1.8
The devices map comes back, wait for a solutions or next version firmware.

Regards
Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 25 of 89