Reply

Has Netgear fixed the iOS and macOS issues?

Arjan1000
Guide

Has Netgear fixed the iOS and macOS issues?

I have had the Netgear Orbi at the beginning of this year. On that moment the product suffered from a lot of disconnects for ios and mac-os devices. In potential it's a great product but i am curious if I could buy this product again because the apple related issues are gone?

 

Any thoughts?

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 6
nirvana
Initiate

Re: Has Netgear fixed the iOS and macOS issues?

I haven't had disconnect issues (on any of the firmware) but currently, the bandwidth on the iPhones is horrible relative to computers. The speed test on laptops (wireless) and a Linux desktop (wired) get 100Mbps+ but the iPhone 6 gets maybe 10-20Mbps. Granted that is still fine for most uses, but the 2.0.0.74 firmware did show a lower speed for the iPhone.

Message 2 of 6
st_shaw
Master

Re: Has Netgear fixed the iOS and macOS issues?

No issues for nine months with iOS and MacOS devices.  I recently measured 470 Mbps average data throughput on my iPhone 7+ as well.  I haven’t measured throughput on the .74 firmware yet. 

Message 3 of 6
Mrgoodall
Star

Re: Has Netgear fixed the iOS and macOS issues?

I've had mine for since February or so, and have had no ios/MacOs specific issues. And it simply blazes. Im running the latest firmware with no issues.

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 4 of 6
aaz
Virtuoso
Virtuoso

Re: Has Netgear fixed the iOS and macOS issues?

Not sure why your speed is so slow on iPhone 6 - I am testing right now on iPhone 6 and it's giving me 154/16.8 which actually exceeds my cable internet speed contract. You may want to select a different server to test with on the speedtest.net app.

Message 5 of 6
DavePDX
Aspirant

Re: Has Netgear fixed the iOS and macOS issues?

Having just updated to firmware 2.x, I was quite surprised to see truly dismal speeds on my iPhone 7.  I have 1 Gb fiber, and on my wired devices have a solid 940 Mbps both directions.  On my MBP retina, I routinely get 480 wirelessly.  However, on the iPhone 7, I was only getting about 25 or 30, even after rebooting the phone. I didn't matter how close I was to the main Orbi or Satellite.  Finally, I tried rebooting the main Orbi, and my speed on the iPhone 7 topped out at an amazing 542 Mbps!

 

I don't understand why my other devices were unaffected nor why the previous reboot didn't have this affect, but was glad to solve the problem.  Maybe worth a try.

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 892 views
  • 1 kudo
  • 6 in conversation
Announcements

Orbi WiFi 6E