Reply

Re: How to disable WiFi on the Orbi Router or Satellite

yata001
Star

How to disable WiFi on the Orbi Router or Satellite

Enable on telnet on the router or satellite

  • For the router, go to http://192.168.1.1/debug.htm
  • For a statellite, log into the router, copy the IP address of the satellite, and go to http://<satellite ip>/debug.htm
  • Check Enable Telnet

 

Telnet to the router or satellite

  • Use telnet from the command line or terminal (use nc if on the latest macOS)
  • Enter the admin username and password

 

Disable the wifi band by entering the following commands

  • For 2.4Ghz band use
    1. config set endis_wl_radio=0
    2. ifconfig $(config get wl2g_NORMAL_AP) down
  • For the 5Ghz band use
    1. config set endis_wla_radio=0
    2. ifconfig $(config get wl5g_NORMAL_AP) down
  • For the guest 2.4Ghz band use
    1. config set wlg1_endis_guestNet=0
    2. ifconfig $(config get wl2g_NORMAL_AP) down
  • For the guest 5Ghz band use
    1. config set wla1_endis_guestNet=0
    2. ifconfig $(config get wl5g_GUEST_AP) down

The first command will disable the wifi monitoring for the band and the second command will shutdown the band itself.

The config command write to the nonvolatile memory so the settings will still be there after a restart.

Model: RBK53| Orbi Router + 2 Satellites Orbi WiFi System
Message 1 of 23
Barney67
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

On firmware V2.2.1.210 I was unable to disable the 2.4GHz channel using this procedure. Is it still valid?

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 2 of 23
ekhalil
Master

Re: How to disable WiFi on the Orbi Router or Satellite


@Barney67 wrote:

On firmware V2.2.1.210 I was unable to disable the 2.4GHz channel using this procedure. Is it still valid?


Yes, should be valid. Please make sure to reboot the node after you do the procedure.

Only one small correction to the well described procedure above (in red text below) 🙂

  • For 2.4Ghz band use
    1. config set endis_wl_radio=0
    2. ifconfig $(config get wl2g_NORMAL_AP) down
  • For the 5Ghz band use
    1. config set endis_wla_radio=0
    2. ifconfig $(config get wl5g_NORMAL_AP) down
  • For the guest 2.4Ghz band use
    1. config set wlg1_endis_guestNet=0
    2. ifconfig $(config get wl2g_GUEST_AP) down
  • For the guest 5Ghz band use
    1. config set wla1_endis_guestNet=0
    2. ifconfig $(config get wl5g_GUEST_AP) down

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750, Wired/Wireless Backhaul / Orbi RBR50 + 6x RBS50 + RBS40V, Wired/Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 3 of 23
ekhalil
Master

Re: How to disable WiFi on the Orbi Router or Satellite


@Barney67 wrote:

On firmware V2.2.1.210 I was unable to disable the 2.4GHz channel using this procedure. Is it still valid?


Yes, should be valid. Just please make sure to reboot the node after applying the procedure.

Just a small correction to the well described procedure above (in red text below😞 🙂

  • For 2.4Ghz band use
    1. config set endis_wl_radio=0
    2. ifconfig $(config get wl2g_NORMAL_AP) down
  • For the 5Ghz band use
    1. config set endis_wla_radio=0
    2. ifconfig $(config get wl5g_NORMAL_AP) down
  • For the guest 2.4Ghz band use
    1. config set wlg1_endis_guestNet=0
    2. ifconfig $(config get wl2g_GUEST_AP) down
  • For the guest 5Ghz band use
    1. config set wla1_endis_guestNet=0
    2. ifconfig $(config get wl5g_GUEST_AP) down

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750, Wired/Wireless Backhaul / Orbi RBR50 + 6x RBS50 + RBS40V, Wired/Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 4 of 23
yata001
Star

Re: How to disable WiFi on the Orbi Router or Satellite

Thanks for the correction.

 

The settings work on the latest firmware, V2.2.1.210. Also, you have to apply the settings to every router and satellite if you want to disable 2.4GHz entirely. To check that the settings were applied, run the command "config get endis_wl_radio" and make sure it returns 0. Also run "iwconfig $(config get wl2g_NORMAL_AP)" and verify that Access Point is Not-Associated.

 

If you're willing to try something untested, it appears that the entire 2.4 and 5GHz bands can be disable from the web interface. You have to log into the router and navigate to Advanced -> Advanced Settings -> Wireless Settings. Then open the web console in firefox (Developer Tools then Console for Chrome) and enter the following and press return:

document.getElementById("formframe").contentWindow.document.querySelectorAll("[style='display:none']").forEach(i => i.removeAttribute("style"))

 

This should show all the hidden elements including the "Enable Wireless Router Radio" checkboxes for 2.4 and 5GHz. You can uncheck and press Apply.

 

It seems to conflict with the first procedure so I haven't really tested to see if it works.

 

Message 5 of 23
Barney67
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

Hi,

 

Ok can confirm this is NOT disabling the 2.4 Wifi on the router.

 

I do the following:

 

config set endis_wl_radio=0

config get endis_wl_radio (Returns 0)

ifconfig $(config get wl2g_NORMAL_AP) down

config commit

reboot

 

config get endis_wl_radio (Returns 1 after reboot)

 

I do have different SSID for 2.4 and 5GHz Networks if this makes a difference.

I have the satellite turned off during the test.

 

Message 6 of 23
Barney67
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

I should add I get the same result using the webpage

 

The 2.4GHz radio does turn off, but comes back after a power restart. Same result if i use the checkbox on the web interface. Thanks for your help.

Message 7 of 23
FURRYe38
Guru

Re: How to disable WiFi on the Orbi Router or Satellite

Sounds like this modification is not supported in the FW and is only temporary and doesn't persist past a reboot. 


@Barney67 wrote:

I should add I get the same result using the webpage

 

The 2.4GHz radio does turn off, but comes back after a power restart. Same result if i use the checkbox on the web interface. Thanks for your help.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RBK752(v.5) | Switches NG GS105/8 and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 8 of 23
simonking
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

I opened the Orbi Wireless Settings webpage in Developer Mode in Google Chrome and can confirm that disabling and reenabling the 5Ghz channel works.

 

Thanks for this great find 🙂 

Message 9 of 23
ekhalil
Master

Re: How to disable WiFi on the Orbi Router or Satellite


@Barney67 wrote:

Hi,

 

Ok can confirm this is NOT disabling the 2.4 Wifi on the router.

 

I do the following:

 

config set endis_wl_radio=0

config get endis_wl_radio (Returns 0)

ifconfig $(config get wl2g_NORMAL_AP) down

config commit

reboot

 

config get endis_wl_radio (Returns 1 after reboot)

 

I do have different SSID for 2.4 and 5GHz Networks if this makes a difference.

I have the satellite turned off during the test.

 


I tested this procedure now. The command "ifconfig $(config get wl2g_NORMAL_AP) down" does not work for some reason. Instead follow the following procedure:

  • For 2.4Ghz band use
    1. config set endis_wl_radio=0
    2. config get wl2g_NORMAL_AP --> Get the prontout (should be ath0)
    3. ifconfig ath0 down --> Or use the output from command in point 2 above
  • For the 5Ghz band use
    1. config set endis_wla_radio=0
    2. config get wl5g_NORMAL_AP --> Get the prontout (should be ath1)
    3. ifconfig ath1 down --> Or use the output from command in point 2 above
  • For the guest 2.4Ghz band use
    1. config set wlg1_endis_guestNet=0
    2. config get wl2g_NORMAL_AP --> Get the prontout (should be ath0)
    3. ifconfig ath0 down --> Or use the output from command in point 2 above
  • For the guest 5Ghz band use
    1. config set wla1_endis_guestNet=0
    2. config get wl5g_GUEST_AP --> Get the prontout (should be ath11)
    3. ifconfig ath11 down --> Or use the output from command in point 2 above

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750, Wired/Wireless Backhaul / Orbi RBR50 + 6x RBS50 + RBS40V, Wired/Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 10 of 23
troytemplin
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

This worked perfectly but if I want to turn it back on what are the commands?

Message 11 of 23
ekhalil
Master

Re: How to disable WiFi on the Orbi Router or Satellite


@troytemplin wrote:

This worked perfectly but if I want to turn it back on what are the commands?


  • To disable: For 2.4Ghz band use
    1. config set endis_wl_radio=0
    2. config get wl2g_NORMAL_AP --> Get the prontout (should be ath0)
    3. ifconfig ath0 down --> Or use the output from command in point 2 above
  • To enable back: For 2.4Ghz band use
    1. config set endis_wla_2nd_radio=1
    2. config set wl2g_NORMAL_AP=ath0
    3. ifconfig ath0 up

-------------------------------------------------------------

  • To diable: For the 5Ghz band use
    1. config set endis_wla_radio=0
    2. config get wl5g_NORMAL_AP --> Get the prontout (should be ath1)
    3. ifconfig ath1 down --> Or use the output from command in point 2 above
  • To enable back: For 5Ghz band use
    1. config set endis_wla_2nd_radio=1
    2. config set wl5g_NORMAL_AP=ath1
    3. ifconfig ath1 up

-------------------------------------------------------------

  • To disable: For the guest 2.4Ghz band use
    1. config set wlg1_endis_guestNet=0
    2. config get wl2g_GUEST_AP --> Get the prontout (should be ath02)
    3. ifconfig ath02 down --> Or use the output from command in point 2 above
  • To enable back: For the guest 2.4Ghz band use
    1. config set endis_wla_2nd_radio=1
    2. config set wl2g_GUEST_AP=ath02
    3. ifconfig ath02 up

-------------------------------------------------------------

  • To disable: For the guest 5Ghz band use
    1. config set wla1_endis_guestNet=0
    2. config get wl5g_GUEST_AP --> Get the prontout (should be ath11)
    3. ifconfig ath11 down --> Or use the output from command in point 2 above
  • To enable back: For the guest 5Ghz band use
    1. config set endis_wla_2nd_radio=1
    2. config set wl5g_GUEST_AP=ath11
    3. ifconfig ath11 up

 

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBR850 + RBS850 + 2x RBS750, Wired/Wireless Backhaul / Orbi RBR50 + 6x RBS50 + RBS40V, Wired/Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 12 of 23
xtract
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

I have tested this on my RBK50, specifically disabling the 2.4ghz radio on JUST the RBR50 and not the satelitte, and have an issue. I can see that when I run the command "ifconfig ath0 down", that mostly all 2.4ghz devices do move to the satellite. My issue is that, there are still a couple of devices that connect to the RBR50 on 2.4ghz (I'm guessing because they use the MAC of the radio as well to connect?) BUT, using a scanner, I can see that even when the radio is 'shut down' using that command and 98% of the 2.4ghz devices move to the satellite, that the RBR50 is still broadcasting, but just pushing 2.4ghz devices to the satellite. Any ideas why it woud be doing this? Basically, putting ath0 in a down state does not seem to actually shut down the radio that ath0 is..almost as if it is some sort of software cutoff that blocks 2.4ghz devices.

 

I'd like to be able to have my base and satelllite push 5ghz and only the satellite push 2.4ghz. Meaning I should be able to run a network scan and only see one instance of my network in the 2.4ghz spectrum coming from the satellite.

Message 13 of 23
icalks
Tutor

Re: How to disable WiFi on the Orbi Router or Satellite

This is insane. Disabling the 2.4GHz or 5GHz channel should be as easy as going to wifi settings and doing so. Is anyone from Orbi/Netgear monitoring this thread? Please fix this interface shortcoming.
Message 14 of 23
FURRYe38
Guru

Re: How to disable WiFi on the Orbi Router or Satellite

You can disable the WiFi SSID broadcast only. Disabling of either radio is not officially supported by any other means. This is not a bug. 


@icalks wrote:
This is insane. Disabling the 2.4GHz or 5GHz channel should be as easy as going to wifi settings and doing so. Is anyone from Orbi/Netgear monitoring this thread? Please fix this interface shortcoming.

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RBK752(v.5) | Switches NG GS105/8 and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 15 of 23
rootard
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

Hello

 

I want to switch off the router at night. As there's no such option in the interface I've made a series of attempts using ifconfig + crontab.

 

I've listed all interfaces on my RBR20, there are plenty more including NetGear_Hidden: sync channels?

wl2g_NORMAL_AP is ath0 and wl5g_NORMAL_AP is ath2

 

root@RBR20:~/mnt/circle/localinit# iwconfig

ath02 IEEE 802.11b ESSID:"NETGEAR-Guest"
Mode:Master Frequency:2.472 GHz Access Point: Not-Associated

ath12 IEEE 802.11ac ESSID:"NETGEAR-Guest"
Mode:Master Frequency:5.54 GHz Access Point: Not-Associated

ath0 IEEE 802.11ng ESSID:"MYSSID"
Mode:Master Frequency:2.472 GHz Access Point: XX:XX:XX:XX:XX:XX

ath1 IEEE 802.11ac ESSID:"MYSSID"
Mode:Master Frequency:5.54 GHz Access Point: XX:XX:XX:XX:XX:XX

ath2 IEEE 802.11ac ESSID:"MYSSID"
Mode:Master Frequency:5.18 GHz Access Point: XX:XX:XX:XX:XX:XX

ath01 IEEE 802.11ng ESSID:"NETGEAR_ORBI_hidden76"
Mode:Master Frequency:2.472 GHz Access Point: XX:XX:XX:XX:XX:XX

ath11 IEEE 802.11ac ESSID:"NETGEAR_ORBI_hidden76"
Mode:Master Frequency:5.54 GHz Access Point: XX:XX:XX:XX:XX:XX

ath21 IEEE 802.11ac ESSID:"NETGEAR-Guest"
Mode:Master Frequency:5.18 GHz Access Point: Not-Associated

 

When I switch off the satellite then ifconfig down as above I can still see my SSID and the attached devices keep on working !

Worse, after a couple of seconds the APs move back from Not-Associated to their original ON state

iwconfig ath2 power off does'nt work either...

 

Netgear Please fix this !

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 16 of 23
CrimpOn
Guru

Re: How to disable WiFi on the Orbi Router or Satellite


@rootard wrote:

I want to switch off the router at night. As there's no such option in the interface I've made a series of attempts using ifconfig + crontab.


Does "switch off the router" mean or "turn off the WiFi but leave wired devices working normally"?  Like any other electronic device, the Orbi router can be powered off a timer or even a switched electrical outlet.

I love my Orbi.
Message 17 of 23
rootard
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

@CrimpOn Yes the device is inside my bedroom so I'd like to switch the wifi on/off programmatically at night while leaving it live for extra features (switch, dhcp, named...)

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 18 of 23
CrimpOn
Guru

Re: How to disable WiFi on the Orbi Router or Satellite


@rootard wrote:

Yes the device is inside my bedroom so I'd like to switch the wifi on/off programmatically at night while leaving it live for extra features (switch, dhcp, named...)


Apart from killing access for all of the Internet of Things (IoT) devices in the entire house (thermostat, smoke alarms, Ring doorbells, security cameras, etc.)... is there a special significance to the Orbi being in the bedroom?

I love my Orbi.
Message 19 of 23
rootard
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

I'm concerned with the potential impacts of wifi signals on our health as along with DECT phones it's one of the most nocive waves. I'm living in a small apartment with 2 levels. The router is at the floor level close to the internet access, it's not strong enough to reach 1st floor through the concrete floor. On level 1 I only have bedrooms  so the satellite is inside the central one.

 

Still I'm surprised that Netgear doesn't propose a way to schedule wifi opeating hours as this feature can be found on far less expensive access points. I'll also expect an OS command to be available out of the box and it's not the case

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 20 of 23
yeahman
Tutor

Re: How to disable WiFi on the Orbi Router or Satellite

I agree with you, one should be able to disable all wifi on a schedule - really a simple feature..... 

Message 21 of 23
strikelight
Aspirant

Re: How to disable WiFi on the Orbi Router or Satellite

Has anyone been able to get this to work on the latest firmware?  When disabling on a satellite (connected via wireless backhaul), I've found as soon as I switch the normal bands off using this, The router will start reporting that the connection to the satellite is poor, and eventually disconnect it from the setup.

Message 22 of 23
FURRYe38
Guru

Re: How to disable WiFi on the Orbi Router or Satellite

Disabling WiFi signals on Orbi systems is not supported by NG. Thus we can presume that any attempts would lead to bad operation of the system. Would be not advised to attempt to modify this. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RBK752(v.5) | Switches NG GS105/8 and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 23 of 23
Top Contributors
Discussion stats
  • 22 replies
  • 22987 views
  • 12 kudos
  • 12 in conversation
Announcements

Orbi WiFi 6E