Discussion stats
  • 6 replies
  • 693 views
  • 1 kudo
  • 2 in conversation
Announcements

Top Contributors
Reply
Highlighted
Guide

MY Products all have red cross

I've noticed when I've logged into the netgear website and looked at my products, they all have a red cross under hardware, phone support, chat support and email support.

 

Does this mean that even though I've had the product less than 1 year that Netgear are not providing me with any form of support under the 2 year warranty if it is needed?

 

 

Model: RBK53| Orbi Router + 2 Satellites Orbi WiFi System
Message 1 of 7
Highlighted
Master

Re: MY Products all have red cross

The Phone, Chat and Email support are only for the first 90 days. But I think you should have a green tick under hardware if you had the product less than one year.

I have the same situation and this is how my Netgear page look like now:

Namnlöst 2.png

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 2 of 7
Highlighted
Guide

Re: MY Products all have red cross

mine all have 3 stars

 

purchased june 2018

orbi.JPG

Message 3 of 7
Highlighted
Master

Re: MY Products all have red cross


@walkerx wrote:

mine all have 3 stars

 

purchased june 2018

 


Then I think you need to contact NG regarding this. May be @Blanca_O can kindly help with this? Smiley Happy

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 4 of 7
Highlighted
Guide

Re: MY Products all have red cross


@ekhalil wrote:

@walkerx wrote:

mine all have 3 stars

 

purchased june 2018

 


Then I think you need to contact NG regarding this. May be @Blanca_O can kindly help with this? Smiley Happy


Netgear won't let me contact them via email regarding this, so I've just contacted Amazon about it, advising of the issue with the single satellite and that according to netgear I have no warranty on the product, when there should be 2 years for UK users.

Message 5 of 7
Highlighted
Master

Re: MY Products all have red cross


@walkerx wrote:
..........

Netgear won't let me contact them via email regarding this, so I've just contacted Amazon about it, advising of the issue with the single satellite and that according to netgear I have no warranty on the product, when there should be 2 years for UK users.


Ok, I hoep you will get some help from Amazon then.

By the way have tried the suggestions in the other post: Smiley Happy

  1. Have you tried to factory reset the Satellite?
  2. Have you tried to connect the Ethernet backhaul to another LAN port on the Satellite?

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 6 of 7
Highlighted
Guide

Re: MY Products all have red cross


@ekhalil wrote:

@walkerx wrote:
..........

Netgear won't let me contact them via email regarding this, so I've just contacted Amazon about it, advising of the issue with the single satellite and that according to netgear I have no warranty on the product, when there should be 2 years for UK users.


Ok, I hoep you will get some help from Amazon then.

By the way have tried the suggestions in the other post: Smiley Happy

  1. Have you tried to factory reset the Satellite?
  2. Have you tried to connect the Ethernet backhaul to another LAN port on the Satellite?

Yes to both and definitely think issue with the satellite as it's not even picking up the password from my main orbi and still using the default after the reset and resync and still only connecting via wifi.

 

Amazon don't repair the item or replace it, so their solution is to send the whole thing back for a refund and to re-order a replacement

Message 7 of 7