Reply

Re: My Orbi Satellite won't connect to the Orbi Router

SilverSword58
Follower

My Orbi Satellite won't connect to the Orbi Router

Hello, I recently purchased a Netgear Orbi RBR50 and was excited to set it up because my old router wasn't any good. We setup the router, and it worked smoothly. Then, we tried to hook up the satellite to the router, but that didn't work. Here's what happend. We watched a video on how to hook up the satellite to the router, but when we tried, the Orbi keeps on blinking white. We hit the sync button on the Orbi Router, then we hit the one on the Satellite soon after. Then, it doesn't show a color after five minutes of waiting for a color to appear. Please help, how do we fix this? Has anyone had this problem, and resolved it? 

Extra Detail:
FW - 2.5.1.8 (Latest as of 4/19/20)

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 4
AaronLTek
Guide

Re: My Orbi Satellite won't connect to the Orbi Router

I suggest you return it, get refund, immediately. No joke.

 

I've had an RBR50 for a month + 2 Sats and have had MAJOR problems with it. Sats connect over Wifi but not Ethernet (tried multiple factory resets). Throughput is in the gutter (7 to 50 mbps) even when signal strength is 50-60dbms. And more.

 

I'm going to call Netgear tomorrow (they never answered email) and if they dont replace it without question then I'm filing a credit card claim to get my money back. I'm not going ot mess around... I've spent about 15 hours messing with this.

Message 2 of 4
Retired_Member
Not applicable

Re: My Orbi Satellite won't connect to the Orbi Router

How long did the sat blink white before you gave up?

 

the firmware you have has known problems 

 

leave the sat alone as in longer 

 

if it does connect then go to downloads and look for an earlier firmware version 

Message 3 of 4
AaronLTek
Guide

Re: My Orbi Satellite won't connect to the Orbi Router

I loaded Voxels' FW and after resetting the Sats and connecting them direct to the router it finally showed as Wired. Then I mived them back to thier locations and it still shows wired.  I may be done with this buggy Netgear crap. I ordered ASUS it will be here tomorrow. I never had problems with ASUS gear... ran ASUS for 6 years prior to getting this Orbi.


@Retired_Member wrote:

How long did the sat blink white before you gave up?

 

the firmware you have has known problems 

 

leave the sat alone as in longer 

 

if it does connect then go to downloads and look for an earlier firmware version 


 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 469 views
  • 0 kudos
  • 3 in conversation
Announcements