Reply

Netgear Armor activation failed

SamuelKwok
Follower

Netgear Armor activation failed

I bought a subscription after the trial period and I have already activated it via the email from bitdefender. The activation is accepted but my RBR20 is still showing "Expired-Off". When I go to the bitdefender site, seems it require installing something into the device for protection. Question here, how to install external software to the Orbi router? Anyone can help on this?

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 3
FURRYe38
Guru

Re: Netgear Armor activation failed

Netgear has set up a community forum specifically for the Armor product. Most of the people who watch that forum are more likely to have experience with Armor and know how to work it better than those of us who follow this "general Orbi" forum. Might be more likely to find someone who has a solution if the question is posted there:
https://community.netgear.com/t5/NETGEAR-Armor/bd-p/en-home-armor
https://www.netgear.com/landings/armor
Good Luck.

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CM2000 Modem | Wifi Router RAXE50 and R8500(v.158) Router Mode and RBK752(v.2) AP mode | Switches NG GS105/8 | 

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700, GS308v3

Message 2 of 3
vajim
Master

Re: Netgear Armor activation failed

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 308 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E