Reply

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering

SW_
Prodigy
Prodigy

ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering

If you have a mixed of 2.4Ghz/5Ghz iOS devices, IoT devices, and legacy clients,

and you're currently having problem with your ORBI WiFi network such as:

 

  1. Devices/clients are unable to find/connect to 2.4Ghz band after Orbi reboots/restarts/etc., i.e., you have to manually disable 5Ghz band broadcast so that these clients can connect to Orbi 2.4Ghz WiFi network.
  2. Clients want to switch from 2.4Ghz band over 5Ghz due to poor/unstable 5Ghz signal, but can't.
  3. Bad roaming experiences, i.e., drop calls when walking between different rooms or areas of the house.
  4. WiFi drops.
  5. Poor WiFi performance.

 

Can you please try this?

 

Telnet into your ORBI Router and type these cmds from ORBI telnet terminal:

(Please check out this link for telnet and related information.)

 

  1. config get enable_band_steering           (Note:  This should return 1, which is the default value)
  2. config enable_band_steering=0
  3. config commit
  4. reboot

 

To re-enable band steering, do this:

 

  1. config enable_band_steering=1
  2. config commit
  3. reboot

 

Your Orbi will reboot.  Please wait for ~10mins to enable Orbi/Satellites WiFi network to reach steady state prior to testing.  After you're done with the experiment, can you please share your results and experiences?

 

Message 1 of 9
SW_
Prodigy
Prodigy

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering


@SW_ wrote:

If you have a mixed of 2.4Ghz/5Ghz iOS devices, IoT devices, and legacy clients,

and you're currently having problem with your ORBI WiFi network such as:

 

  1. Devices/clients are unable to find/connect to 2.4Ghz band after Orbi reboots/restarts/etc., i.e., you have to manually disable 5Ghz band broadcast so that these clients can connect to Orbi 2.4Ghz WiFi network.
  2. Clients want to switch from 5Ghz band to 2.4Ghz due to poor/unstable 5Ghz signal, but can't.
  3. Bad roaming experiences, i.e., drop calls when walking between different rooms or areas of the house.
  4. WiFi drops.
  5. Poor WiFi performance.

 

Can you please try this?

 

Telnet into your ORBI Router and type these cmds from ORBI telnet terminal:

(Please check out this link for telnet and related information.)

 

  1. config get enable_band_steering           (Note:  This should return 1, which is the default value)
  2. config set enable_band_steering=0
  3. config commit
  4. reboot

 

To re-enable band steering, do this:

 

  1. config set enable_band_steering=1
  2. config commit
  3. reboot

 

Your Orbi will reboot.  Please wait for ~10mins to enable Orbi/Satellites WiFi network to reach steady state prior to testing.  After you're done with the experiment, can you please share your results and experiences?

 


Fixed some mistakes.

 

 

Message 2 of 9
ekhalil
Master

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering

The band steering feature encourages dual-band-capable clients to stay on the 5 GHz band on dual-band APs. This ability frees up resources on the 2.4 GHz band for single-band clients.

The following parameters control Band Steering in Orbi:

 

lbd_LowRSSIAPSteerThreshold_CAP_W2=35     (-60 dBm)

lbd_LowRSSIAPSteerThreshold_CAP_W5=20     (-75 dBm)

lbd_LowRSSIAPSteerThreshold_RE_W2=35    (-60 dBm)

lbd_LowRSSIAPSteerThreshold_RE_W5=20    (-75 dBm)

 

lbd_APSteerToRootMinRSSIIncThreshold=10

lbd_APSteerToPeerMinRSSIIncThreshold=10

lbd_APSteerToLeafMinRSSIIncThreshold=10

lbd_RSSISteeringPoint_UG=10

lbd_RSSISteeringPoint_DG=5

 

lbd_BTMSteeringProhibitShortTime=15 (when a wireless client connects to AP, AP will block 2.4GHz connection for 15 seconds, thus encourage it to try connecting to 5GHz network first. After 15 seconds, if the client did not join the 5GHz network, it will be able to connect to the 2.4G network.

lbd_SteeringProhibitTime=120

lbd_MaxSteeringTargetCount=1  (maximum number of clients that can be connected to AP’s 5GHz wireless network in priority)

lbd_MaxSteeringUnfriendly=86400

lbd_SteeringUnfriendlyTime=600

multi_ap_disablesteering=0

f5964e1dd9ef35c678fdf1fa85c49dda65a3c13f79be474bae8dc5e70f43b548.png

 

 

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 3 of 9
DougB628
Apprentice

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering


@ekhalil wrote:

The band steering feature encourages dual-band-capable clients to stay on the 5 GHz band on dual-band APs. This ability frees up resources on the 2.4 GHz band for single-band clients.

The following parameters control Band Steering in Orbi:

 

lbd_LowRSSIAPSteerThreshold_CAP_W2=35     (-60 dBm)

lbd_LowRSSIAPSteerThreshold_CAP_W5=20     (-75 dBm)

lbd_LowRSSIAPSteerThreshold_RE_W2=35    (-60 dBm)

lbd_LowRSSIAPSteerThreshold_RE_W5=20    (-75 dBm)

 

lbd_APSteerToRootMinRSSIIncThreshold=10

lbd_APSteerToPeerMinRSSIIncThreshold=10

lbd_APSteerToLeafMinRSSIIncThreshold=10

lbd_RSSISteeringPoint_UG=10

lbd_RSSISteeringPoint_DG=5

 

lbd_BTMSteeringProhibitShortTime=15 (when a wireless client connects to AP, AP will block 2.4GHz connection for 15 seconds, thus encourage it to try connecting to 5GHz network first. After 15 seconds, if the client did not join the 5GHz network, it will be able to connect to the 2.4G network.

lbd_SteeringProhibitTime=120

lbd_MaxSteeringTargetCount=1  (maximum number of clients that can be connected to AP’s 5GHz wireless network in priority)

lbd_MaxSteeringUnfriendly=86400

lbd_SteeringUnfriendlyTime=600

multi_ap_disablesteering=0

f5964e1dd9ef35c678fdf1fa85c49dda65a3c13f79be474bae8dc5e70f43b548.png

 

 


All of this sounds great, assuming that a dual band client can get a sufficiently strong connection on the 5GHz band. But if it has a weak signal to the 5GHz band, and perhaps if it is still monitoring the 2.4GHz signal, it may re-attempt to connect via 2.4GHz, dropping the 5GHz connection. It is then ignored again, and it connects back to 5GHz. And the process repeats.

 

I believe this could be happening with my D-Link DCS2630L cameras, which support both bands. I have a D-Link NVR312L that attempts to connect to the streaming URL's of these cameras, and it is showing that the connections are dropping sporadically and frequently. I wish I could disable the camera's ability to connect on one of the bands, as I believe that would possibly solve my problems. I did run my Orbi with split SSID's for a few months, and the cameras had much more consistent connections. But I had more inconsistency with other devices, such as my Apple TV's, and if those don't work well, the family tends to gripe a lot more and a lot more loudly.

 

I have also tried another product as a network video recorder, iSpy, and saw similar behavior there too.

Message 4 of 9
SW_
Prodigy
Prodigy

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering

@DougB628 wrote:

...it may re-attempt to connect via 2.4GHz, dropping the 5GHz connection. It is then ignored again, and it connects back to 5GHz....

The experiment, disabling band steering, is to find out if it could break this infinite loop.  If a client is be able to connect to either 2.4Ghz or 5Ghz band, it could stop ping-pong between 2.4Ghz/5Ghz band, which is the ideal outcome.

 

@DougB628 wrote:

I believe this could be happening with my D-Link DCS2630L cameras,..

If possible, could you give "disable band steering" a shot at your convenience?

Message 5 of 9
gr8sho
Virtuoso

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering

Probably worth checking for firmware update on the devices.

Orbi RBK50 in AP mode, 100/20 Mbps VDSL2, Arris BGW210 gateway

Message 6 of 9
DougB628
Apprentice

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering


@SW_ wrote:

@DougB628 wrote:

...it may re-attempt to connect via 2.4GHz, dropping the 5GHz connection. It is then ignored again, and it connects back to 5GHz....

The experiment, disabling band steering, is to find out if it could break this infinite loop.  If a client is be able to connect to either 2.4Ghz or 5Ghz band, it could stop ping-pong between 2.4Ghz/5Ghz band, which is the ideal outcome.

 

@DougB628 wrote:

I believe this could be happening with my D-Link DCS2630L cameras,..

If possible, could you give "disable band steering" a shot at your convenience?


Tried it. Still disabled now. It seems that this is even worse, with most of the cameras staying disconnected from the NVR almost all the time. I also tried rebooting all the cameras by unplugging them and plugging them back in. One thing that is a bit different - they are all connecting to 2.4GHz now, none are on 5GHz. I will try re-enabling band steering and rebooting them all again and see if some of them go back to 5GHz. I seem to recall that they were not all on 2.4GHz before.

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 7 of 9
ekhalil
Master

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering


@DougB628 wrote:


.......

Tried it. Still disabled now. It seems that this is even worse, with most of the cameras staying disconnected from the NVR almost all the time. I also tried rebooting all the cameras by unplugging them and plugging them back in. ......


I think your issues are resulting from having big overlapping between the AP's coverage areas.

I'd try to reduce the transmission power of both bands to reduce the overlapping between the router and the satellites.

You can find the power setting in the advanced radio settings.

 

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 8 of 9
SW_
Prodigy
Prodigy

Re: ORBI RBR50/RBS50 2.4Ghz/5Ghz Band Steering


@DougB628 wrote:

One thing that is a bit different - they are all connecting to 2.4GHz now, none are on 5GHz...

This is interesting because it implies that 5Ghz signal is weaker or clients default to 2.4Ghz.  As @ekhalil's suggestion, try to lower the transmit power of 2.4Ghz bellow 5Ghz and see if that makes a difference.  For example, lower 2.4Ghz transmit power to 50% and 5Ghz to 75%.  Might also want to disable Fast Roaming to avoid ping-pong between Orbi/Satellites if there's big coverage overlap between them.

 

@DougB628 wrote:
I seem to recall that they were not all on 2.4GHz before.

This means that band steering is working as expected b/c Orbi hides 2.4Ghz from these clients so that they would connect to 5Ghz.

Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 6245 views
  • 0 kudos
  • 4 in conversation
Announcements