Reply

ORBI RBR50 not working and led ring doesn't light up

moomats
Tutor

ORBI RBR50 not working and led ring doesn't light up

Help!
My Orbi RBR50 (router) stopped working. I have tried to reset it to no avail.

The led ring light doesn't turn on too! My system consists of RBR50 and two RBS50s. The satellites appear to be working because their lights are magenta.

Help!

Thank you,

MM

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 1 of 13
CrimpOn
Guru

Re: ORBI RBR50 not working and led ring doesn't light up

The RBR50 has power?  (i.e. the LED on the back at the bottom is GREEN?)

How exactly did you "reset" the router?

I love my Orbi.
Message 2 of 13
moomats
Tutor

Re: ORBI RBR50 not working and led ring doesn't light up

The power led is green and I reset the router by pushing in the reset button.
Thank you for your help!
MM
Message 3 of 13
CrimpOn
Guru

Re: ORBI RBR50 not working and led ring doesn't light up

I attempted a reset once and neglected to hold the paperclip in long enough.  First the LED turns orange (for a LONG time), and then it begins to blink.  I saw the orange, thought "done", and pulled the paperclip back out.  Watched the Netgear video and realized I was not waiting long enough.

I love my Orbi.
Message 4 of 13
moomats
Tutor

Re: ORBI RBR50 not working and led ring doesn't light up

Thanks for your help. I tried again. I held the reset button down for longer than 2 minutes and the light never turned amber, it stayed green the entire time. Do you have any other suggestions?

Thank you!

Message 5 of 13
FURRYe38
Guru

Re: ORBI RBR50 not working and led ring doesn't light up

Does the top LED turn on Amber, not the LED in back. If this comes on Amber, then let go of the reset button in back and the top LED should blink WHITE then pulsate WHITE. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 6 of 13
gr8sho
Virtuoso

Re: ORBI RBR50 not working and led ring doesn't light up

If you hold the reset button too long I think it aborts. Watch the LED and when it starts blinking Amber, release the paper clip. The hardware boot up takes some time so be patient. The top ring will eventually turn blue. If doing this on the base stations, I’d leave the satellites powered off and then deal with them afterwards.
I actually like the way the hardware self configures itself and pairs via reset process.

Orbi RBK50 in AP mode, 100/20 Mbps VDSL2, Arris BGW210 gateway

Message 7 of 13
moomats
Tutor

Re: ORBI RBR50 not working and led ring doesn't light up

No, the led ring light doesn't light up at all!
Message 8 of 13
FURRYe38
Guru

Re: ORBI RBR50 not working and led ring doesn't light up

Possible unit is bad. You might contact NG support and get additional help and ask about an RMA. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 9 of 13
CrimpOn
Guru

Re: ORBI RBR50 not working and led ring doesn't light up


@moomats wrote:

Thanks for your help. I tried again. I held the reset button down for longer than 2 minutes and the light never turned amber, it stayed green the entire time. Do you have any other suggestions?

Thank you!


We may have a terminology problem.  The "reset" is a tiny hole next to the Power button and under the back LED.  Unbend a paper clip and stick the end into the hole.  Is this what you did?

I love my Orbi.
Message 10 of 13
moomats
Tutor

Re: ORBI RBR50 not working and led ring doesn't light up

Yes. Netgear refers to the tiny hole as a reset button.
Message 11 of 13
moomats
Tutor

Re: ORBI RBR50 not working and led ring doesn't light up

Thank you for your help, I will.

 

Message 12 of 13
gr8sho
Virtuoso

Re: ORBI RBR50 not working and led ring doesn't light up

Putting aside the top LED comment, it’s amazing the reset button is not working at all. And you do feel the indent when pushing the clip in.

Orbi RBK50 in AP mode, 100/20 Mbps VDSL2, Arris BGW210 gateway

Message 13 of 13
Top Contributors
Discussion stats
  • 12 replies
  • 9298 views
  • 3 kudos
  • 4 in conversation
Announcements

Orbi WiFi 6E