Reply
Highlighted
Aspirant

ORBI RBR50 w/ 1 Sat Constant Connection Lost

Model: ORBI RBR50 w/ 1 sat

Firmware: V2.0.0.74

OS: Win10, Android

Mode: Router

 

Seems to be the same old story every where in this community. My Orbi constantly loses connection.  This interfers with all connected devices (constant freezes, lost internet of things connections and constant resets)  I have the most current software, yet I'm still consistently losing connection to the internet and my devices. I even have : (Enable Implicit BEAMFORMING - Boosts WiFi speed, reliability, & range for all mobile devices) selected and this does nothing for reliability! Very frustated and ready to abandon NETGEAR all together.... Please help!!!

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 5

Accepted Solutions
Highlighted
Aspirant

Re: ORBI RBR50 w/ 1 Sat Constant Connection Lost

Yes,I also have done many factory resets and nothing has helped.  I've also had my cable company's line checked once at their expense and once at my expense (more money wasted).  There are no issue on their  side so, after having experiences these constant drops repeatedly for about a year (got my orbi when it was released), if I can't resolve it this time then I'll have to ditch NETGEAR FOREVER and fork out more money for a better, more reliable product.  Researching new products now to find one that works...a better mesh router!

View solution in original post

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 3 of 5

All Replies
Highlighted
Initiate

Re: ORBI RBR50 w/ 1 Sat Constant Connection Lost

Same here, factory reset did nothing for me, sure is fun to get kicked out of games because my >$300 Wi-Fi system isn't stable
Message 2 of 5
Highlighted
Aspirant

Re: ORBI RBR50 w/ 1 Sat Constant Connection Lost

Yes,I also have done many factory resets and nothing has helped.  I've also had my cable company's line checked once at their expense and once at my expense (more money wasted).  There are no issue on their  side so, after having experiences these constant drops repeatedly for about a year (got my orbi when it was released), if I can't resolve it this time then I'll have to ditch NETGEAR FOREVER and fork out more money for a better, more reliable product.  Researching new products now to find one that works...a better mesh router!

View solution in original post

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 3 of 5
Highlighted
Initiate

Re: ORBI RBR50 w/ 1 Sat Constant Connection Lost

I solved my issue by "upgrading" to the 1.11.0.20 firmware

I don't know about any features the new versions have that I would use so I'm sticking with this firmware for the forseeable future

https://kb.netgear.com/000038846/RBR50-RBS50-Firmware-Version-1-11-0-20

I updated the router, then the satellite, and had to sync the satellite again after

Also, the satellite wasn't letting me log into it, saying I was inputting the wrong password, so I had to factory reset the satellite and sync it again before updating it

I had to disable automatic updating so it wouldn't go back to 2.whatever

https://community.netgear.com/t5/Orbi/Firmware-V1-12-0-18-Discussion/m-p/1323973#M10304

Note: I also had to set orbi_auto_upg=0

Message 4 of 5
Highlighted
Aspirant

Re: ORBI RBR50 w/ 1 Sat Constant Connection Lost

Thanks...I'll give it a try after the holiday!!!  Cheers!

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 878 views
  • 1 kudo
  • 2 in conversation
Announcements