Reply

ORBI and SONOS - FW V1.12.0.18 does not work

Loxley
Guide

ORBI and SONOS - FW V1.12.0.18 does not work

iOS devices cannot connect to SONOS with a Boost wired direct to an Orbi router with the new firmware for Orbi - V1.12.0.18.   Macs and PCs can connect.  Has anyone else experienced this problem and does anyone have a solution?  I do not wish to use SONOS in wifi mode without a Boost connection as, even with Orbi, the wifi signal is not good enough around the whole house to stop drop-outs etc.

 

iOS devices can connect to SONOS with a wired Boost using the old firmware for Orbi - V1.11.0.20.  I have therefore downgraded to this pending a solution with the new firmware.

 

All help appreciated.

 

 

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 12
timch
Luminary

Re: ORBI and SONOS - FW V1.12.0.18 does not work

I have Sonos working perfectly with 12.0.18 using a Boost wired directly to the Orbi router. Sonos can sometimes have a problem with resetting IP addresses so I would advise setting up your Orbi network then removing the power to all your Sonos devices and then powering up starting with your Boost. Allow that a few minutes before switching on the ZPs. I am assuming in this that your basic Orbi setup is correct. Just to check, I assume that if it is set as a router that the modem is not routing. Also, I assume the Boost is connected to the router or the satellite.
Message 2 of 12
Loxley
Guide

Re: ORBI and SONOS - FW V1.12.0.18 does not work

Thanks for the reply Timch.

 

My system is connected as you set out in your note.  I have restarted from the ground up (Boost then other Sonos units) but I still don't get a working system under iOS using the new firmware. Everything works using an HP laptop, a MacBook Air and an iMac - it just seems to be iPhones and iPads that cannot connect.  If I revert to the previous firmware, everything works, including iOS devices.  

 

For what it's worth, I have also reserved the IP addresses of all the Sonos units. 

Message 3 of 12
st_shaw
Master

Re: ORBI and SONOS - FW V1.12.0.18 does not work

No problems here with a Boost setup either. As @timch said, I would look for a wiring or setup problem first.

 

I don't know your setup, but if you have two routers and Orbi is not in AP mode, then the wired and wireless clients could be on different subnets and Sonos wouldn't work.

 

Message 4 of 12
Loxley
Guide

Re: ORBI and SONOS - FW V1.12.0.18 does not work

Thanks st_shaw and timch.

 

My set-up is using a Netgear modem (no router capability) to which the Orbi is connected, acting as a router.  The Sonos Boost is connected by ehternet to the Orbi unit.

 

Everything works well, including controlling Sonos via wifi by desktop, portable (PC and Mac), except iOS devices which cannot connect when the Orbi has the V1.12.0.18 firmware.  Are you both having no trouble with iPhones and iPads on your set-ups?

 

Everything, including iOS devices works for me when using the older firmware V1..11.0.20.

 

With thanks for your help.

 

Message 5 of 12
st_shaw
Master

Re: ORBI and SONOS - FW V1.12.0.18 does not work

@Loxley No problems with iPhones and iPads and Sonos on v1.12.0.18. I'm running Orbi in AP mode though.

 

You are seeing strange behavior for sure. It's not obvious what the problem is. It amost sounds like the iOS devices are connectig to a different WiFi network.  A few questions might help figure out what's happening:

 

1. Is the guest network enabled on Orbi?

 

2. What is the IP address of your Orbi router, e.g. 192.168.1.1, and what is the WiFi SSID and IP address on your iOS device when it's not working?

 

3. When your iOS device isn't working with Sonos, can your iOS device access other devices on your LAN?  If you don't have a way to test LAN connectivity, you could download an app that includes ping functionality. "Network Tools" from Hurricane Electric on the App Store includes a ping function. With that you can see if you are able to ping the router, the Sonos Boost, etc.

 

4. When iOS cannot see Sonos, does it matter whether the iOS device is connected to the Orbi Router or Satellite.  Some people have reported issues with Satellite connectivity, but I don't think I've seen anyone say they cannot see devices wired to the router when they are associated with the Orbi router WiFi.

 

 

Message 6 of 12
Loxley
Guide

Re: ORBI and SONOS - FW V1.12.0.18 does not work

st_shaw - thanks for your repply - it is all a bit odd, I agree, especially as everything including Sonos recognition, does work when using the V1.11.0.20 firmware.

 

In answer to your questions:

 

1.  Guest network is disabled

 

2.  The Orbi is in router mode and its IP address is the default 192.168.1.1.  The SSIDs on the iOS devices match the Orbi router and their IP addresses are reserved in the range 192.168.1.xx to xxx

 

3.  Yes - all my iOS devices work with the Orbi using the new firmware but none recognises the Sonos network.  

 

4.  It makes no difference whether the iOS devices are connected to the router or the satellit.

 

 

Message 7 of 12
st_shaw
Master

Re: ORBI and SONOS - FW V1.12.0.18 does not work

Nothing obvious still. Let me ask two more questions to clarify.

 

2. How are the IP addresses reserved for your iOS devices--on the Orbi DHCP server, or manually on the iOS device itself? (Trying to rule out possible IP address duplication.)

3. You say the iOS devices work.  How exactly are you verifying that?  (I want to be sure you can ping or otherwise connect to devices on your LAN, not access the Internet. iOS devices rarely connect to other clients on the LAN under normal use, so I need to ask.)

Message 8 of 12
Loxley
Guide

Re: ORBI and SONOS - FW V1.12.0.18 does not work

Thanks for the reply. 

 

The answers to the additional questions are:

 

2. Reservation is on the Orbi router

 

3.  I've used Net Analyser to ping the devices and confirm no conflicts 

 

 

 

 

Message 9 of 12
st_shaw
Master

Re: ORBI and SONOS - FW V1.12.0.18 does not work

Ok.  You've tried almost everything I can think of and nothing explains the behavior.

 

If your other devices can connect via WiFi and see Sonos, and if your iOS devices can access the LAN fine, there is absolutely zero explanation for why iOS devices could not access Sonos, unless there was some sort of firewall rule in place blocking access.

 

The only other things I would try are 1) a reset of Orbi to factory defaults and re-setup, and 2) having iOS forget the Orbi WiFI network and re-connecting.

Message 10 of 12
Loxley
Guide

Re: ORBI and SONOS - FW V1.12.0.18 does not work

Thank you again.

I've checked the firewalls and cannot see an issue. It still stumps me that it is only the change in Orbi firmware that results in the problem.

I will try your suggestions next weekend.

Thanks.
Message 11 of 12
alangsam
Aspirant

Re: ORBI and SONOS - FW V1.12.0.18 does not work

I had a ATT Wifi router that had limited range. I have had sonos in the house for years. I switched to the Orbi and satelite setup and wifi range and speed much better. However it has wrecked my sonos setup. i constantly have to use the wizard to reconnect the Speakers. We get sound dropouts or the quality is terrible. Interstingly when using the web tools we can see that the upstairs sonos speakers are connecting to the main orbi downstairs instead of the satellite orbi 5 feet away? This has been very painful. i didnt have the option to connect them via ethernet.

 

I have ordered a Sonos boost to see if it helps. All in all while i love the orbi i like my sonos better.

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 3873 views
  • 0 kudos
  • 4 in conversation
Announcements