Reply

Re: Orbi Firmware update 2.5.0.38 problems

RonRolfsen
Tutor

Re: Orbi Firmware update 2.5.0.38 problems

Over the weekend reset the router (but not the satellites) - rebooted and now it seems to be working.  What was very odd was that the reset did not wipe out the settngs (password, static IP addresses) - so it seems as if it did not do a complete reset from scratch (not complaining but not what was expected, and yes, I did the reset correctly).  In any case it has now been up for 24 hrs and recognizes all the devices and satellites and no issues with the web GUI.  Thanks for the help and comments.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 51 of 88
FURRYe38
Guru

Re: Orbi Firmware update 2.5.0.38 problems

From where did you reset the RBR? From the RBR web page or use of the back button. Press of the back button for 15 seconds should erase and wipe out all configurations. Did the setup wizard not appear for you after the reset? This should be the first thing seen if you setup with a PC and web browser.


@RonRolfsen wrote:

Over the weekend reset the router (but not the satellites) - rebooted and now it seems to be working.  What was very odd was that the reset did not wipe out the settngs (password, static IP addresses) - so it seems as if it did not do a complete reset from scratch (not complaining but not what was expected, and yes, I did the reset correctly).  In any case it has now been up for 24 hrs and recognizes all the devices and satellites and no issues with the web GUI.  Thanks for the help and comments.


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.1/RBK50 v2.7.2.104(WW)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 52 of 88
RonRolfsen
Tutor

Re: Orbi Firmware update 2.5.0.38 problems

Reset on the router via paperclip for >10 seconds.  Did not get the setup wizard.  Attached via the web GUI via PC to the router and when the login did not accept the defaut admin/password - tried my existing one which then connected. (as I said it was weird - I know should not have been this way - I was not smoking or drinking :-)  Rebooted the router and then things appeared to be corrected.  So I don't know if there is some partial reset but when I inserted the paper clip and counted, the lights changed to the flashing yellow/amber by the reset hole. Might not have been a full 15 seconds but definately greater than 7 seconds as indicated by the manual.  Bottom line it is now back to normal.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 53 of 88
FURRYe38
Guru

Re: Orbi Firmware update 2.5.0.38 problems

Ya 10 seconds isn't enough. 15 seems to be the sweet spot. For next time if needed. 

Glad is all working now. Please mark your thread and solved so others will know.

Be sure to make a back up configuration to file for safe keeping. Saves time if a reset is needed. 

 

Enjoy. Smiley Wink


@RonRolfsen wrote:

Reset on the router via paperclip for >10 seconds.  Did not get the setup wizard.  Attached via the web GUI via PC to the router and when the login did not accept the defaut admin/password - tried my existing one which then connected. (as I said it was weird - I know should not have been this way - I was not smoking or drinking :-)  Rebooted the router and then things appeared to be corrected.  So I don't know if there is some partial reset but when I inserted the paper clip and counted, the lights changed to the flashing yellow/amber by the reset hole. Might not have been a full 15 seconds but definately greater than 7 seconds as indicated by the manual.  Bottom line it is now back to normal.


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.1/RBK50 v2.7.2.104(WW)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 54 of 88
wchp
Luminary

Re: Orbi Firmware update 2.5.0.38 problems


@FURRYe38 wrote:

Please mark your thread and solved so others will know.

If he didnt get the setup screen and his settings were intact it sounds like he did not actually do a full factory reset. Just not sure this is actually the solution of just coincidence. For me, factory reset is a paperclip to the back for 15s+ till reset light starts blinking (And I get the factory setup GUI).

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 55 of 88
FURRYe38
Guru

Re: Orbi Firmware update 2.5.0.38 problems

Ya, seen this before myself. So 15 seconds is the key for a full complete reset. 


Thanks for letting us know what you saw. 

 

Glad it's up and running. On v38. Smiley Wink


@wchp wrote:

@FURRYe38 wrote:

Please mark your thread and solved so others will know.

If he didnt get the setup screen and his settings were intact it sounds like he did not actually do a full factory reset. Just not sure this is actually the solution of just coincidence. For me, factory reset is a paperclip to the back for 15s+ till reset light starts blinking (And I get the factory setup GUI).


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.1/RBK50 v2.7.2.104(WW)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 56 of 88
Retired_Member
Not applicable

Re: Orbi Firmware update 2.5.0.38 problems


@FURRYe38 wrote:

Ya, seen this before myself. So 15 seconds is the key for a full complete reset. 


Thanks for letting us know what you saw. 

 

Glad it's up and running. On v38. Smiley Wink


@wchp wrote:

@FURRYe38 wrote:

Please mark your thread and solved so others will know.

If he didnt get the setup screen and his settings were intact it sounds like he did not actually do a full factory reset. Just not sure this is actually the solution of just coincidence. For me, factory reset is a paperclip to the back for 15s+ till reset light starts blinking (And I get the factory setup GUI).


What’s key is there no factory reset.   Nice 


 

Message 57 of 88
wchp
Luminary

Re: Orbi Firmware update 2.5.0.38 problems

@wchp wrote:

On a 2018 Macbook Pro on Firmware V 2.5.0.38 I am experiencing ½ to ¼(or less) the 802.11AC throughput vs. the previous version of firmware.

460-585 mps on 2.3.5.30 from Mac OS wifi details and 520/41.2 from Speedtest app

40-180 mbps on 2.5.0.38from Mac OS wifi details and 86/23.9 from Speedtest app

Observed using WiFi details AND WiFi explorer.

Both observations on WiFi Explorer show Chan 48, 90% signal strength, SNR 54dB readings with both versions of firmware.

Laptop and Router locations unchanged.

Tried everything except factory reset/paper clip simply because I dont want to and dont feel I should need to with a public firmware release (with beta firmware versions this is a given that a factory reset is done)

Of note (if it makes any difference) I am running the Armor protection on the RBR (for both tests).

Have reverted back to 2.3.5.30 and will wait for next rev of FW.

 

 

OK... finally decided to give a hard reset a try.

1) Upgraded from 2.3.5.30 to 2.5.0.38 (Tested and till same speed issue)

2) Applied Hotfix 2.5.0.40 (tested and still same speed issue)

AND STILL exactly the same problem.

3) Paperclip reset the router and both Satallites from scratch

Exact same problem still as listed above making NO changes to the factory config other than the firmware rev.

4) Manually entered my standard config.

Still:

"460-585 mps on 2.3.5.30 from Mac OS wifi details and 520/41.2 from Speedtest app

40-180 mbps on 2.5.0.38from Mac OS wifi details and 86/23.9 from Speedtest app"

 

SO... went to Costco and purchased a brand new RBK53S system

1) Upgraded from 2.3.5.xx (firmware it shipped with) to 2.5.0.38

2) Applied Hotfix 2.5.0.40

3) Tested WiFi speed and same poor performance on new system as my old one.

3) Downgraded the NEW RBK53S system to 2.3.5.30 AND... silly thing, WiFi speeds and connectivity back to normal.

 

I dont see a hard reset resolving the performance issues that are presenting themselves in my environment (CM-1100 --> RBK53)

with either my 1 year old RBK53 or a brand new RBK53S

I dont have PC or Android devices to test with but the WiFi slowdown is significant on my 2018 Mackbook Pro and iPhone Xs.

 
Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 58 of 88
FURRYe38
Guru

Re: Orbi Firmware update 2.5.0.38 problems

Thanks for trying the reset and letting us know. 

 

Keep what works for you loaded. 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.1/RBK50 v2.7.2.104(WW)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 59 of 88
dancar
Aspirant

Re: Orbi Firmware update 2.5.0.38 problems

I have the same naming problem, and I have 40 devices.  I do not want to reset and start all over.  I even downloaded v.40 thinking that would be a fix, but it was not.  Does anyone know if this problem will be fixed by Netgear and when?  Thanks.

Message 60 of 88
FURRYe38
Guru

Re: Orbi Firmware update 2.5.0.38 problems

A factory reset and setup from scratch should be performed as a last resort to see if this resolves what your seeing. 

If you reset and setup and it fixes your problem besure to do a backup configuration to file for safe keeping. Saves time when resets maybe needed. 

 

You can down grade FW as well. 


@dancar wrote:

I have the same naming problem, and I have 40 devices.  I do not want to reset and start all over.  I even downloaded v.40 thinking that would be a fix, but it was not.  Does anyone know if this problem will be fixed by Netgear and when?  Thanks.


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.1/RBK50 v2.7.2.104(WW)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 61 of 88
dancar
Aspirant

Re: Orbi Firmware update 2.5.0.38 problems

I also downloaded v.40, and no change in the names of the devices.  Please let me know if you get an answer about a fix from NG.  Thanks.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 62 of 88
Blanca_O
NETGEAR Moderator

Re: Orbi Firmware update 2.5.0.38 problems

Hi Orbi Community,

 

Please be informed that firmware v2.5.0.38 and v2.5.0.40 were pulled out from the update server. 

 

The newly released firmware v2.3.5.34 fixes the web SSL certificate (https). If you are having issues with firmware 2.5.0.38/40, please downgrade the firmware to 2.3.5.30 or apply firmware 2.3.5.34. Please see download links: 

 

RBR50 / RBS50 Firmware Version 2.3.5.34 - Hot Fix
https://kb.netgear.com/000061420/RBR50-RBS50-Firmware-Version-2-3-5-34-Hot-Fix


RBR50 / RBS50 Firmware Version 2.3.5.30
https://kb.netgear.com/000061080/RBR50-RBS50-Firmware-Version-2-3-5-30

 

How do I manually upgrade firmware on my Orbi router using orbilogin.com?
https://kb.netgear.com/31573/

 

A new firmware will be available soon in replace with the firmware v38.

 

Regards,
Blanca
Community Team

Message 63 of 88
jtlynn23
Tutor

Re: Orbi Firmware update 2.5.0.38 problems

 

Both the 2.5.0.38 and 2.5.0.40 firmware updates have been disasters on my RBR50 and RBS50.  

 

The problems with wireless performance and the Device List began with .38 and continue with .40.  

 

WiFi performance has been dismal: for some reason the unit randomly ratchets back WiFi speeds to a max of 40-50 Mbit/sec every few days. When this happens, a hardwired speed test between the Orbi router and my cable modem consistently shows my full bandwidth of 700 Mbit/sec.   Power-cycling the unit brings WiFi speed back to normal,  but every couple days it inexplicably kicks back down again.  Clearly, this firmware has messed with the WiFi services on the RBR50 and RBS50.

 

The "Devices" list is messed up-- devices I got rid of 2 years ago have reappeared as "active," and I can't fix a single incorrect entry on the list--  I agree that this is an "annoyance" but it serves as a blatant sign of a company that lacks pride in its work and disrepects its customers.  I have managed software development teams and the fact that this software was actually approved for release to customers is appalling.

 

Netgear should be ashamed of themselves for releasing this on their customers.

 

And before the fanboys tell me to do a factory reset-- a solution which has met with very mixed results in this forum-- I will say that I refuse to spend another minute of my energy trying to fix this vendor's lousy work.

 

If a "factory reset" really is the answer, I will gladly start out from scratch again, and here's how I will do it:

 

I just returned from Best Buy with a Linksys Velop Mesh System that I bought via a sweet Black Friday deal.  I will be going through a new setup process, and it's going to be with a competing product.

 

I have had this Orbi system for over two years and have had minimal trouble with it.  And I've been a Netgear customer since the late 1990s in their Bay Networks days.  This experience has destroyed my confidence in the Netgear brand. 

 

If anyone wants a used Orbi system with half-baked firmware on the cheap, let me know.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 64 of 88
FURRYe38
Guru

Re: Orbi Firmware update 2.5.0.38 problems

I was told today that NG pulled v30 and v40 from there Orbi update servers. So users shouldn't see this on there FW update page on the RBR. Yes there available via the download site. 

 

They confirmed that v34 is the standing latest version that they recommend upgrading to. You can upgrade to v34 which has the web page certificate fix or downgrade to v30 or last working version of FW. A factory reset is the last resort if users can't get there systems working normally. Those of us who do resets and manual upgrades, this seems to avoid issues seen by those of you who do see issues and choose not to do a reset. It's up to you. NG said it was coming out with a new FW udpate to fix the device naming issue found in v38. For those of you who can't get there systems working, with or with out a factory reset, revert back to something that works for you and wait for the next update to arrive. No date was given when the next FW upate will be released.


Good Luck. 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.1/RBK50 v2.7.2.104(WW)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 65 of 88
Wire1852
Apprentice

Re: Orbi Firmware update 2.5.0.38 problems

@Blanca_O 

Why isn't this message posted as a pinned announcement at the top of the Orbi Web page instead of a reply in a 3 page thread.

 

It's not rocket science.

 


@Blanca_O wrote:

Hi Orbi Community,

 

Please be informed that firmware v2.5.0.38 and v2.5.0.40 were pulled out from the update server. 

 

The newly released firmware v2.3.5.34 fixes the web SSL certificate (https). If you are having issues with firmware 2.5.0.38/40, please downgrade the firmware to 2.3.5.30 or apply firmware 2.3.5.34. Please see download links: 

 

RBR50 / RBS50 Firmware Version 2.3.5.34 - Hot Fix
https://kb.netgear.com/000061420/RBR50-RBS50-Firmware-Version-2-3-5-34-Hot-Fix


RBR50 / RBS50 Firmware Version 2.3.5.30
https://kb.netgear.com/000061080/RBR50-RBS50-Firmware-Version-2-3-5-30

 

How do I manually upgrade firmware on my Orbi router using orbilogin.com?
https://kb.netgear.com/31573/

 

A new firmware will be available soon in replace with the firmware v38.

 

Regards,
Blanca
Community Team


 

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 66 of 88
thedak
Apprentice

Re: Orbi Firmware update 2.5.0.38 problems

@Blanca_O  Thanks for finally pulling this!  It was creating problems for a plethora of users!

@FURRYe38  

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 67 of 88
spinkick
Apprentice

Re: Orbi Firmware update 2.5.0.38 problems

Why are they having such a hard time with firmware and this product? Its been 3-4 years since this device was released.

Message 68 of 88
thedak
Apprentice

Re: Orbi Firmware update 2.5.0.38 problems

@Blanca_Othanks for pulling this firmware.   I had to downgrade.  A plethora of customers were having problems.  Await the fixed version.  

@FURRYe38

 

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 69 of 88

Re: Orbi Firmware update 2.5.0.38 problems

Try simply power off and repower rather than a reboot or reset.

Only once that I know of my Orbi had to power cycle to get new settings to take after a firmware update.

Simply rebooting from the app didn't do it.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 70 of 88

Re: Orbi Firmware update 2.5.0.38 problems

Try power cycling the Obbi rather than a reboot.

Solve my issue after that.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 71 of 88
Vaslo
Guide

Re: Orbi Firmware update 2.5.0.38 problems

 


@Blanca_O wrote:

Hi Orbi Community,

 

Please be informed that firmware v2.5.0.38 and v2.5.0.40 were pulled out from the update server. 

 

The newly released firmware v2.3.5.34 fixes the web SSL certificate (https). If you are having issues with firmware 2.5.0.38/40, please downgrade the firmware to 2.3.5.30 or apply firmware 2.3.5.34. Please see download links: 

 

RBR50 / RBS50 Firmware Version 2.3.5.34 - Hot Fix
https://kb.netgear.com/000061420/RBR50-RBS50-Firmware-Version-2-3-5-34-Hot-Fix


RBR50 / RBS50 Firmware Version 2.3.5.30
https://kb.netgear.com/000061080/RBR50-RBS50-Firmware-Version-2-3-5-30

 

How do I manually upgrade firmware on my Orbi router using orbilogin.com?
https://kb.netgear.com/31573/

 

A new firmware will be available soon in replace with the firmware v38.

 

Regards,
Blanca
Community Team


Yay, about time.  One of the executives must have finally had some problems because giving the "Just Completely Reset Your Router" and "No one else is having this problem" finally caught up to the decision makers.  What possibly took so long to make this change?



EDIT:  I realized I STILL have issues with v30 - thats what I have installed after my last complaint and it's the same problem.  I gave up for a few weeks hoping Netgear would get it together.

 

Some guy on Slickdeals said the following:  "I went to v2.2.1.210 and its resolved my issues with Apple Products. I've turned off auto-updates and its been working normally for a week now."   Going to try this one.  I hadn't updated the firmware in a while so was using one that was likely before this one.  

Message 72 of 88
Igott
Star

Re: Orbi Firmware update 2.5.0.38 problems

I'm having the same type of issue since this update, no changes in placement of my main orbi unit and 2 satellite units. On wirelss video conferencing and wifi calling are absolutely horrible. I've tried rebooting my routers resyncing the satellite and not improvement. Anything that is wired works perfect was my whole home is streaming apple TV HD and 4K streams without an issue. Please help any ideas on how to resolve as the wirelss issues are impacting my ability to work from home.
Message 73 of 88
FURRYe38
Guru

Re: Orbi Firmware update 2.5.0.38 problems

Has a factory reset and setup from scratch been performed since last update?


@Igott wrote:
I'm having the same type of issue since this update, no changes in placement of my main orbi unit and 2 satellite units. On wirelss video conferencing and wifi calling are absolutely horrible. I've tried rebooting my routers resyncing the satellite and not improvement. Anything that is wired works perfect was my whole home is streaming apple TV HD and 4K streams without an issue. Please help any ideas on how to resolve as the wirelss issues are impacting my ability to work from home.

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.1/RBK50 v2.7.2.104(WW)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 74 of 88
Vaslo
Guide

Re: Orbi Firmware update 2.5.0.38 problems


@FURRYe38 wrote:

Has a factory reset and setup from scratch been performed since last update?


@Igott wrote:
I'm having the same type of issue since this update, no changes in placement of my main orbi unit and 2 satellite units. On wirelss video conferencing and wifi calling are absolutely horrible. I've tried rebooting my routers resyncing the satellite and not improvement. Anything that is wired works perfect was my whole home is streaming apple TV HD and 4K streams without an issue. Please help any ideas on how to resolve as the wirelss issues are impacting my ability to work from home.

 


Doesn't need a factory reset.  Needs someone to get off their rear and write a patch to fix it.

Message 75 of 88
Top Contributors
Discussion stats
Announcements