Reply
Highlighted
Aspirant

Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

Alright, yet another XFiniti issue post! Like many, I am having issues getting my mother's RBR20 to connect to the internet with the Xfinity Arris TG1682G Modem/Router. 

I have enabled Bridge mode on the modem/router. When I go back in and check the wifi settings, they show disabled.

Next, I setup the Orbi and add the Arris modem/router MAC address. When I do that, Orbi shows the IP information from Comcast. When I remove it, it does not. However, in either state, it cannot connect to the internet and has a magenta light on it. It is cabled properly. I have searched through the Arris config to see if I could find any other methods to disable the wifi transmitters, but enabling bridge mode seems to be the only way. 

 

What I do not understand is why Orbi cannot connect to the internet even though it has the Comcast IP info showing in the DHCP listing. That makes no sense to me. Thanks in advance, everyone.

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 10

Accepted Solutions
Highlighted
Apprentice

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

Please make sure of the following 

1. The Orbi "Internet/Yellow Port" is connected by ethernet cable to Arris TG1682G.
2. No other devices are connected to Arris TG1682G ethernet ports. 
3. Arris TG1682G is in bridge Mode.
4. The Orbi is in router mode and setup to obtain WAN DHCP automatically. 
5. Power off both devices. Power on Arris TG1682G first and wait until LEDs show active and Internet. The power on the Orbi. 

Comcast/Xfinity like most ISPs only assigns an account 2 public IP addresses and only one can be assigned to a device connected to the ethernet ports. So if you have multiple devices connected to the Arris TG1682G they may be racing for that 1 public IP address. 

My Setup (Cable 1000Mbps/50Mbps)>CM1000>RBR50 V2.7.1.60(Router Mode)

View solution in original post

Message 2 of 10

All Replies
Highlighted
Apprentice

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

Please make sure of the following 

1. The Orbi "Internet/Yellow Port" is connected by ethernet cable to Arris TG1682G.
2. No other devices are connected to Arris TG1682G ethernet ports. 
3. Arris TG1682G is in bridge Mode.
4. The Orbi is in router mode and setup to obtain WAN DHCP automatically. 
5. Power off both devices. Power on Arris TG1682G first and wait until LEDs show active and Internet. The power on the Orbi. 

Comcast/Xfinity like most ISPs only assigns an account 2 public IP addresses and only one can be assigned to a device connected to the ethernet ports. So if you have multiple devices connected to the Arris TG1682G they may be racing for that 1 public IP address. 

My Setup (Cable 1000Mbps/50Mbps)>CM1000>RBR50 V2.7.1.60(Router Mode)

View solution in original post

Message 2 of 10
Highlighted
Aspirant

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

Okay, thanks for the advice.

 

1. Check!

2. I do have things plugged in there so maybe that's the issue.

3. Check!

4. Check!
5. WIll make sure I come up in that order.

 

Thanks again.

Message 3 of 10
Highlighted
Master

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.


@charleyp1 wrote:


Next, I setup the Orbi and add the Arris modem/router MAC address. When I do that, Orbi shows the IP information from Comcast. When I remove it, it does not. However, in either state, it cannot connect to the internet and has a magenta light on it. It is cabled properly.


 

Why are you setting up the Orbi and adding the Arris MAC address? Once you disable DHCP and setup the Arris in bridge mode, you should be able to use the app (still think it's the easiest and fastest way for an initial setup) and configure the Orbi router in router mode, and add satellites if needed. Once configured you can go to orbilogin.com and finish configuring the Orbi the way you want.  

 

Orbi RBK53 System/RBR50/RBS50/RBS50. + Orbi Voice RBS40V
RBK753 system/RBR750/RBS750/RBS750 + RBK853 System/RBR850/RBS850/RBS850
There's always a logical answer, if you have all the facts!
Message 4 of 10
Highlighted
Aspirant

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

On one the various threads on this subject, I read someone suggested that. When I do not add it, I do not have an IP address from Comcast. When I do, I get an IP address pushed down to the Orbi (though I still cannot access the internet).

Message 5 of 10
Highlighted
Master

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.


@charleyp1 wrote:

On one the various threads on this subject, I read someone suggested that. When I do not add it, I do not have an IP address from Comcast. When I do, I get an IP address pushed down to the Orbi (though I still cannot access the internet).


Go back and check your Arris settings. The modem needs to be active and the LAN portion technically disabled. Make sure, after changing settings on the Arris, and before connecting the Orbi, you reboot the Arris. This way the Arris will obtain the info from the ISP and assign an IP address to the Orbi router.

Orbi RBK53 System/RBR50/RBS50/RBS50. + Orbi Voice RBS40V
RBK753 system/RBR750/RBS750/RBS750 + RBK853 System/RBR850/RBS850/RBS850
There's always a logical answer, if you have all the facts!
Message 6 of 10
Highlighted
Aspirant

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

Trust me, I have. I spent 3 1/2 hours yesterday troubleshooting this. The only setting change I am aware of that needs to be made is enabling bridge mode. If there is another setting change to be made, no one has discovered and posted about it, as far as I can tell. I scoured every possible setting that can be changed in the Arris TG1682G and there is no way for a home user to, say, disable the wireless transmitters short of enabling bridge mode. If anyone has any suggestions on what else can be fiddled with in the modem, I'd love to hear them.

Message 7 of 10
Highlighted
Guru

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

Check the Arris modems users manual for transparent, or NAT or Bridge mode features on the modems web page. I have set a few of these modems up for bridge mode and it's there. Been a while since I did my last one. Once it's bridged fully and you applied the change. Your RBR router should be connected to the 1st port on the modem. Power OFF The modem for 1 minute then back ON and let it sync. Then Power ON the RBR. I would factory reset the RBR and walk thru the setup wizard at 192.168.1.1 with a wired PC. This should help you get the RBR connected to the Modem. 

 

Unless the ISP has done something else to the modem, this should work. 

 

You can use the modems DMZ in router mode for the RBR in router mode as a back up plan. 


@charleyp1 wrote:

Trust me, I have. I spent 3 1/2 hours yesterday troubleshooting this. The only setting change I am aware of that needs to be made is enabling bridge mode. If there is another setting change to be made, no one has discovered and posted about it, as far as I can tell. I scoured every possible setting that can be changed in the Arris TG1682G and there is no way for a home user to, say, disable the wireless transmitters short of enabling bridge mode. If anyone has any suggestions on what else can be fiddled with in the modem, I'd love to hear them.


 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 8 of 10
Highlighted
Apprentice

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

I had previously asked and you responded. Did you remove all the other devices from Arris TG1682G  except the Orbi and it's still not resolving a Public IP address.

"2. No other devices are connected to Arris TG1682G ethernet ports.

2. I do have things plugged in there so maybe that's the issue."

ISPs limit the number of Public IP addresses they assign to an account. Usually they only allow one device to resolve through the Ethernet ports. Most likely though when you put the Arris TG1682G in bridge mode the ethernet ports are not turned off. So if you have another device conneted the Orbi is racing the other device for that public IP address. 


This is why most retail modems have only one ethernet port as the ISPs limit number of devices. 

I would highly recommend only having the ORBI connected to the Arris TG1682G via ethernet and the other devices on the Orbi LAN ethernet ports




My Setup (Cable 1000Mbps/50Mbps)>CM1000>RBR50 V2.7.1.60(Router Mode)
Message 9 of 10
Highlighted
Aspirant

Re: Orbi RBR20 issues with Arris TG1682G Modem/Router for Xfinity.

So this ended up doing the trick for me. I followed these steps after resetting the Orbi to factory default. I then followed the setup using the app, NOT from a PC. I definitely think the issue was having other devices connected to the Arris modem/router.

Thanks for the assistance folks!
Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 454 views
  • 4 kudos
  • 4 in conversation
Announcements