Reply
flk2278
Initiate

Orbi RBR50 2.5.0.38 firmare bug

Attached devices list has bogus device name etc. info and can no longer be edited. Althought the edit device name screen appears no changes ever get applied after pushing apply button.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 11

Accepted Solutions
flk2278
Initiate

Re: Orbi RBR50 2.5.0.38 firmare bug

Version 2.5.0.40 fixes fo the problem for me.

View solution in original post

Message 4 of 11

All Replies
CrimpOn
Sensei

Re: Orbi RBR50 2.5.0.38 firmare bug

This has been a complaint since this firmware was released.  The ability to customize device names and types is "totally broken."

Some people have found that the new firmware solves more pressing problems.

Others have found even more deficiencies and have moved back to 2.3.5.30.

I, personally, waited to see what people were finding and have decided to ignore this firmware update.

I love my Orbi.
Message 2 of 11
FURRYe38
Guru

Re: Orbi RBR50 2.5.0.38 firmare bug

Care to give v40 a try? Looks like one user said the naming of devices seems fixed for him. 

https://community.netgear.com/t5/Orbi/Where-are-the-device-names-located-when-in-a-telnet-session/td...


@flk2278 wrote:

Attached devices list has bogus device name etc. info and can no longer be edited. Althought the edit device name screen appears no changes ever get applied after pushing apply button.


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 3 of 11
flk2278
Initiate

Re: Orbi RBR50 2.5.0.38 firmare bug

Version 2.5.0.40 fixes fo the problem for me.

View solution in original post

Message 4 of 11
FURRYe38
Guru

Re: Orbi RBR50 2.5.0.38 firmare bug

Awesome. Glad its working. Please mark your thread and solved so others will know. 

Besure to make a backup configuration to file for safe keeping.

 

Enjoy. Smiley Wink

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 5 of 11
TokyoHam
Aspirant

Re: Orbi RBR50 2.5.0.38 firmare bug

The new firmware (.40) did not fix the problem for me, although I didn't do a factory reset as it takes far too long to set everything back up. Although I still can't change/save device names or icons, .40 does at least correctly display previously saved names, rather than just showing the devices' MAC addresses.
Message 6 of 11
FURRYe38
Guru

Re: Orbi RBR50 2.5.0.38 firmare bug

One poster reported that a reset help with this for his system. If you need device naming abilit, you'll need to downgrade to v30 or v34. 


@TokyoHam wrote:
The new firmware (.40) did not fix the problem for me, although I didn't do a factory reset as it takes far too long to set everything back up. Although I still can't change/save device names or icons, .40 does at least correctly display previously saved names, rather than just showing the devices' MAC addresses.

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 7 of 11
pablohoney
Luminary

Re: Orbi RBR50 2.5.0.38 firmare bug

I got an email informing me that new firmware is currently undergoing "DQA testing" and if it qualifies it should be officially released next week.

 

I'm not holding my breath that it will fix the recent issues we all have been experiencing.

 

If it doesn't I'll be on to their CEO and CTO yet again asking them what sort of incompetence is going on within Netgear...

Message 8 of 11
pablohoney
Luminary

Re: Orbi RBR50 2.5.0.38 firmare bug

*That should be "SQA testing" not "DQA testing".

Message 9 of 11
lyricnz
Aspirant

Re: Orbi RBR50 2.5.0.38 firmare bug

Since foolishly updating from 2.3.5.x to 2.5.0.40, my RBR has started crashing/becoming unavailable every few days.  How can I downgrade back to 2.3.5.x which worked basically fine?  (slightly less pretty around device icons, but I didn't notice any other changes).

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 10 of 11
FURRYe38
Guru

Re: Orbi RBR50 2.5.0.38 firmare bug

Did you factory reset the RBR after applying v40? Mine never saw this crashing after I applied v40. 

 

You can downgrade to v34 if you want too. Just manually download the FW files and apply. I recommend factory reset the RBR and setup from scratch after applying v34 to ensure it's installed correctly. 


@lyricnz wrote:

Since foolishly updating from 2.3.5.x to 2.5.0.40, my RBR has started crashing/becoming unavailable every few days.  How can I downgrade back to 2.3.5.x which worked basically fine?  (slightly less pretty around device icons, but I didn't notice any other changes).


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.104(WW) Circle Enabled
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 11 of 11
Top Contributors
Discussion stats
  • 10 replies
  • 1878 views
  • 1 kudo
  • 6 in conversation
Announcements