Reply

Re: Orbi RBR50 Device Names not Saving

FURRYe38
Guru

Re: Orbi RBR50 Device Names not Saving

Some have said v40 works for them:

https://community.netgear.com/t5/Orbi/Orbi-RBR50-2-5-0-38-firmare-bug/m-p/1826207/highlight/true#M76...

If you choose to update, manually download the FW files for the RBS and RBR. Install them then factory reset the RBR and setup from scratch. See if this helps your system. I would factory reset the RBR and setup from scratch to remove any lingering older code.

 

NG is aware of the problem found in v38 and is working on it:

https://community.netgear.com/t5/Orbi/Orbi-RBR50-Device-Names-not-Saving/m-p/1827023/highlight/true#...

 

This isn't a show stopper problem, though a inconvienence for some, and it's only been a month since it was discovered.


@migsta wrote:

While it may be working for some folks on .30, devices is broken for me as well.  Hit and miss whether or not the device type and/or name stick.  I have no idea how Netgear can get away with this issue for as long as they have.  If Netgear was deploying software for Apple or Microsoft, they would have been fired for releasing such a release.  Or, at the very least, they would have fixed the issue the day of.  But, they don't care about the paying consumer that actually keeps them in business.  They have a glorified Executive Team that probably know nothing about ALL of the frustrating issues that their very products cause for us but it gives them a pretty good livelihood - as is mostly the case in the corporate world.


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 76 of 116
migsta
Apprentice

Re: Orbi RBR50 Device Names not Saving

It doesn't work.  It's broken.  I have used a brand new router (because i needed a satellite had the spare useless router) and i have factory reset including loading the firmwre using tftp command but it does not work.  Devices is broken.  And, as I've said countless times, devices works just as crappy on the RAX series routers.  Devices has been broken with Netgear for months.  This is issue is evident with the iOS app and GUI app and with all of your most popular routers.  Maybe, it works for Android folks?

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 77 of 116
FURRYe38
Guru

Re: Orbi RBR50 Device Names not Saving

Something to contact NG about or wait for the next FW update. Someone already said NG was planning a FW update this next month. 

 

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 78 of 116
FURRYe38
Guru

Re: Orbi RBR50 Device Names not Saving

https://community.netgear.com/t5/Orbi/2-5-0-40-Attached-Devices-Issue-on-RBR50-RBS50/m-p/1827366/hig...

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 79 of 116
Vasquezi
Aspirant

Re: Orbi RBR50 Device Names not Saving

Having the same issue on v38.  Device names not saving. Any solutions out there?

Message 80 of 116
tomschmidt
Virtuoso

Re: Orbi RBR50 Device Names not Saving

I suggest upgrading your firmware on your RBR50 and RBS50 to v2.5.1.8 to fix the device naming issue.  See https://www.netgear.com/support/product/RBR50#download

 


@Vasquezi wrote:

Having the same issue on v38.  Device names not saving. Any solutions out there?


RBK53 Orbi AC3000 Tri-band WiFi System (RBR50v1 router and two RBS50v1 satellites) running v2.5.1.16 firmware
Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 81 of 116
thrustercat
Aspirant

Re: Orbi RBR50 Device Names not Saving

I agree, this is very bad. I have the same issue, although it’s more related to device pictures. Clearly the save button is a load of bull.

NG - Shame on you for skimping on something called “Testing”!!!!!
Message 82 of 116
Orbipain
Guide

Re: Orbi RBR50 Device Names not Saving

Name changes are not holding on the RBR50 or the RBS50. Shouldn't this information be pulled automatically from the main Router? The names are correct on my ATT router.

Message 83 of 116
CrimpOn
Sensei

Re: Orbi RBR50 Device Names not Saving


@Orbipain wrote:

Name changes are not holding on the RBR50 or the RBS50. Shouldn't this information be pulled automatically from the main Router? The names are correct on my ATT router.


No.  The concept of having "names" and "descriptions" of devices is an embellishment to make looking at tables more convenient for users.  It is not standardized.  Orbi has no way of asking the primary router for information like this. (nor does any router I am aware of)

 

p.s. Having two routers "works ok" most of the time (I did it for over a year).  Eventually, however, there are specific situations that simply cannot work with two routers (internet gaming, VPN into the network, port forwarding.  As long as you do not need such services, you will be OK.  If in the future you wonder, "why can't I get this #### to work???", the first thing people on the forum will recommend is getting one of the devices out of router mode.

I love my Orbi.
Message 84 of 116
thrustercat
Aspirant

Re: Orbi RBR50 Device Names not Saving

I’m in the similar situation, feels like names are saving, but display pics are not... monitoring.
Message 85 of 116
FURRYe38
Guru

Re: Orbi RBR50 Device Names not Saving

What FW version are you using? v2.5.1.8 is supposed to have working FW for device naming. 


@thrustercat wrote:
I’m in the similar situation, feels like names are saving, but display pics are not... monitoring.

 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 86 of 116
thrustercat
Aspirant

Re: Orbi RBR50 Device Names not Saving

2.3.5.30

Message 87 of 116
FURRYe38
Guru

Re: Orbi RBR50 Device Names not Saving

v2.5.1.8 is supposed to have working FW for device naming. 


@thrustercat wrote:

2.3.5.30


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 88 of 116
Orbipain
Guide

Re: Orbi RBR50 Device Names not Saving

Well folks I just wanted to wish you poor Orbi owners a fond farewell as I have donated my 2 year old RBK50 Orbi package to charity. 2 years of ever increasing firmware failures have exceeded my patience and I've moved along to Ubiquti. With all of the increasing iterations of Orbi products now I find it difficult to see how firmware updates can be accurately applicable to all of them. The last update bricked my system and I've had enough. How many updates now? More than 25 I think and that, along with poor technical support, has put me on the boat to hopefully greener pastures. I will light a Candle for Y'all and lament a product that comes from a Company that I once trusted for reliable products. Oh well. 

Message 89 of 116
thrustercat
Aspirant

Re: Orbi RBR50 Device Names not Saving

@ NETGREAR >> My ORBI setup says no new firmware is available.  But I see there is a new version - is this a manual install only?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 90 of 116
tomschmidt
Virtuoso

Re: Orbi RBR50 Device Names not Saving

If you are running v2.5.0.x firmware, it was very buggy and was retracted by @netgear.  A manual update to v2.5.1.8 is recommended if you are running the v2.5.0.x releases,  If you are running v2.3.5.x firmware, it is pretty stable, so it is up to you if you want to upgrade to v2.5.1.8 from it for the latest.  Search this forum for v2.5.1.8 for more details.


@thrustercat wrote:

@ NETGREAR >> My ORBI setup says no new firmware is available.  But I see there is a new version - is this a manual install only?


 

RBK53 Orbi AC3000 Tri-band WiFi System (RBR50v1 router and two RBS50v1 satellites) running v2.5.1.16 firmware
Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 91 of 116
tomschmidt
Virtuoso

Re: Orbi RBR50 Device Names not Saving

I understand your frustration with the Orbi firmware, I feel the same pain.  Technical Support from @netgear has been unacceptable.  Their firmware team has released buggy firmware too many times and has taken too long to correct the issues.  Many cases of their updates breaking and bricking working systems!  Thus they turned off their autoupdate of firmware.

 


@Orbipain wrote:

Well folks I just wanted to wish you poor Orbi owners a fond farewell as I have donated my 2 year old RBK50 Orbi package to charity. 2 years of ever increasing firmware failures have exceeded my patience and I've moved along to Ubiquti. With all of the increasing iterations of Orbi products now I find it difficult to see how firmware updates can be accurately applicable to all of them. The last update bricked my system and I've had enough. How many updates now? More than 25 I think and that, along with poor technical support, has put me on the boat to hopefully greener pastures. I will light a Candle for Y'all and lament a product that comes from a Company that I once trusted for reliable products. Oh well. 


 

RBK53 Orbi AC3000 Tri-band WiFi System (RBR50v1 router and two RBS50v1 satellites) running v2.5.1.16 firmware
Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 92 of 116
Orbipain
Guide

Re: Orbi RBR50 Device Names not Saving

The funniest thing is that the Orbi automated website just gave me 5 points and an upgrade to "Luminary" status. Nice job Roboadmin!

Message 93 of 116
CrimpOn
Sensei

Re: Orbi RBR50 Device Names not Saving


@Orbipain wrote:

 I've moved along to Ubiquti.


I hear great things about Ubiquiti.  After you have some experience with it, I would be delighted if you would come back and leave a comparison.  How does the performance compare?  The cost?  What are the feature differences?  Does it "do more", or are some features not available.  How does support compare?

 

Two years ago when I was frustrated with my R7000, Orbi was pretty much the "only game in town."  (The new Nighthawk mesh had not been released.)  Reviews all rated Orbi on top.  I do not plan to change until we have WiFi 6 devices in the house that will benefit from a WiFi upgrade, and everybody will be selling WiFi 6 products.  I certainly will remember all these Netgear forum discussions when looking for a replacement, and will be browsing reviews and other user forums.

 

Good Luck

I love my Orbi.
Message 94 of 116
FURRYe38
Guru

Re: Orbi RBR50 Device Names not Saving

v2.5.1.8 is here:

https://www.netgear.com/support/product/RBK50.aspx#download

 

Manully update the RBS first then the RBR. I recommend a factory reset and setup from scratch. 

 

Mines running like a great on this version of FW. 

 


@thrustercat wrote:

@ NETGREAR >> My ORBI setup says no new firmware is available.  But I see there is a new version - is this a manual install only?


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 95 of 116
kalyson
Aspirant

Re: Orbi RBR50 Device Names not Saving

I am on firmware version V1.4.1.42_1.3.4  and upgraded from .30.    This exact problem showed up after the upgrade.  

 

So apparently Netgear has STILL not been able to fix this problem.

 

Pathetic.    Looking at other router manufacturers now.

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 96 of 116
Mac_G
Aspirant

Re: Orbi RBR50 Device Names not Saving

I would if I could too.

Amplifi or Unifi?

Message 97 of 116
CrimpOn
Sensei

Re: Orbi RBR50 Device Names not Saving


@kalyson wrote:

I am on firmware version V1.4.1.42_1.3.4  and upgraded from .30.    This exact problem showed up after the upgrade.  

So apparently Netgear has STILL not been able to fix this problem.

Pathetic.    Looking at other router manufacturers now.


This is a bit confusing.  The model referenced in the post footer lists Nighthawk, yet this is a user forum for Orbi.  V1.4.1.42_1.3.4 is not a firmware release for the RBR50.  The latest Orbi firmware for my RBR50 updates device descriptions and types and seems to "stick".  While the episode has been dismal, and I remain annoyed to lose the pretty pictures and device types, it is hardly a problem I would consider scrapping a network for.  (Buying new WiFi because I'm bored and want to upgrade, sure. But, because device names are not the way I like them?)

 

I love my Orbi.
Message 98 of 116
migsta
Apprentice

Re: Orbi RBR50 Device Names not Saving

Device manipulation, including the naming of devices and selecting device types is Fundamental to any router operation. NETGEAR can’t seem to understand this let alone fix it. It’s embarrassing that they release such atrocious software behind such quality hardware.
Message 99 of 116
FURRYe38
Guru

Re: Orbi RBR50 Device Names not Saving

Um, your way behind on FW. v2.5.1.8 has solved the device naming issue. Please manually download it and apply to your RBS first then RBR lastly. Factory reset the system and setup from scratch. Then name your devices. It works. 


@kalyson wrote:

I am on firmware version V1.4.1.42_1.3.4  and upgraded from .30.    This exact problem showed up after the upgrade.  

 

So apparently Netgear has STILL not been able to fix this problem.

 

Pathetic.    Looking at other router manufacturers now.


 

My Setup (Cable 1Gbps/50Mbps)>CM1200 v2.02.03(LAG Disabled)>RBK853 v3.2.18.223/SRK30 V3.2.33.106)
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, RBK50, R7800, R7960P, EX7500/EX7700, XR450(v2.3.2.120) and WNHDE111
Message 100 of 116
Top Contributors
Discussion stats
Announcements