Reply
Highlighted

Orbi & the new Roomba i7+ connectivity

(I apologize for the repost. There was some sort of techinical error with my original post.)

We recently purchased a Roomba i7+. We could not get it to connect to Roomba's servers to update it's software, and got a persistent "Robot is attempting to register with cloud," message. Because of this, a couple of it's main features were unavailable to us (History and Smart Maps.)  In order to use these, the robot has to connect to their cloud. I can connect to and operate my Roomba via Wi-Fi, but the Roomba cannot connect to iRobot.

 

After working with iRobot customer support and trying numerous things, I decided to pull out an old router we had laying around--a Netgear WNDR3700.  As soon as I got that up and running, we were able to update the Roomba with no issues. Smart Maps and History were available to us to use. The "Robot is attempting to register with cloud" message was replaced by a, "Robot is communicating with MQTT broker" message. 

 

All was good. However, as soon as I switched the router back to the Orbi, the first message reappeared and Smart Maps and History were grayed out. 

I have scoured these forums trying to find the cause, and have no clue what else to try. This has already been a three week ordeal. Any ideas are appreciated!

Setup: 
Orbi RBR50 and two RBS50 Satellites, all using v2.2.1.210

Arris SB8200 modem (ours, not rented)

What I have tried:
-enabling/disabling Daisy Chain, UPnP, Fast Roaming, IPv6, Implicit Beamforming (only changing one thing at a time)

-disabling security, changing it from WPA2-PSK to NONE

-forcing my phone and the Orbi onto 2.4 GHz (unlike previous versions of Roomba which only worked with 2.4 GHz, the i7 also works on the 5 GHz channel)

-unplugging the satellites, so that both my phone and the Roomba connect directly with the router

-both 2.4GHz and 5GHz changed CTS/RTS Threshold to 2307

-plugging the 3700 into the Orbi, and connecting to that with a different SSID than the Orbi

Model: RBR50| Orbi AC3000 Tri-band WiFi (Router Only), RBS50| Orbi AC3000 Tri-band WiFi (Satellite Only)
Message 1 of 21

Accepted Solutions
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

Yes if you had a modem/router combo before and it wasn't bridged, the Orbi will re-configure for 10. address pool. Since you have the newer SB series modem only, I presume you haven't every reset the Orbi thus keeping the 10 address pool. This is fine. It could be possible that maybe if you have not done a reset on the Orbi since, then maybe you can do this as a last resort. 

 

Yes you set up the DMZ for the 3700 correctly. I was hoping this would help avoid any issues between the Orbi and Roomba however someting seems to be keeping the Roomba from fully connecting. It's possible there is some port issue or someting on Orbi thats stopping it. 

 

Yes you'll see other wired devices on the 3700 as it's connected client app is searching was connected to it's LAN port thus seeing other devices stemming from the Orbi thru the 3700. This is expected. 

 

If you decide to do the factory reset on the Orbi, go ahead and turn OFF the 3700 and Roomba for now. Set up the Orbi router from scratch, walk thru the setup wizard. This time you'll get a 192.168.1.1 on the router, You might first test the Roomba to see if it connects thru the router first. Then try setting WPA to disable temporarily. If the Roomba still does not connect fully with WPA disabled and it's services don't appear, then Roomba and NG need to review this and hopefully collaborate and find a fix. Be sure to re-enable WPA2 and AES after testing the Roomba.

 

 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111

View solution in original post

Message 13 of 21

All Replies
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

Try this, set up Guest network on the Orib and see if the Roomba will connect here...

 

Try the 3700 LAN to LAN connected to the Orbi. Ensure that the 3700 is configured for AP mode fully, I don't remember if the 3700 had a web page AP option or not. You can manually set AP mode by setting a new IP address for the routers IP address from 192.168.1.1 to .1.37. Turn OFF items such as uPnP, Firewall, Guest Network Wifi and any Traffic or QoS features. Configure the SSID on the 3700 for something different and make sure the channels between the Orbi and 3700 are far from each other, they can't be on the same channe. When these are all disabled, disable DHCP server at the very last. Save settings. Then connect the 3700 LAN port to a open LAN port on the Orbi. You should be able to access the 3700 web page at 192.168.1.37 from the Orbi side of it's LAN port with a wired PC. 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 2 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity

 Thank you for your help. I believe many things I have tried have come from reading your posts in my search. Smiley Happy  I DID try setting up a guest network on the Orbi and connectng to that. (It did not work.) Add that to the list of things I have tried. lol

I will try the other stuff with my 3700 and get back to you. 

Message 3 of 21
Highlighted
Retired_Member
Not applicable

Re: Orbi & the new Roomba i7+ connectivity

Message 4 of 21
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

Ok, keep us posted. I'm hoping the 3700 method will work. You may still need to put it's IP address into the Orbi DMZ as well. 

You can try separating the wifi SSIDs on the Orbi however I don't recommend it as this defeats the Orbi MESH design and purpose. So this is why I suggested the use of the 3700 as an entry point for the Roomba...


@JenEricRal wrote:

 Thank you for your help. I believe many things I have tried have come from reading your posts in my search. Smiley Happy  I DID try setting up a guest network on the Orbi and connectng to that. (It did not work.) Add that to the list of things I have tried. lol

I will try the other stuff with my 3700 and get back to you. 


 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 5 of 21
Highlighted
Retired_Member
Not applicable

Re: Orbi & the new Roomba i7+ connectivity


@FURRYe38 wrote:

Ok, keep us posted. I'm hoping the 3700 method will work. You may still need to put it's IP address into the Orbi DMZ as well. 

You can try separating the wifi SSIDs on the Orbi however I don't recommend it as this defeats the Orbi MESH design and purpose. So this is why I suggested the use of the 3700 as an entry point for the Roomba...

 

You could possibly reach out to those who have been successful in seperating the freqs.  The question would be did it affect overall performance of the Orbi?,..... as opposed to labeling it a defeatist effort.





 

Message 6 of 21
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

This doesnt' concern performance rather operation of the Orbi and connetion with devices. Some devices have issues with MESH systems and Smart Connect. There both router Mfr and Device participants involved. Not just NG. Device Mfrs have to ensure there devices and wifi drivers meet wifi standards. They may or may not depending on how they are set up and designed. Regardless, Users shouldn't have to separate the MESH system to make devices work. I've never had to along with others. if others have had to then thats fine as well. I believe NG may be close that solution or may work towards users not being able to separate as NG wants the Orbi working as intended. 

 


@Retired_Member wrote:

@FURRYe38 wrote:

Ok, keep us posted. I'm hoping the 3700 method will work. You may still need to put it's IP address into the Orbi DMZ as well. 

You can try separating the wifi SSIDs on the Orbi however I don't recommend it as this defeats the Orbi MESH design and purpose. So this is why I suggested the use of the 3700 as an entry point for the Roomba...

 

You could possibly reach out to those who have been successful in seperating the freqs.  The question would be did it affect overall performance of the Orbi?,..... as opposed to labeling it a defeatist effort.





 





My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 7 of 21
Highlighted
Retired_Member
Not applicable

Re: Orbi & the new Roomba i7+ connectivity


@FURRYe38 wrote:

This doesnt' concern performance rather operation of the Orbi and connetion with devices. 

 

There's your answer.  No performance degrade. Mesh or no mesh.  

 

Users shouldn't have to separate the MESH system to make devices work. 

 

I agree so let NG fix it.  When I spoke with the maker of my weather station they acted like they had never heard of the problem.  With the number of devices that will only connect at 2.4G, companies like NG need to figure it out soon.  From the standpoint of the network, the router controls who comes and goes, so I will point back to the Orbi (and all others).

 


@Retired_Member wrote:

@FURRYe38 wrote:

Ok, keep us posted. I'm hoping the 3700 method will work. You may still need to put it's IP address into the Orbi DMZ as well. 

You can try separating the wifi SSIDs on the Orbi however I don't recommend it as this defeats the Orbi MESH design and purpose. So this is why I suggested the use of the 3700 as an entry point for the Roomba...

 

You could possibly reach out to those who have been successful in seperating the freqs.  The question would be did it affect overall performance of the Orbi?,..... as opposed to labeling it a defeatist effort.





 


 


 

Message 8 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity

I am going to describe what I did, and hopefully you can tell me if I did it correctly. I am far from great at this stuff, so I rely on online tutorials.

 

-I already had different SSID's set up for both routers. I ensured all were on different channels.

-In Orbi, under Advanced>Setup>LAN setup, I changed the Starting and Ending IP address range from 10.0.0.2-10.0.0.254 to 10.0.0.2-10.0.0.250, because something I read said to manually set up an AP, you had to give the AP router an IP address within the same subnet, but outside of the DHCP range of the main router. 

 

-on the 3700, under Advanced>LAN Setup, I entered 10.0.0.254. I turned off UPnP, then I unchecked "Use Router as DHCP Server."

 

-I then connected a LAN port on the Orbi to a LAN port on the 3700.

What I am seeing now:
-I can successfully connect to the 3700's SSID's, with a working internet connection. I connected my phone and the Roomba to it. 

-My phone and the Roomba are connected to the 3700's SSID, but in the Roomba app and on my phone, they show they are connected to Orbi's IP address.

-In Orbi under attached devices, the 3700, the Roomba and my phone are all showing up as WIRED devices connected to the Orbi Router.

The issue with my Roomba still exists.

Let me know if I did something incorrectly. 

Message 9 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity


@FURRYe38 wrote:

Ok, keep us posted. I'm hoping the 3700 method will work. You may still need to put it's IP address into the Orbi DMZ as well. 

You can try separating the wifi SSIDs on the Orbi however I don't recommend it as this defeats the Orbi MESH design and purpose. So this is why I suggested the use of the 3700 as an entry point for the Roomba...



Exactly. Separating the SSID's is not something I want to do just to get this to work correctly. The new i-Series Roombas are the only ones that work on both 2.4 and 5 GHz networks. Is it still possible that is what is causing the issue?

In my original post, I  mentioned that I tried forcing both my phone and the Roomba to the 2.4 GHz band. (It was another tutorial I had read. I had changed signal strengths or something like that, and then verified that both were connected to 2.4 GHz instead of the 5 GHz they usually are connected to.)

Message 10 of 21
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

Yes great work on the 3700. you have it working. 

Odd though that the Orbi is using 10. address scheme though, default is 192.168.1...Well if it's working don't bother this. 

Lets try adding the IP address for the 3700 in to the Orbi routers DMZ and save settings, reboot the router and 3700 and Roombas. 

 

Devices that are connected to the 3700 will show up as wired devices since the 3700 is actually a wired device connected to the Orbi router, so this is expected and ok. 

 

Hoping this will help. I would recommend that you contact the Mfr of Roomba and give them this thread and see if they have any input. If ALL others devices connect and working with the Orbi and the Roomba is the only device having problems, Both Rooma and NG will need to have a review of this. 

 

@ChristineT

@Christian_R


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 11 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity

Thanks for confirming that I did the AP setup correctly. 

The Orbi's IP as always been 10 for us. We have owned our fair share of routers, and it is a first for us. Back when we first got it, we used it with an modem/router combo from AT&T (fiber network.) Originally, we did not have the AT&T's router disabled. Maybe that has something to do with it? No clue! (We are currently using Cox's Gigablast service in a new state, as we had moved.)

Did I do this correctly? I went to ADVANCED>Setup>WAN Setup, clicked "Enable Default DMZ Server," and then entered the 3700's IP address. Then I reset everything. The issue still persists.  Even if it did work, what kind of security risk is there for having the 3700 in the Orbi's DMZ?

 

In the 3700's attached devices list, there are 9 devices now showing on the WIRED list, and then my phone and the Roomba in the Wireless.The Orbi Router and the two satellites are 3 of the 9 devices on the wired list. (Some were showing before I made the DMZ change.) 

I have been in touch with iRobot's support for a few weeks now. Over the weekend, I sent them a message letting them know that the 3700 worked, so that means there is an issue between Orbi and Roomba. They just responded suggesting that I check for a firmware update on the Orbi. That was one of the first things I had tried. Smiley LOL I will go ahead and link them with this thread, too.

Thank you so much for your help on this. I really appreciate it!

 


@FURRYe38 wrote:

Yes great work on the 3700. you have it working. 

Odd though that the Orbi is using 10. address scheme though, default is 192.168.1...Well if it's working don't bother this. 

Lets try adding the IP address for the 3700 in to the Orbi routers DMZ and save settings, reboot the router and 3700 and Roombas. 

 

Devices that are connected to the 3700 will show up as wired devices since the 3700 is actually a wired device connected to the Orbi router, so this is expected and ok. 

 

Hoping this will help. I would recommend that you contact the Mfr of Roomba and give them this thread and see if they have any input. If ALL others devices connect and working with the Orbi and the Roomba is the only device having problems, Both Rooma and NG will need to have a review of this. 

 

@ChristineT

@Christian_R


 

Message 12 of 21
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

Yes if you had a modem/router combo before and it wasn't bridged, the Orbi will re-configure for 10. address pool. Since you have the newer SB series modem only, I presume you haven't every reset the Orbi thus keeping the 10 address pool. This is fine. It could be possible that maybe if you have not done a reset on the Orbi since, then maybe you can do this as a last resort. 

 

Yes you set up the DMZ for the 3700 correctly. I was hoping this would help avoid any issues between the Orbi and Roomba however someting seems to be keeping the Roomba from fully connecting. It's possible there is some port issue or someting on Orbi thats stopping it. 

 

Yes you'll see other wired devices on the 3700 as it's connected client app is searching was connected to it's LAN port thus seeing other devices stemming from the Orbi thru the 3700. This is expected. 

 

If you decide to do the factory reset on the Orbi, go ahead and turn OFF the 3700 and Roomba for now. Set up the Orbi router from scratch, walk thru the setup wizard. This time you'll get a 192.168.1.1 on the router, You might first test the Roomba to see if it connects thru the router first. Then try setting WPA to disable temporarily. If the Roomba still does not connect fully with WPA disabled and it's services don't appear, then Roomba and NG need to review this and hopefully collaborate and find a fix. Be sure to re-enable WPA2 and AES after testing the Roomba.

 

 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111

View solution in original post

Message 13 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity

That makes sense. No, we didn't do any sort of factory reset on the Orbi when we moved, or after I had figured out that having two routers was causing our double NAT.  I do like the 10's for its simplistic look, though. lol Are there any disadvantages to the 10's? If I do do a factory reset and it gives me the ol' 192, can I manually switch it back to 10's if I want? Smiley LOL


It is sounding like a full reset may be necessary. I don't think it should be too big of a deal other than having to rename a few things. UPnP has been working pretty well, for the most part, so we don't even have anything port forwarded anymore. 

Message 14 of 21
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

Yes, if you still like using 10, you can certainly keep it. 

You might change the pool size to 100. to .200. Give you a bit more room for static IP addresses on either side. 

 

Yes, uPnP is working well and you don't need PF when it's enabled. 

 

Let us know how it goes with a reset and check the roomba. Worth a try. Smiley Frustrated

 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 15 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity

You Rock!!! Thank you so much for taking the time to help me out. The factory reset worked, THANK GOODNESS!!!

 

Unless I missed something, all the settings were the same after the reset except for Daisy Chain and IPv6. Daisy Chain was turned on, and IPv6 was turned off. I had toggled the Daisy Chain on and off while troubleshooting, but never turned off IPv6.  I successfully turned IPv6 back on and all still works fine. I'm pretty curious what caused the issue, but I am so glad it is working now.

 

Oh, and my husband was the one that switched the network to 10. when we bought the Orbi. He said it is more secure. I did set up the new network with 10 because it is prettier than 192. Smiley Tongue

Message 16 of 21
Highlighted
Guru

Re: Orbi & the new Roomba i7+ connectivity

Great to hear. Glad its working. 

 

Ya there may have been some hold over settings from prior use of the other ISP modem which could still have been in the router configuration. I've noticed that when switching ISP modems, the Orbi seems to hold on to some of these settings for unknown reasons, and the only way to get them blown out is to factory reset. Well if you tried daisy chain and IPv6 and Roomba is still working, I presume it may not be something related to those. 

 

Thats funny. 10 is not more secure than any other IP address. You can use 10, 172 or 192 or any class C address schema. However asthetics and looks is everything. LOL. Smiley Tongue

 

Enjoy. Smiley Wink


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 17 of 21
Highlighted
Aspirant

Re: Orbi & the new Roomba i7+ connectivity

I'm sorry, I don't understand what the solution is.  We have the same issue.  We have the Orbi system setup and we have the i7+ and can't get any of the cloud functions to work.  Could someone add another post that does a step by step solution?

Also, did I read correctly that the roomba will work on the 5GHz network?

Thanks.

Model: RBK30| Orbi AC2200 WiFi System
Message 18 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity


@wischmi2 wrote:

I'm sorry, I don't understand what the solution is.  We have the same issue.  We have the Orbi system setup and we have the i7+ and can't get any of the cloud functions to work.  Could someone add another post that does a step by step solution?

Also, did I read correctly that the roomba will work on the 5GHz network?

Thanks.


I had to factory reset my Orbi. Try these instructions. You will have to set everything back up after you reset. And yes, the i7+ works on 5GHz. I have not had any issues with mine since doing the factory reset. Truthfully, a factory reset is much more simple than any of the other stuff you saw me try. Smiley Very Happy

 

https://kb.netgear.com/31486/How-do-I-reset-my-Orbi-system-to-factory-default-settings

Message 19 of 21
Highlighted
Aspirant

Re: Orbi & the new Roomba i7+ connectivity

Thanks for the quick response!

I tried doing the factory reset and now that we have re-connected the Orbi network and factory reset of the vacuum (i7+) the iphone doesn't see the roomba anymore.  Unfortunately, it looks like that did not solve the issue.  

 

So all you did was a factory reset and setup your Orbi correct?

 

Message 20 of 21
Highlighted

Re: Orbi & the new Roomba i7+ connectivity

I don’t think I uninstalled and reinstalled the app on my iPhone after factory resetting the Orbi, but it may be worth trying.

Are you sure your iphone is reconnected to your Orbi network?
Message 21 of 21
Top Contributors
Discussion stats
  • 20 replies
  • 9948 views
  • 3 kudos
  • 4 in conversation
Announcements