× Some paid Circle Parental controls customers may be showing free options only. Router firmware correcting this issue will be available ASAP. Visit Status.NETGEAR.com for updates.

Discussion stats
  • 3 replies
  • 10128 views
  • 0 kudos
  • 2 in conversation
Announcements

Top Contributors
Reply
Highlighted
Aspirant

Orbi doesn't work with Chromecast. Please help

I just received my Orbi Rbk50 today. I got it set up and it updated to the latest firmware. My phone, ring doorbell, and Google home all connected fine and seem to be working but my Chromecast ver. 2 will not work. It says "Reconnect me. You are connected to the network but can not access the internet." I tried restarting the modem and Orbi and the Chromecast. I tried factory resetting the Chromecast several times. Is this a known issue? Any ideas? Thanks

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 1 of 4

Accepted Solutions
Highlighted
Guru

Re: Orbi doesn't work with Chromecast. Please help

What FW is currently loaded?
What is the Mfr and model# of the ISP modem the NG router is connected too?

What channels are you using? Auto? Try setting manual channel 1, 6 or 11 on 2.4Ghz and any unused channel on 5Ghz.
Try WPA instead of WPA2, then try WPA and AES Only.

 

Try disabling the following and see:
MIMO, Daisy Chain, Fast Roaming, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Save settings and reboot the router and satellite(s).
If you updated to recent FW v.210, try enabling Daisy Chain. Some have mentioned that this seems to be working in reverse order, enabling means disabled actually. So try this out as well.
https://community.netgear.com/t5/Orbi/Firmware-2-2-1-210-and-connection-problems-Skybell/m-p/1649275...


My Setup (Cable 900Mbps/50Mbps)>CM1100>Orbi RBK50 v2.5.1.16 and Orbi RBK853 v3.2.11.2(AP Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK852, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111

View solution in original post

Message 2 of 4

All Replies
Highlighted
Guru

Re: Orbi doesn't work with Chromecast. Please help

What FW is currently loaded?
What is the Mfr and model# of the ISP modem the NG router is connected too?

What channels are you using? Auto? Try setting manual channel 1, 6 or 11 on 2.4Ghz and any unused channel on 5Ghz.
Try WPA instead of WPA2, then try WPA and AES Only.

 

Try disabling the following and see:
MIMO, Daisy Chain, Fast Roaming, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Save settings and reboot the router and satellite(s).
If you updated to recent FW v.210, try enabling Daisy Chain. Some have mentioned that this seems to be working in reverse order, enabling means disabled actually. So try this out as well.
https://community.netgear.com/t5/Orbi/Firmware-2-2-1-210-and-connection-problems-Skybell/m-p/1649275...


My Setup (Cable 900Mbps/50Mbps)>CM1100>Orbi RBK50 v2.5.1.16 and Orbi RBK853 v3.2.11.2(AP Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK852, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111

View solution in original post

Message 2 of 4
Aspirant

Re: Orbi doesn't work with Chromecast. Please help

Thank you! I found out my Google home also did not have internet internet access. Man I was bummed out but in the end I only had to make one of your changes to get everything to work right. I'm on firmware ver. 2.2.1.210 and daisychain was on by default. Once I turned that off everything instantly started working!
Thank you!
Message 3 of 4
Highlighted
Guru

Re: Orbi doesn't work with Chromecast. Please help

Glad it fixed it. Enjoy. 

Smiley Wink


My Setup (Cable 900Mbps/50Mbps)>CM1100>Orbi RBK50 v2.5.1.16 and Orbi RBK853 v3.2.11.2(AP Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK852, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 4 of 4