Reply
Highlighted
Tutor

Problems Displaying Web Pages in Router Mode with Frontier

Situation: I'm with Frontier (old Verizon) and have 300 Mbps up and down. I used to have my Orbi RBK50 in AP mode connected to the ISP Modem (Verizon modem). Everything was fine except for a few details: sometimes videos would freeze for a short time and I could not enjoy some orbi features that are only available in Router mode. So, after readying about the experience of a few people in this forum I made the following change: Got rid or my ISP modem. Connected the ethernet cable from my ISP (Frontier ONT) directly to the WAN port in the Orbi RBK50 and switched the Orbi back to Router mode. I made no other changes.

If I mesure internet speed from the Orbi router, everything looks as good or better than before (getting 300+ Mbps up and down). If I measure network speed via WiFi (Ookla SpeedTest), everything looks as good or better than before.

Problem: The problem is that now some Apps or web pages take a long time to display (over 4 seconds) and often do not display completely (pictures and videos are missing). The most obvious one is Facebook. I have to refresh the page or close the app (on iPhone) and open it again for the pages to start displaying.

Questions: Any idea what could be the problem or what I can test? Could this be a DNS issue (currently the Orbi router does not have anything in the DNS setting). Could this be an MTU size issue (currently set at the 1500 default).

I thought of using the following methos to figure our the ideal MTU size:
https://kb.netgear.com/19863/Ping-Test-to-determine-Optimal-MTU-Size-on-Router

But I get 1472 which is exactly the maximung size for ping packets, so I don't think this helps:
https://kb.netgear.com/25675/How-do-I-change-the-MTU-size-on-my-NETGEAR-Wireless-Router-DSL-Gateway

Any other ideas before Resetting the Whole Orbi system? The Orbi RBK50 has the latest firmware: V2.3.5.30. I do have 3 satellites 1 RBS50 and 2 RBW30 (V2.3.5.6) but I don't think that's relevant since it doesn't matter if the client devices experiencing the problem are connected directly to the router. But open to suggestions.

Message 1 of 5

Accepted Solutions
Highlighted
Tutor

Re: Problems Displaying Web Pages in Router Mode with Frontier

Sorry, I meant that the DNS was set to Get Automatically from ISP. I changed it to use the Google DNS Servers and that didn't seem to help.

Hope I'm not speaking too early when I say that I may have found the culprit. I remember that when I changed the Orbi from AP mode Router mode I set the Internet Connection Type under IPv6 to Auto Detect. This is one of the new cool things I was looking forward to try since AP mode doesn't suport IPv6 (I think, or at least doen't offer any settins option).

It turns out that apparently Frontier (nor Verizon for that matter) support IPv6. I just set Internet Connection Type to Dissabled and althoug it's still too early to tell for sure it does seem to have fixed the problem. Fingers crossed.

View solution in original post

Message 3 of 5

All Replies
Highlighted
Sensei

Re: Problems Displaying Web Pages in Router Mode with Frontier


@Stevensa wrote:

Questions: Any idea what could be the problem or what I can test? Could this be a DNS issue (currently the Orbi router does not have anything in the DNS setting).


"Does not have anything" as in the button "Get automatically from ISP" is checked, but there are no values in the IP fields?

Can you look at the IP settings on one of the connected devices and report what they show for DNS?

 

It is pretty easy to test the DNS theory by putting in Google's DNS IP's (8.8.8.8 and 8.8.4.4)

I love my Orbi.
Message 2 of 5
Highlighted
Tutor

Re: Problems Displaying Web Pages in Router Mode with Frontier

Sorry, I meant that the DNS was set to Get Automatically from ISP. I changed it to use the Google DNS Servers and that didn't seem to help.

Hope I'm not speaking too early when I say that I may have found the culprit. I remember that when I changed the Orbi from AP mode Router mode I set the Internet Connection Type under IPv6 to Auto Detect. This is one of the new cool things I was looking forward to try since AP mode doesn't suport IPv6 (I think, or at least doen't offer any settins option).

It turns out that apparently Frontier (nor Verizon for that matter) support IPv6. I just set Internet Connection Type to Dissabled and althoug it's still too early to tell for sure it does seem to have fixed the problem. Fingers crossed.

View solution in original post

Message 3 of 5
Highlighted
Sensei

Re: Problems Displaying Web Pages in Router Mode with Frontier

My IPv6 is set to "disabled".  I remember 15 years ago the network guru's were saying the IPv4 was "doomed" and everything would transition to IPv6.  Here we are today, with a gazillion devices connected and NAT is still plugging away.  I often disable IPv6 on my Windows machines.

I love my Orbi.
Message 4 of 5
Highlighted
Tutor

Re: Problems Displaying Web Pages in Router Mode with Frontier

Happy to report that everything is running smoothly fast now. That fixed the problem I was having.

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 768 views
  • 1 kudo
  • 2 in conversation
Announcements