Reply

Re: RBR10, slow internet using VLAN

old586whizz
Aspirant

RBR10, slow internet using VLAN

Heya guys,

 

I've been fairly pleased with my RBR10 Orbi (with 2 attached satellites to extend the range to cover the whole house).

I have had the opportunity to replace my internet to gain double the speed for half the price (fibre to the house) - so how could I say no!?

(Firmware: V2.7.3.22)

 

The ISP obviously gave me a router - which uses up extra power and does nothing for me - so I looked at setting up my Orbi router to replace it.. Doing so, I found my new ISP uses a VLAN configuration on the router.

 

So I do a speed test on both devices before doing anything:

Old ISP (RBR10) = ~350mbps download, 40mbps upload, both cabled and over 5G wifi...

New ISP (new router) = 370mbps download, 100mbps upload wifi (~800mbps down, 150mbps up cabled)

RBR10 through ethernet to new router = ~500mbps download, 110mbps upload wifi (~800mbps down, 150mbps up cabled).

Laptop using VLAN config plugged directly into fibre black box = ~800mbps download, 150mbps upload.

 

The RBR10 also has the "speedtest" internally, the RBR10 speeds reflect the cabled speeds (so I'm not losing speed anywhere through RBR10 yet).

 

HOWEVER, when I switch the RBR10 to be plugged into the ISP ethernet fibre box and set up the VLAN (vlan tag group is the only one that worked - the bridge group didn't work) things go funny.

 

First - Orbi seems to react badly to no internet access.. The admin pages take their time to return the settings, things like VLAN page and the wireless page seem to hang for about 6 minutes before returning the correct settings to the screen... Why is Orbi so reliant on an active internet connection to let me see or change the settings for Wifi!? This is a bit silly.

Anyway, skipping past that bit (and the fact it seems to reboot the router to set a VLAN setting to the internet port, when it shouldn't need to), I get the VLAN setup and it works (after taking a minute or two longer than I would expect).

HERE is when things get 'interesting' speed wise:

 

110mbps download, 30mbps upload (wifi AND cabled) over the new fibre connection.

"speedtest" button in the Orbi router settings = ~800mbps download, ~150mbps upload (what I would expect).

 

This surprised me..

Why is my Orbi router taking such a big hit, both wireless and wired, to simply put VLAN tagging on the TCP packets leaving the internet ethernet port? As it's Linux under the hood, it should just be a vlan bridge device handled by the kernel, and not much extra processing needed (standard 802.11q + p).

 

Does anyone have any advice on this issue, as I don't want to power another router simply to VLAN-tag the internet traffic due to the fact the orbi router cuts the speed to 12% of the speed I should be getting (wasting a plug socket, the electricity, space, cables, etc).

 

Any help is much appreciated.

 

--

Old586whizz

Message 1 of 3
old586whizz
Aspirant

Re: RBR10, slow internet using VLAN

Hazel,

 

That's a slight "takeover" of my original thread concerning VLAN speed issues, however:

 

1) Bridge vs AP .. In AP mode I'm fairly sure the RBR20 just acts as a wireless hub onto your network, and so it would use your ISP's router as a DHCP server + firewall etc (basically, it shouldn't matter if it's bridge or AP mode to the ISP).... Do you mean "router" vs "AP", since those are the only modes I see on my RBR10.

 

2) Which wifi signals are you using? 2.4Ghz or 5Ghz?

I know you cannot disable one or the other in the RBR10, but if you name them differently (name-2G, name-5G) you can more easily see which wifi network you are connecting to.. That way you can:

a) Check the network settings for that specific wifi and adjust them if required

b) See if you're using 5G which should be capable of 500+mbps or 2.4G which would be closer to your 200mbps max speed of ISP .

 

3) Have you plugged in a laptop/PC to the LAN and done any speed testing (to show it is just Wifi or the actual router)? Have you tried turning off the Satellites and just testing the RBR directly (powering off the Satellites would stop any backhaul chatter cluttering wifi up).

 

4) Orbi in AP mode probably won't care about device specifics so I would assume it's down to that (as well as possible randomised MAC addresses now being popular with the mobile devices).. The categorizations will come from the leading characters of the MAC addresses, but in AP mode why should it care about categories and names - that's generally for the DHCP server to worry about.

 

--

Old586whizz

edit: fixed a typo

Message 2 of 3
old586whizz
Aspirant

Re: RBR10, slow internet using VLAN

Well - it seems that Netgear don't care too much with regards to their products or support (I emailed them regarding firmware updates and got no response).

 

So, in order to help anyone who mistakenly bought a Netgear product over any other competing product, I offer some assistance in order to try and fix your router woes.

 

Netgear has a "debug" page (http://<IP-of-router>/debug.htm) .

In some of these is often an "enable telnet" (why they aren't using SSH god only knows).

However, in some that option isn't available. Instead you have to use an external tool to enable telnet (google search 'netgear telnet enable github').. I won't link it here in case it's against forum policy.

Once that is enabled, you can telnet onto your router and use "admin" and the password as the login details...

 

I was able to log in and check some configs and details, and clear up some settings - and I could do it a LOT faster in here than waiting for the GUI to timeout due to the lack of internet because I cannot configure it due to the GUI timeouts!

Anyway, in here there are several things you can do now, but the most useful being the "config" command.

 

config show                # shows you the settings + values
config set setting=value   # sets a setting to a value
config commit              # writes this out to nvram to take effect later

 

Basically those are the important bits.

There's other commands if you want to look into it..

swconfig       # switch config, helpful for VLANs etc
brctl          # bridge control command, useful for how the devices are bridged together for coms
ip a s         # list out the ethernet devices + IPs
iwconfig       # show/configure the wireless devices
ethtool        # show/configure ethernet device settings
ssdk_sh        # very complicated, I'd leave this to how the scripts use it .. look in /tmp/ssdk.sh for what it does to set up your vlan

 

So I log in and check the config with "vlan" in the setting name... I notice that some settings probably should be set differently.

So I correct some settings, please see the below as an example of the CORRECT settings that allow your internet to be VLAN-tagged, but your ethernet/internet network will not be:

root@RBR10:/# config show |sort |grep -i vlan
enable_vlan=1
i_opmode=vlan
iptv_vlan=0
iptv_vlan_enable=0
set_vlan_tag=0
vlan_edit_num=1
vlan_tag_0=1 Intranet 11 0 0 0
vlan_tag_1=1 Internet 123 0 0 0
vlan_type=1

(I've deleted the unimportant lines above)

 

In order to, for example, set the "Internet" VLAN to 234, you would do the following:

root@RBR10:/# config set vlan_tag_1="1 Internet 234 0 0 0"
root@RBR10:/# config commit
root@RBR10:/# reboot

 

Once that is done, I have found that the network speeds are now correct through the RBR10 (~900mbps ethernet, ~450mbps wifi.. Which is around the max).

 

--

Old586whizz

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 259 views
  • 0 kudos
  • 1 in conversation
Announcements

Orbi WiFi 6E