Reply
Highlighted
Aspirant

RBR20 - Slow upload

Hi, 

 

It's been a while since I have this issue with my Orbi system. I looked for a solution but I couldn't find any. 

 

I have my Orbi router connected directly to my home fiber and if I run a speedtest from Orbi's app speeds are fine. If I do it from any device upload is quite slow. Download is fine, it drops if I'm connected to a satellite instead of the router but that's not an issue I suppose. 

 

For the upload it doesn't matter if I'm connected to the router or to a satellite, if I'm using wifi or ethernet or if I connect the Orbi to the ISP's router. It's always slow.

Sometimes restarting all the system fixes the problem for a while, like an hour or so, but then it comes back. 

 

I also attached a speedtest to prove the issue. 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 4
Highlighted
Guru

Re: RBR20 - Slow upload

What Firmware version is currently loaded?
What is the Mfr and model# of the Internet Service Providers modem/ONT the NG router is connected too?

 

IF you see same issue while connected to the ISPs router with out the Orbi online, then you'll need to contact the ISP about this. This would be an ISP issue. 

 

This would be a double NAT (two router) condition which isn't recommended. https://kb.netgear.com/30186/What-is-Double-NAT
https://kb.netgear.com/30187/How-to-fix-issues-with-Double-NAT
Couple of options,
1. Configure the modem for transparent bridge or modem only mode. Then use the Orbi router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ/ExposedHost or IP Pass-Through for the IP address the Orbi router gets from the modem. Then you can use the Orbi router in Router mode.
3. Or disable all wifi radios on the modem and connect the Orbi router to the modem, configure AP mode on the Orbi router. https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point and https://www.youtube.com/watch?v=H7LOcJ8GdDo&app=desktop

 

Please avoid posting any WAN IP address information in forums and pictures for security reasons. 


My Setup (Cable 900Mbps/50Mbps)>CAX80>XR450 v2.3.2.106(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 2 of 4
Highlighted
Aspirant

Re: RBR20 - Slow upload

Thanks for you answer. I'm on V2.3.5.36 and at the moment i don't have any ips router connected. The orbi router directly connects to the Nokia ONT I have. Using isp's router between ont and orbi doesn't solve the problem. I also tried using the orbi as access point to make sure that there is no double nat or stuff like that but it doesn't make a difference. 

Message 3 of 4
Highlighted
Guru

Re: RBR20 - Slow upload

Try a factory reset and setup from scratch. Soon as the wizard completes, don't enable Armor, Access Controls, QoS speed test or Traffic Meter, just run the ookla speed test app from a wired PC. 

 

Might update to v16 as last restort as well:

https://community.netgear.com/t5/Orbi/RBR50-RBS50-Firmware-2-5-1-16-Update/m-p/1897955/highlight/tru...

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>XR450 v2.3.2.106(Router Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 129 views
  • 0 kudos
  • 2 in conversation
Announcements