Reply

RBR50 Suddenly Stopped Working

chenhli
Tutor

RBR50 Suddenly Stopped Working

Hello,

 

On 1/8/2019, I purchased the RBK50 Wifi system from BestBuy in Michigan, USA.

 

I gave the system to my parents, and they took it back to Taiwan (where they live now) to enhance their Wifi coverage at home (and the product was registered in Taiwan). They were very pleased with the performance of the product and enjoyed having it very much, however, a few days ago the main router (RBR50) suddenly stopped working. There is no light at all even though the power is on. We tried different ways to resolve the issue such as cycling the power and resetting the system, but the issue remains and it seems to be a hardware issue.

 

Since the product is still under hardware warranty, we would like to obtain a replacement for it. Since the product was purchased in the US but registered in Taiwan, should my parents contact Netgear Taiwan for the warranty claim? Or should they bring the product to the US, and do the warranty claim in the US?

 

Thank you!

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 13

Accepted Solutions
chenhli
Tutor

Re: RBR50 Suddenly Stopped Working

Solution found. No further response needed.

View solution in original post

Message 4 of 13

All Replies
Chuck_M
Mentor

Re: RBR50 Suddenly Stopped Working

This kind of question should be directed at Netgear support and not on this community forum.

 

This community forum is only for technical support by users (not netgear employees) who just try and help each other.  None of us speak on behalf of netgear.

 

Good luck.

---------------
My Equipment: Cox Cable (350Mb/35Mb), Orbi AX6000 (RBR850, 3 x RBS850) (2xWired backhaul), NG GS116PP Gigabit Smart Switch, Synology DS1019+ NAS
Message 2 of 13
FURRYe38
Guru

Re: RBR50 Suddenly Stopped Working

@Blanca_O 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 3 of 13
chenhli
Tutor

Re: RBR50 Suddenly Stopped Working

Solution found. No further response needed.
Message 4 of 13
FURRYe38
Guru

Re: RBR50 Suddenly Stopped Working

Please let us know how it got the problem solved so others will know. 

Thank you. 


@chenhli wrote:
Solution found. No further response needed.

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 5 of 13
newak47
Aspirant

Re: RBR50 Suddenly Stopped Working

Hi Chenhli

Can you please let us know how this was resolved - as I and  many others (it would seem) have a similar issue. Thanks

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 6 of 13
FURRYe38
Guru

Re: RBR50 Suddenly Stopped Working

Please make a new post and let us know whats wrong with your system and we'll try to help you out. 


@newak47 wrote:

Hi Chenhli

Can you please let us know how this was resolved - as I and  many others (it would seem) have a similar issue. Thanks


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 7 of 13
chenhli
Tutor

Re: RBR50 Suddenly Stopped Working

Hi,

 

The technical issue of the Orbi system itself was not resolved. We tried all trouble shooting methods we found and none of them worked, and at this point we are guessing that it is a hardware issue. The solution I got from the customer service was getting a replacement through the hardware warrenty.

 

You can contact them through customer.service@netgear.com (it took them almost a week to reply my first email), or just call 1-888-638-4327 if you live in the US.

 

Just FYI, 3 replacement options they provided are (for customers living in the US):

1. Standard Swap Option: send the defective product back to Netgear warehouse, they will run some tests to determine the issues. If issues are confirmed, the replacement will be shipped back in 5-7 days. No charge.
2. Advanced Ground Shipping Option: Netgear to send replacement first in 4-5 days with $16.99 charge for shipping, and we send the faulty unit back to Netgear in a couple days.
3. Advanced Next Business Day Shipping Option: same as the advanced option, but it costs $29.99 and ships within 24-48 hours.

 

I will start the replacement process in about 2 weeks. Let's see how it goes.

Message 8 of 13
FURRYe38
Guru

Re: RBR50 Suddenly Stopped Working

Thanks for letting us know the status. Hope the RMA unit works for you. 

Good Luck. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 9 of 13
newak47
Aspirant

Re: RBR50 Suddenly Stopped Working

For what it's worth, my issue also appears resolved. I simply unplugged the RBR50 from router and power, left it for 24 hours and plugged back in to power. I got a magenta LED, plugged back in to modem, and it connected. RBS50 also connected. It has reset to Firmware version  1.8.0.6, buit at least it is no long er the brick I thought it was. No idea why unplugging worked, but I'm happy so far, Thought I'd post as all other "solutions" seem to be RMA, and I am not sure I had that option (2nd hand purchase). Wanted to give others hope...!

Funnily enough, as I am typing this, the satellite is  rebooting, and has gone offline...I almost feel that I am being watched/cursed... 🙂

All good - blue LED, and we're  back. Spooky.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 10 of 13
FURRYe38
Guru

Re: RBR50 Suddenly Stopped Working

What FW version is your RBR and RBS at? 


@newak47 wrote:

For what it's worth, my issue also appears resolved. I simply unplugged the RBR50 from router and power, left it for 24 hours and plugged back in to power. I got a magenta LED, plugged back in to modem, and it connected. RBS50 also connected. It has reset to Firmware version  1.8.0.6, buit at least it is no long er the brick I thought it was. No idea why unplugging worked, but I'm happy so far, Thought I'd post as all other "solutions" seem to be RMA, and I am not sure I had that option (2nd hand purchase). Wanted to give others hope...!

Funnily enough, as I am typing this, the satellite is  rebooting, and has gone offline...I almost feel that I am being watched/cursed... 🙂

All good - blue LED, and we're  back. Spooky.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 11 of 13
newak47
Aspirant

Re: RBR50 Suddenly Stopped Working

V1.8.0.6

And it's saying "No new firmware version available" when I log in to Orbilogin.net so can't seem to update that way.

Was hoping it would update itself, as I'm loathe to touch it - but nothing so far. Will look into updating manually, but not sure how to connect directly to PC. Any tips?!

Message 12 of 13
FURRYe38
Guru

Re: RBR50 Suddenly Stopped Working

Yes, download v2.0.0.74 FW files for both RBR and RBS. Apply the FW file to the RBS first, then the RBR lastly. After that, you can apply the latest v60 FW file to the RBS first.

 

The RBR it was required to apply v212 first then you can apply v32 or later version up to v60. Not sure if you can go directly from v2.0.0.74 to v60 on the RBR with out the v212. I would apply the v212 first on the RBR then apply v60. 


@newak47 wrote:

V1.8.0.6

And it's saying "No new firmware version available" when I log in to Orbilogin.net so can't seem to update that way.

Was hoping it would update itself, as I'm loathe to touch it - but nothing so far. Will look into updating manually, but not sure how to connect directly to PC. Any tips?!


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 13 of 13
Top Contributors
Discussion stats
  • 12 replies
  • 4045 views
  • 2 kudos
  • 4 in conversation
Announcements

Orbi WiFi 6E