Discussion stats
  • 40 replies
  • 4383 views
  • 9 kudos
  • 14 in conversation
Announcements

Top Contributors
Reply
Highlighted
Guide

RBR50 with Firmware 2.5.1.8

I just did a manual update to 2.5.1.8 from 2.5.0.38 as I also added a 4th satelitte. Everything is connected via ethernet backhaul.

 

 

Everything is running fine (ALL wifi switches and echo dots work) except now ALL my devices connected to wifi both on orbilogin and the orbi app have disappeared from DEVICE MANAGER on the orbi app as well as the orbilogin.net page. Only the HARDWIRED ethernet devices are showing up. I had to do a manual update on the router and the orbi satellite as the AUTO-updater was not updating my newest satellite from formware ver 2.3.1... while the router and my 3 satellites were sitting with ver 2.5.0.38.

 

Can anyone guiode me on what to do? I also can't find the 2.5.0.38 and am afraid I may have to do a hard reset.

 

Thoughts?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 41
Highlighted
Master

Re: RBR50 with Firmware 2.5.1.8

I would first determine whether the issue in on the Orbi or on the "app".  Can you connect to the Orbi web interface and look at the "Attached Devices" page?

 

There is also a community forum specifically for the App https://community.netgear.com/t5/Orbi-App/bd-p/en-home-orbi-app 

I love my Orbi.
Message 2 of 41
Highlighted
Guide

Re: RBR50 with Firmware 2.5.1.8

So I did login to the GUI on the orbilogin webpage off my PC and again NO DEVICES were listed although they certainly are ALL connected.

Message 3 of 41
Highlighted
Master

Re: RBR50 with Firmware 2.5.1.8

No devices, or no WiFi devices?  Some people think the "factory reset" cleans out garbage and allows the firmware to work correctly.

I, myself, cringe at the thought.  I might be willing to "wait and see" if the device list improves on its own before doing a reset.

I love my Orbi.
Message 4 of 41
Highlighted
Guide

Re: RBR50 with Firmware 2.5.1.8

Wi-Fi devices. My Ethernet devices pop up just fine.
Message 5 of 41
Highlighted
Master

Re: RBR50 with Firmware 2.5.1.8

Well, once again, "I got nothin" (except that it reinforces my position to wait until January to consider updating firmware from 2.3.5.30).

 

Maybe you could consider the process of a factory reset and setup from scratch a form of meditation?  Spend an hour or so typing things into the Orbi LAN setup and device naming screens, checking each one off a master list until "Done".

 

A hint:  I found that a new setup worked best for me when I initially left the Orbi name at the factory default, rather than changing it to match my previous setup.  That way, none of my devices would attach to the Orbi before I had made all the IP assignments and was ready for them.  After the DHCP definitions and LAN setup, then I would go back and change the SSID so that everything could attach.

I love my Orbi.
Message 6 of 41
Highlighted
Guide

Re: RBR50 with Firmware 2.5.1.8

So I reverted back to 2.3.5.30 and all is well!!!

Download here:

https://kb.netgear.com/000061080/RBR50-RBS50-Firmware-Version-2-3-5-30

Message 7 of 41
Highlighted
Master

Re: RBR50 with Firmware 2.5.1.8

And no factory reset.  Great News!

I love my Orbi.
Message 8 of 41
Highlighted
Tutor

Re: RBR50 with Firmware 2.5.1.8

I encountered your problems exactly when upgrade to 2.5.1.8. and have no choice to roll back to 2.3.5.34 satellite remains 2.5.1.8   Everything seems fine.

 

Seems 2.5.1.8 have problem, might wait for next update or a solutions for "No WiFi connected devices" solved.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 9 of 41
Highlighted
Tutor

Re: RBR50 with Firmware 2.5.1.8

Same problem here after update, so try to install old firmware

Message 10 of 41
Highlighted

Re: RBR50 with Firmware 2.5.1.8

Hi,

 

I came to the community to see if I can fixed the same problem with my devices not showing up properly in the Orbi app and webbase version. I'm still running firmware version 2.5.0.38. So, the problem you may be having is not due to the new update v2.5.1.8. Does it make since for me to update to v2.5.1.8 before the device problem is fixed?

Thanks,

Aaron


@ahmer1213 wrote:

I just did a manual update to 2.5.1.8 from 2.5.0.38 as I also added a 4th satelitte. Everything is connected via ethernet backhaul.

 

 

Everything is running fine (ALL wifi switches and echo dots work) except now ALL my devices connected to wifi both on orbilogin and the orbi app have disappeared from DEVICE MANAGER on the orbi app as well as the orbilogin.net page. Only the HARDWIRED ethernet devices are showing up. I had to do a manual update on the router and the orbi satellite as the AUTO-updater was not updating my newest satellite from formware ver 2.3.1... while the router and my 3 satellites were sitting with ver 2.5.0.38.

 

Can anyone guiode me on what to do? I also can't find the 2.5.0.38 and am afraid I may have to do a hard reset.

 

Thoughts?


 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 11 of 41
Highlighted
Virtuoso

Re: RBR50 with Firmware 2.5.1.8

The v2.5.1.8 firmware release for the RBR50 and RBS50 does fix the device naming issues caused by v2.5.0.x firmware.  NG has removed v2.5.0.x from their downloads due to the bugs in it.  You have to manually update to v2.5.1.8, as the auto-update feature is disabled, NG broke too many users by autoupdating their routers with defective firmware.

RBK53 Orbi AC3000 Tri-band WiFi System (RBR50v1 router and two RBS50v1 satellites) running v2.5.1.16 firmware
Model: RBK53|Orbi AC3000 Tri-band WiFi System, RBR50|Orbi AC3000 Tri-band WiFi Router
Message 12 of 41
Highlighted
Guru

Re: RBR50 with Firmware 2.5.1.8

Also if after updating to v2.5.1.8 exhibits problems, a factory reset and setup from scratch should be performed. I updated to v2.5.1.8 and didn't factory reset. Have had zero issues and device naming is working well on a RBK50. 

Working for others as well:

https://community.netgear.com/t5/Orbi/Orbi-RBR50-is-not-supporting-900Mb-on-the-WAN-to-LAN-test/m-p/...

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 13 of 41
Highlighted
Tutor

Re: RBR50 with Firmware 2.5.1.8

Thanks for the Hard Reset tips.  Might try if I have time.

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 14 of 41
Highlighted
Guru

Re: RBR50 with Firmware 2.5.1.8

Ya, sometimes there needed as a last resort. Others are reporting good operations with v2.5.1.8. When you do get it reset and setup again, be sure to save a backup configuration to file for safe keeping. 

 

If your system is out of warranty, you can also give Voxels FW for Orbi a try as well. 


@peteryung wrote:

Thanks for the Hard Reset tips.  Might try if I have time.


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 15 of 41
Highlighted
Guide

Re: RBR50 with Firmware 2.5.1.8

@FURRYe38 , thanks for the updates.

Curious if you did manual upgrade or did the Firmware Update page show you a new version is available? I don't see the new FW being availbe within the GUI yet. But can see the download itself on the Netgear Page.

Also do you have any experience if the statement from above is true that the iOS app has issues with this FW Version?

 

Would you recommend upgrading from 2.3.5.30 to 2.5.1.8?

 

Any thoughts much appreciated.

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 16 of 41
Highlighted
Tutor

Re: RBR50 with Firmware 2.5.1.8

Either the Web browser or in the Orbi Apps, Firmware update notifications are being shown.

Attach my web orbilogin page and the iOS App, the Firmware update notifications are shown

DA032A2F-965C-47BD-B21F-9A92071D6DB0.jpeg924245B8-9BA2-4E8D-8591-6BAC51B4A39D.png

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 17 of 41
Highlighted
Apprentice

Re: RBR50 with Firmware 2.5.1.8

Huh ... worked fine here.

 

Did you update the satellites first, one by one checking for reconnection to the router?

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 18 of 41
Highlighted

Re: RBR50 with Firmware 2.5.1.8

Yes, it is showing up for you because you’re at still V2.5.0.35. I’m at v2.5.0.38 and it’s not there.
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 19 of 41
Highlighted

Re: RBR50 with Firmware 2.5.1.8

Correction: You’re at v2.3.5.34.
Message 20 of 41
Highlighted
Tutor

Re: RBR50 with Firmware 2.5.1.8

So glad I came across this post.  I was just about to decide to pull the trigger and go ahead with a manual update from version V2.3.5.30 to the latest 2.5.1.8 as neither in the web interface nor the orbi app has the feature 'Online Update' returned any updated firmware version info.

 

Recently logging into the gui for my EX3700 WiFi Range Extender showed the  "New update is available".  Now of course that thing seems to be behind by 9 versions of firmware releases however.  

 

 

Def will wait for awhile to go ahead with the V2.3.5.30 update.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 21 of 41
Highlighted
Guru

Re: RBR50 with Firmware 2.5.1.8

Been no issues with v2.5.1.8. Solid and stable. 

 

v2.5.1.8 is a minor update and thus may not appear in a auto FW check or Orbi app. Others have seen it appear in the Orbi app. 

 

I manually downloaded it and manually installed it. RBS first, then RBR lastly. Zero issues. Solved a device naming problem in v38 and v40. 

 

Good luck. 


@Sevwren wrote:

So glad I came across this post.  I was just about to decide to pull the trigger and go ahead with a manual update from version V2.3.5.30 to the latest 2.5.1.8 as neither in the web interface nor the orbi app has the feature 'Online Update' returned any updated firmware version info.

 

Recently logging into the gui for my EX3700 WiFi Range Extender showed the  "New update is available".  Now of course that thing seems to be behind by 9 versions of firmware releases however.  

 

 

Def will wait for awhile to go ahead with the V2.3.5.30 update.


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 22 of 41
Highlighted

Re: RBR50 with Firmware 2.5.1.8

I performed the manual update to Firmware v2.5.1.8 and everything except Circle is working fine. I had issues with NETGEAR Circle losing its connection before updating to v2.5.1.8.
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 23 of 41
Highlighted
Guru

Re: RBR50 with Firmware 2.5.1.8

Seen others with Circle issues. I recommend if your needing circle to work, please post about Circle over in the Circle forum:

https://community.netgear.com/t5/Circle-Smart-Parental-Controls/bd-p/en-home-circle

 

Good Luck. 


@coretech51 wrote:
I performed the manual update to Firmware v2.5.1.8 and everything except Circle is working fine. I had issues with NETGEAR Circle losing its connection before updating to v2.5.1.8.

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>Orbi RBK50 v2.5.1.16(Router Mode)
Additional NG HW: C7800/CM1100/CM1200, Orbi CBK40, Orbi RBK50/RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 24 of 41
Highlighted
Apprentice

Re: RBR50 with Firmware 2.5.1.8

Just did a manual update to Satellite and then Router for version 2.5.1.8.  All went smooth.  Things seem to be operating well.  Hopefully it will stay that way!

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 25 of 41