Reply
Highlighted

RBS50 satellite firmware corrupted

HI, I have just bought a new Satelite for my home and it connected once. Then I moved it further from the router, but it didn't connect. Now even if I move it closer the satellite ring flashes white and when I start it, the power button flashes red, then turns green, but the ring light is still flashing white. After looking in the manual, I see that this means the firmware is corrupted. So how do I fix this? Finding tech support on Netgear is impossible. I bought the satellite on Amazon.ca by the way. I'm using a mac if that changes anything on how to do the resetting of the firmware manually is possible.

TIA!

Model: RBS50| Orbi AC3000 Tri-band WiFi (Satellite Only)
Message 1 of 5
Highlighted
NETGEAR Moderator

Re: RBS50 satellite firmware corrupted

Have you tried to factory reset the unit by holding the reset button for 10+ seconds?

 

DarrenM

Message 2 of 5
Highlighted

Re: RBS50 satellite firmware corrupted

Hi Darren, yes I did, with still the same result.

Model: RBS50| Orbi AC3000 Tri-band WiFi (Satellite Only)
Message 3 of 5
NETGEAR Moderator

Re: RBS50 satellite firmware corrupted

I will need to get you in contact with support to work on this please send me a PM with the info below.

 

Name:

Email:

Phone:

Country:

Preferred Contact: Schedule: (Include Dates, Times and Time Zone available to work with us)

Orbi Model:

S/N number:

 

DarrenM

Message 4 of 5
Highlighted

Re: RBS50 satellite firmware corrupted

Thanks Daren, I returned my RBS50 after contacting support. I will not buy another one though as after testing, I wanted to put it too far from my RBK50. 

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 924 views
  • 0 kudos
  • 2 in conversation
Announcements