Reply

Roku Premiere Cannot See Orbi Router

Nthhawke
Aspirant

Roku Premiere Cannot See Orbi Router

I recently purchased a Roku Premiere to replace my now dead Roku Ultra (trying to value engineer rather than paying the full $$$ for the Ultra).

 

Its all up and running fine, but my issue is that when setting up, the network scan is not even seeing my Orbi. The Roku is literally 3 feet away from the Orbi, so its not a distance issue.

 

I know the Roku Premiere does not function on the 5Ghz bandwidth, but I would think it could still see the Orbi and just run at the 2.4Ghz range.

 

I have connected the Roku to my TP Link modem (which is a wifi/modem), but by doing this I cannot use the Roku remote app on my phone as by default I connect this to my Orbi network due to better range and performance (and the app and the ROku need to be on the same wifi network to function).

 

Anyone any ideas or come across this? I cannot think of how to get the Roku to see and connect to the Orbi.

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 1 of 4
FURRYe38
Guru

Re: Roku Premiere Cannot See Orbi Router

What Firmware is currently loaded?

What is the Mfr and model# of the ISP modem the NG router is connected too?

 

Under Advanced Tab/Advanced Settings/Wireless Settings uncheck the Broadcast 5Ghz SSID. Apply. 

What kind of SSID name are you using? Try a simple SSID name to see if the new Roku can see it. 

 

Try setting up the same SSID name on the modem/router as you have on the Orbi temporarily. Then connect the Roku to the modem/router. When it's setup. Turn OFF the wifi on the modem/router and reboot or power cycle the Roku. See if the Roku will connect to the Orbis wifi SSID. 

 

Modem Combo Units:
This would be a double NAT condition which isn't recommended. Couple of options,
1. Configure the modem for transparent bridge mode. Then use the Orbi router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ or IP Pass-Through for the IP address the Orbi router gets from the modem. Then you can use the Orbi router in Router mode.
3. Or disable all wifi radios on the modem and connect the Orbi router to the modem, configure AP mode on the Orbi router. https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point and https://www.youtube.com/watch?v=H7LOcJ8GdDo&app=desktop

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK853 (Router Mode) | and R9000 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 2 of 4
Nthhawke
Aspirant

Re: Roku Premiere Cannot See Orbi Router

Thanks Furry. Those are some ninja level suggestions.

 

I will give them a try and let you know how I get on!

Message 3 of 4
FURRYe38
Guru

Re: Roku Premiere Cannot See Orbi Router

Let us know.. Please give feedback for the question presented as well.

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK853 (Router Mode) | and R9000 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1544 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E