Reply
Highlighted
Tutor

Re: SONOS Compatability with Orbi

I just connected to my orbi today and it works great. Only thing I had to do was attach a connect to the orbi router and start a new setup.
Message 51 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

The problem isn't the router, it's the satellites. I can't connect some things to the router. I have to wire them to the satellite and it is entirely unstable when I do that.

Not sure if it is related to being a two satellite system. But I believe people with one satellite are having the same issues.

If you try connecting something that uses the internet constantly (streaming, game or other thing like that) the satellite regularly drops connectivity and stays broken for several minutes.

Anyway, eero is winning so far. We'll see if it stays that way.

--Derrek

Message 52 of 149
Highlighted
Tutor

Re: SONOS Compatability with Orbi

I've had no problems. Wired directly to router and have 3 Amps all running perfectly and I have the 2.4 band off as well. Like I said, I basically setup the Sonos as a New system once I wired my connect to the Orbi Router. Works all over the house.
Message 53 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

That worked for me as well to fix Sonos (only tested briefly). This thread isn't really a Sonos compatibility thread for me anymore. I'm having problems with *everything* connected via wifi or wired to any satellite (not the router).

Orbi satellites are dropping all connectivity for everything for me. But since most things don't constantly use the network, I didn't notice until Sonos constantly failed (the effected wifi devices would simply jump to the other satellite or router unit which would cause me to miss the fact that a satellite is down). If I connect anything and stream (say apple tv, or sonos, or a gaming system) through a satellite unit (again, not the router unit), I'm plagued with connectivity issues. Example, I had a number of video conferences on my laptop. I was d/c every 3-5 minutes while an orbi satellite unit became unavailable.

This thread should be renamed: "Orbi Satellite units not stable". Sonos was just the thing that helped me discover that. I'm betting if I used only the Orbi router unit, everything would work fine. (It did briefly when I put a speaker in my office to reset it, but I didn't keep it there long enough to test the theory). But that isn't any better than just using my Airport Extreme.

So far, eero is working. But, orbi appeared to work the first day or two as well. So we'll see if this trend continues.

--Derrek

Message 54 of 149
Highlighted
NETGEAR Moderator

Re: SONOS Compatability with Orbi

Hello dieute 

 

If you have tried changing channels and changing the placement of the satellite and still losing connection all the time you may want to contact our support could be a issue with the satellite and they can help resolve the issue. The satellites shouldn't be dropping connection all the time like you are describing.

 

https://www.netgear.com/support/contact.aspx?cid=wmt_netgear_organic

 

DarrenM

Message 55 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

I already did. After several days of basically asking me to reset the units, which I did multiple times, nothing came out of it. So, I gave up and tried other options (eero and google wifi). I just gave up on it pretty quickly and returned the system.

Maybe I got a dud, but from what I'm reading here and elsewhere, it's a common enough problem that it may be widespread.

Message 56 of 149
Highlighted

Re: SONOS Compatability with Orbi

Touchwood, I have no issues and it is running like a charm. I am using Sonos bridge so no issues at all. Hue lights are also working very smooth.

Message 57 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

I spent a few days evaluating eero. I have finally put it back in the box to return tonight.

The end result is it simply isn't worth the price point for a myriad of reasons. I really wanted to like it. It is the most like old apple products that "just work" out of the box. But for $500 I shouldn't be having sonos issues. I shouldn't be experiencing weird networking outages. Etc. During my testing firmware 2.1 came out and may have fixed these issues. But by that time, I was essentially done.

Google wifi is much cheaper and was showing similar capabilities in the end. On top of that, it seemed to always work. I didn't have a single weird networking thing while using Google Wifi (not with my systems or sonos). It also started producing test results in the speed range I wanted (turns out my internet was partly responsible for that on both eero and google). The only real "flaw" is fewer features than eero. I don't need any of those eero features, but they are not present on google wifi (yet). I am giving this as the gift to my mom. It should work very well for her. I will purchase a second pack for myself if orbi doesn't work out (see below).

I continue to like orbi. I am planning on re-buying the orbi 3-pack to test the new firmware (a minor update was released since I had it) and provide debug logs to netgear. I will purchase it at costco which will let me return things months after I purchase them if they aren't working (by the way, costco is amazing. this is not the first time they have been exceptional for me). I even asked at customer service (some exclusions apply, but they were upfront about it). So I don't have to worry about "netgear won't fix it within my return window". I will run my airport extreme network along side on a different channel so I have stable wifi.

Anyway, that's the result of my experiment in "mesh" networking.

--Derrek

Message 58 of 149
Highlighted
Aspirant

Re: SONOS Compatability with Orbi

I've been testing out the google wifi, and so far I'm loving it. No sonos drop outs or other wifi issues. I also really like the android app. I don't need advanced network setup so it works for me. I'm still able to do IP reservations and some other things which is great. Netgear needs to really improve their interface strategy. Limiting to just the web is a very antiquated way of thinking. Changing the font and background color of the web UI does not constitute a new UI. Netgear is just dated.

 

Looks like my orbi will be routed back to best buy.

Message 59 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

I agree. If I had to make a decision today, it's google wifi. Honestly, if I find it in a store today, I might just buy it and be done with this hassle. Give my mom the new one and leave the one I'm testing setup. Good system.
Message 60 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

I finally got around to buying orbi again from costco (my local warehouse had it in stock). I like google wifi, but a few things really sold me on trying orbi again:

 

1) The backhaul. This eliminates all congestion for busy networks.
2) It has 4 ports on every unit (removes the need for mini switches everywhere saving complexity and cost).

3) Star topology. In my case this is a strength, not a weakness. No matter where I am in my house my networking is exactly the same everywhere. No hop penalties or shared backhaul issues.
4) Not so cloud focused that it can't run without the cloud. Meaning local network stays functional even if my internet dies. Yay.

The good news is I have not had internet this stable in months. So far, no sonos issues, no weird other networking issues and no fussing with the units (outside of having to do the manual firmware upgrade).

I believe I had a faulty unit last time. The setup and update process was much much smoother. It came up so fast on the latest firmware that I thought it didn't do the update.

I've only been running it for a day or two. If it stays this way, I'm pretty happy. Orbi for the win.

FYI: I was going to try Velop from linksys, but since the backhaul is inferior, I decided not to.

For me, orbi is worth the premium over Google Wifi (for 3 units). But if I weren't such a demanding user, Google Wifi would be the winner. It is still running superbly at my mom's house. Now when I go there I have internet everywhere. very good. And I manage it for her from here (even turning off the kid's internet access when they visit).

I hope everyone else got their issues resolved.

--Derrek

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 61 of 149
Highlighted

Re: SONOS Compatability with Orbi

Hey Derrek,

 

I have installed Orbi's for freinds and familys in a couple homes with no issues and have loved the powerful backhaul and I still think it's the best consumer grade mesh system avalible, despite the mesh systems popularity rising. I am an IT engineer by trade so troubleshooting is usually pretty simple for me. 

 

My issue is this, and this is how I found your thread. Today I was working on setting up Orbi with Sonos. Everything seemed to be working fine, but trying to setup the Sonos wirelessly with Orbi (Plug in to Orbi temp till it gets creds then remove) everytime I would remove the Sonos bridge from Orbi the Sono would lose connection to the network and make me try and setup Sonos wireless all over again. 

 

So, having little expereicne with Sonos, I decided to just wire in one of the Sonos receivers directly into the Router portion of Orbi and leave it plugged in. Sonos had no issues then, no dropping, stable sound throughout the home. Well then I speedtested back where the satelite was.... which had changed its color to amber which means fair connection between the router and satelite, and now was only pulling 1-25 mb/s of the previous 125 it should have been pulling before Sonos was setup. 

 

I could replicate it that Sonos was indeed interferring with Orbi. Now I am trying to determine if they are truly incomatible, or can be tweaked to work together and that is what I am trying to determine from the feed.

 

The Router and The Satelite are on the latest firmware as of Today. I will try changing the channels this week (Saw that as a possible fix on this thread) to see if it alleviates the issues, but I have little hope. 

 

In your last post it seems you have Orbi and Sonos working fine now? I do not completely understand the point of the Sonos bridge (I do not personally own a Sonos system) and if it is the only device causing the interference. It is not the "boost" just the bridge.

Message 62 of 149
Highlighted
Tutor

Re: SONOS Compatability with Orbi

I have no problems with my Sonos. I have one component wired directly to the main Orbi and all the rest spread throughout the house. It works perfectly, no issues at all.
Message 63 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

Sonos can introduce a number of issues to mesh networking devices. (Technically Orbi is not a "mesh" network, but the same issues apply because of the multiple physical units)

The bridge and boost serve essentially the same purpose, a purpose that was rendered unnecessary by updates to Sonos speakers. In the past, you needed a "base" for all the Sonos speakers to communicate. At some point Sonos enabled connecting directly to your own wifi network in which you plugin the ethernet cable, setup wifi and then unplug the speaker. If this doesn't work, you may have some speakers setup as one sonos network and others as another. I had a brief period where my speakers behaved as two independent Sonos speaker networks. Not sure how or why, but it was temporary as I was re-setting all network stuff.

Some caveats: If any single Sonos device is plugged in via ethernet, all sonos devices will prefer their own wireless network. I would avoid plugging in more than one device via ethernet. This likely creates the networking problems for mesh systems because it is unclear how protocols it uses should behave on a mesh network and each vendor behaves differently.

I only have two Sonos devices: A connect to play through my existing home theater system. I wired this to one of the Orbi's as they sit right next to each other. The other one (a play:1) connects over the built-in sonosnet created by the connect. This has worked essentially flawlessly on my replacement Orbi. No bridge, no boost, nothing else.

This all assumes you are on Sonos 7.1 (or whatever the latest released firmware).

Option 1: If one of the speakers (not bridge) is near the Orbi, use that one to plug-in to the Orbi and *only* that one. Then setup all speakers elsewhere and leave the bridge out of the picture (not needed). Finally, make sure the Sonosnet channel is opposite the 2.4ghz channel used by Orbi. I put Sonos on channel 11 because 1 was being used by Orbi (I believe that is Orbi's default). Easily done in Sonos app.

Option 2: If no speaker is near an Orbi, then put the bridge near the orbi, plug it in via ethernet, and only it (no other speakers via ethernet). Again, make sure the Sonos channel is opposite Orbi.

Option 3: The final option is to connect *all* speakers through Orbi wifi only. All Sonos devices must remain on wifi only and not wired. If anything is wired, it will flip to SonosNet usage. This works great at my mom's house where google wifi blankets the house in solid wifi and no Sonos device is near a wifi mesh point. But the SonosNet will often work better with interference.

The only reason Sonosnet wouldn't work is if the distances are too large for it to handle. This would be mansion size house like 10,000+ square feet between Sonos devices. This is where the Boost would become useful (the bridge could be used in this case as well). It is unlikely your own wifi will do better than sonosnet with boost/bridge devices.

The only downside to this (and what triggered me returning my first orbi) is if the satellite that the single wired Sonos is connected to starts misbehaving, all Sonos speakers will stop working. The wi-fi way, sometimes only the units connected to that satellite would stop. They might even switch to a functional satellite wifi signal.

I have not seen any of these issues in any Sonos configuration on the new Orbi. It's been working wonderfully daily.

--Derrek

Message 64 of 149
Highlighted
Master

Re: SONOS Compatability with Orbi

@Dynamiteboy I have 9 Sonos components working flawlessly with Orbi. I would recommend you DO NOT connect the Sonos components to WiFi.  I would instead use the "sonosnet" configuration. This is what Derrek described.

 

Just plug one, and only one, Sonos component into the router, or into any hardired connection on the LAN. Sonos will setup it's own invisible mesh network on 2.4 Ghz. You can choose the channel space (1, 6, or 11) via the Sonos Controller App. You need to make sure Orbi and Sonos use different channel spaces.  If Orbi uses 40 MHz on the 2.4 band you will only have two choices...  Put the orbi on Channel 1 and Sonos on channel 11, or vice versa. I have Orbi on 1 and Sonos on 11.

 

Once it's setup, Sonos will dynamically compute routes through the mesh network so that all components are connected, even if you move comonents.  For the mesh to work, the Sonos components have to be close enough to establish a path, but they have decent range.

 

The Bridge simply functions as an additional node on the mesh network.  The bridge can be the ONE Sonos unit hardwired to the LAN.  Or, if another coponent is hardwired, one or more bridges can be plugged into an AC outlet anywhere to provide more nodes in the mesh network, for additional coverage. You can also plug wired devices into the Bridge to give them access to the LAN. I have two bridges in use--one at the router, and another on the other end of the house.

Message 65 of 149
Highlighted

Re: SONOS Compatability with Orbi

I am using Sonos bridge which is set on channel 11 and I have got two Sonos speakers on wifi. I never had any issues on Orbi network with Sonos. 

Message 66 of 149
Highlighted

Re: SONOS Compatability with Orbi

Thanks everyone for the replies. 

 

I was experiencing these issues with the Orbi speed when I had the non-bridge plugged in. In the house there was a "bridge unit" and then each speaker had its own white receiver box? Am I understanding this right? They had multiple Connect amp receivers, that is what I plugged the Orbi router portion into and expereinced the signal drops and speed issues even when it was left plugged in. I am unsure if this is the "Sonosnet setup". I also experience the speed drops when I wired in the wireless bridge to the orbi router portion.

 

Disclaimer, this sonos setup was supposedly setup by a professional awhile ago, but there are so many connect amps, that I am confused what they are all for.

 

Anyways, I can clearly replicate the problem by hooking up the sonos to the Orbi router portion. Then when I remove the sonos amp portion, and restart Orbi, the speed goes back up and the satelite does not get a amber "fair connection" light. 

 

The Orbi firmware is up to date, and I never wired more than 1 Sonos unit into the Router portion of Orbi.

 

So my problem really can only be 3 things from what I am hearing from you guys. 

 

  1. The Sonos Firmware is not update (didn't even think to check that)
  2. The Channels are interfereing and I need to set Orbi to 11 and Sonos to 1
  3. I have a defective Orbi unit, which I just feel is highly unliekly as it works flawlessly without Sonos involved.

Or maybe I need to purchase one of the new "Boost Units" and set it up that way? I don't understand how the bridge is different from it though.

 

I am not limited to any specific sort of "Wireless only" setup, I could find a way to wire any sonos piece to ethernet because the house is wired with network drops.

 

 

Message 67 of 149
Highlighted

Re: SONOS Compatability with Orbi

Sorry, I am not sure what is happening in your setup. I can explain my setup.

I have one Sonos bridge which connected to my switch with ethernet cable on the ground floor. This bridge is sending wifi signal in whole house. So when I setup new speaker, it connects to this bridge via wifi but on its own channel to the bridge. I hope this make any sense?

Message 68 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

First, make sure your Orbi Router and Satellites are all on the same current firmware. Early Orbi's refused to update the satellites automatically. You had to do it manually.

Second, make sure all Sonos devices are up to date.

Third - I want to clear up your understanding of the different Sonos pieces:

Play:1/Play: 3/Play:5/Subwoofer/Other Speaker - These are all speakers, they are configured to either use the sonos network (which they will if *any* Sonos product is wired via ethernet to any Orbi) Or you can configure all of them to use Orbi network directly. As many of us have said, we prefer to wire a single Sonos device and have it be the source of SonosNet on channel 11. All speakers re-broadcast sonosnet if that is what you are using.

Connect/Connect:AMP - These join sonosnet but do not have speakers built-in. The connect is designed to link to a home theater reciever (usually via optical or digital coax). The Connect:AMP can connect to raw speaker wires as it has an amp built-in. Both act like speakers in that they will join a Sonosnet if available, or can be configured to join Orbi Wifi. Same as speakers, it will re-broadcast Sonosnet.

Bridge/Boost - These are effectively Sonosnet repeaters. They take the Sonosnet signal and re-broadcast it (or create it, if they are the wired sonos device). If you are using a Wifi only setup, these are useless. If any speaker can be wired via ethernet, it will serve the purpose of one of these and create your sonosnet. The only real reason to use one is if you want to use Sonosnet (and we think you do) and none of the speakers are within range of an Orbi. In that case, plug one in at the orbi and let all other speakers link to that Sonosnet. Boost is just a newer version of the bridge, better antennas. Only necessary if you are having Sonosnet range issues. You likely don't need these at all if you can wire any other Sonos device.

The issue is that Orbi speed drops when Sonos is connected? I would suggest that multiple Sonos products are wired and a network loop is being created. Make sure only one is wired and all sonos devices are configured for the same speaker collection. If you are using Sonosnet, I would re-configure the Sonos units to not know the Orbi network or password password (In thi iOS App Settings -> Advanced Settings -> Wireless Setup (if it is already asking for you to type something push done and then push the reset button which will remove wireless info from Sonos). Then there is no chance they are hopping back and forth. Also make sure the wired Sonos device always has power.

--Derrek

Message 69 of 149
Highlighted

Re: SONOS Compatability with Orbi

I can confirm that I manaully updated both the Satelite and the Orbi Router to the latest firmware. But I have no idea if Sonos is using the latest Firmware and will have to check on that.

 

Yeah I am not sure why there are so many white amps (5 in total I beleive) so I will have to see if they are running to a speaker system or just not really doing anything at all. I was wiring one of these amps into the Orbi Router portion which would work for a little bit but then Orbi would go a bit haywire.

 

So What I will do is just:

 

  • Ensure Sonos is on the latest firmware
  • Wire in the Sonos Bridge (Not the Connect Amp) directly into the Orbi Router
  • Remove the possible Wifi Creds from the Sonos system
  • Ensure no other Sonos device is wired into a network drop on the wall or something
  • Set Sonosnet to Channel 11 (Where can I do this?)
  • Restart Orbi

Is there anything I should do to reset the Sonos system or individual devices to ensure it is using the "Boost" configuration and not the standard?

 

Also, does the bridge have any relevance if its ethernet is not plugged into anything? (This is how I found it) Does it like wirelessly boost the Sonosnet signal? I think a lot of my confusion stems from Sonos making their devices communicate directly with eachother as of an update or something like you said.

 

 

Best,

Jonathan

 

 

Message 70 of 149
Highlighted
Master

Re: SONOS Compatability with Orbi

@Dynamiteboy You need to make sure only one Sonos component is plugged into the LAN, not just into the Orbi. You cannot have a second Sonos plugged into ANY Ethernet drop anywhere. You definitely need to set the channels to 1 and 11. You might need to reset the Sonos system and start from scratch to ensure everything is setup properly. You shouldn't need a Boost. It's nothing more than a bridge with more powerful wifi hardware.

 

Another option is to hardwire every single Sonos and disable their radios. This requires accessing some undocumented web pages though.

Message 71 of 149
Highlighted
Apprentice

Re: SONOS Compatability with Orbi

In the sonos app settings -> advanced settings -> sonosnet channel.

Very easy. Try and avoid a full sonos reset as that will cause any favorites and account access to be removed. Removing the wireless settings should be enough.

Settings -> about my sonos system should show all connected speakers with WM: 0 and Version: 7.1 (build ......)

Try it out. Let us know how it goes!

--Derrek

Message 72 of 149
Highlighted

Re: SONOS Compatability with Orbi

You can use Controller app on your Windows machine. In Controller app, select Manage and then Settings to check the channel. Under Manage you can see lots of options e.g add new bridge/boost etc.

Message 73 of 149
Highlighted
Master

Re: SONOS Compatability with Orbi


@Dynamiteboy wrote:

does the bridge have any relevance if its ethernet is not plugged into anything? (This is how I found it) Does it like wirelessly boost the Sonosnet signal? I think a lot of my confusion stems from Sonos making their devices communicate directly with eachother as of an update or something like you said.

 

 


As I wrote above, when plugged into AC power only, the bridge expands the Sonos mesh network for better coverage. It does not boost the signal, it provides another node in the mesh network. Mesh means node A and C can communicate by talking through node B in the middle. Like stepping stones. 

Message 74 of 149
Highlighted

Re: SONOS Compatability with Orbi

Perfect thank you for your input, I will update with what happens later this week. My step-by-step looks correct then right?

 

Best,

Jonathan

Message 75 of 149
Top Contributors
Discussion stats
Announcements