Reply
Highlighted

Satellite solid white light after beta firmware update

Hey everyone...my orbi system did the firmware update ( beta firmware V2) the router updated and works just fine but the satellite just has a solid white light and is unresponsive.  Whenever I look in the settings my satellite isn't even showing up... I'm afraid my satellite got bricked of this new update? I tried doing a hard reset and nothing has worked.. can someone please help? any advise much appreciated..thanks in advance...

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 2
Highlighted

Re: Satellite solid white light after beta firmware update

Nevermind...my satellite was indeed bricked by the beta firmware update.  First time one of my devices has ever been bricked Smiley Sad.......not sure how it happened but my quess is that I should have moved the satellite closer to the main router before attempting to let the firmware update.  Kudos to Netgear support though; I called them early this morning and even though my 90 day complimentary support had expired they went ahead and tried to help me anyways.  In the end,  I end up having to do an RMA and will receive a new satellite unit for free since my hardware warranty was good for another 6 months.  All I had to pay was shipping.... will get the new unit tomorrow and hope everything works.......my orbi router is working fine though and I really like some of the improvements they have made!  Good job Netgear!

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 337 views
  • 0 kudos
  • 1 in conversation
Announcements